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Welcome
Thank you for purchasing a Teledyne LeCroy WaveRunner oscilloscope. We're certain you'll be
pleased with the detailed features unique to our instruments.

The manual is arranged in the following manner:

l Safety contains important precautions and information relating to power and cooling.

l Oscilloscope Overview through Maintenance cover everything you need to know about the
operation and care of the instrument.

Documentation for using software options is available from the Teledyne LeCroy website at
teledynelecroy.com. Our website maintains the most current product specifications and should be
checked for frequent updates.

Take a moment to verify that all items on the packing list or invoice copy have been shipped to you.
Contact your nearest Teledyne LeCroy customer service center or national distributor if anything is
missing or damaged. We can only be responsible for replacement if you contact us immediately.

We truly hope you enjoy using Teledyne LeCroy's fine products.

Sincerely,

David C. Graef

Vice President and General Manager, Oscilloscopes
Teledyne LeCroy

x



Safety

Safety
To maintain the instrument in a correct and safe condition, observe generally accepted safety
procedures in addition to the precautions specified in this section. The overall safety of any system
incorporating this product is the responsibility of the assembler of the system.

Symbols
These symbols appear on the instrument or in documentation to alert you to important safety
considerations:

Caution of potential damage to instrument or Warning of potential bodily injury. Refer to the
accompanying information. Do not proceed until the information is fully understood and conditions
are met.

Caution, high voltage; risk of electric shock or burn.

Caution, contains parts/assemblies susceptible to damage by Electrostatic Discharge (ESD).

Frame or chassis terminal (ground connection).

Alternating current.

Standby power (front of instrument).

Precautions

Caution: Comply with the following instructions to avoid personal injury or damage to your
equipment.

Use indoors only within the operational environment listed. Do not use in wet or explosive
atmospheres.

Maintain ground. This product is grounded through the power cord grounding conductor. To avoid
electric shock, connect only to a grounded mating outlet.

Connect and disconnect properly. Do not connect/disconnect probes, test leads, or cables while they
are connected to a live voltage source.

Observe all terminal ratings. Do not apply a voltage to any input that exceeds the maximum rating of
that input. Refer to the front of the instrument for maximum input ratings.

Use only power cord shipped with this instrument and certified for the country of use.

Keep product surfaces clean and dry. See Cleaning.

Do not remove the covers or inside parts. Refer all maintenance to qualified service personnel.
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Execise care when lifting. Use the built-in carrying handle.

Do not operate with suspected failures. Do not use the product if any part is damaged. Obviously
incorrect measurement behaviors (such as failure to calibrate) might indicate impairment due to
hazardous live electrical quantities. Cease operation immediately and sequester the instrument from
inadvertent use.

Operating Environment
Temperature: 5 to 40° C.

Humidity: Maximum relative humidity 90 % for temperatures up to 31° C, decreasing linearly to 50%
relative humidity at 40° C.

Altitude: Up to 3,000 m at or below 30° C.

Cooling
The instrument relies on forced air cooling with internal fans and vents. Take care to avoid restricting
the airflow to any part. In a benchtop configuration, leave a minimum of 15 cm (6 inches) around the
sides between the instrument and the nearest object. The feet provide adequate bottom clearance.
Follow rackmount instructions for proper rack spacing.

Caution: Do not block the cooling vents.

The instrument also has internal fan control circuitry that regulates the fan speed based on the
ambient temperature. This is performed automatically after start-up.

Calibration
The oscilloscope is calibrated at the factory prior to being shipped. The recommended calibration
interval is one year. Calibration should be performed by qualified personnel only.

Schedule an annual factory calibration as part of your regular maintenance. Extended warranty,
calibration, and upgrade plans are available for purchase. Contact your Teledyne LeCroy sales
representative or customersupport@teledynelecroy.com to purchase a service plan.

The oscilloscope software includes both automatic and user-initiated calibration functions. See
Calibration Preferences.

Caution: Remove all inputs prior to performing calibration.

Cleaning
Clean only the exterior of the instrument using a soft cloth moistened with water or an isopropyl
alcohol solution. Do not use harsh chemicals or abrasive elements. Under no circumstances
submerge the instrument or allow moisture to penetrate it. Dry the instrument thoroughly before
connecting a live voltage source.

2



Safety

Caution: Unplug the power cord from the AC inlet before cleaning to avoid electric shock. Do
not attempt to clean internal parts. Refer all maintenance to qualified service personnel.

Power

AC Power
The instrument operates from a single-phase, 100-240 Vrms (± 10%) AC power source at 50/60 Hz (±
5%) or a 100-120 Vrms (± 10%) AC power source at 400 Hz (± 5%). Manual voltage selection is not
required because the instrument automatically adapts to the line voltage.

Power Consumption
Maximum power consumption with all accessories installed (e.g., active probes, USB peripherals,
digital leadset) is 375 W (375 VA) for non-"M" models and 500 W (500 VA) for "M" models. Power
consumption in Standby mode (all models) is 15 W.

Ground
The AC inlet ground is connected directly to the frame of the instrument. For adequate protection
again electric shock, connect to a mating outlet with a safety ground contact.

Caution: Only use the power cord provided with your instrument. Interrupting the protective
conductor (inside or outside the case), or disconnecting the safety ground terminal, creates a
hazardous situation. Intentional interruption is prohibited.
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Oscilloscope Overview
Front of Oscilloscope

A. Touch screen display

B. Front panel

C. Built-in stylus holder

D. Power button

E. Channel inputs (C1-C4)

F. Ext input

G. Aux output

H. USB 2.0 port

I. Mixed-Signal Interface

J. Ground and Calibration output terminals

K. Tilting feet

4



Oscilloscope Overview

Side of Oscilloscope
A. USB 2.0 ports (2)

B. Ethernet port for connecting to
LAN or remote control

C. DisplayPort ports (2) for
connecting external monitor

D. USB 3.1 ports (4)

E. DVI port for external monitor

F. Audio In/Out (mic, speaker,
and line-in) for connecting
external audio devices

G. USBTMC port for remote
control

5
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Back of Oscilloscope

A. Built-in carrying handle

B. Ref Out and Ref In for external reference clock

C. AC power inlet

D. Kensington lock

6



Oscilloscope Overview

Front Panel
Most front panel controls duplicate functionality also available
through the touch screen display.

All the knobs on the front panel function one way if turned and
another if pushed like a button. The first label describes the
knob’s principal “turn” action, and the second label describes
its “push” action.

Front panel buttons light up to indicate which traces and
functions are active. Actions performed from the front panel
always apply to the active trace.

Trigger Controls
The front panel Level knob changes the trigger threshold level
(V). The number is shown on the Trigger descriptor box.
Pushing the knob sets the trigger level to the 50% point of the
input signal.

The READY indicator is lit when the trigger is armed. TRIG'D is
lit momentarily when a trigger occurs. A fast trigger rate
causes the light to stay lit continuously.

Setup opens the Trigger Setup dialog. Press it again to close
the dialog.

Auto sets Auto mode, which triggers the oscilloscope after a
set time, even if the trigger conditions are not met.

Normal sets Normal mode, which triggers the oscilloscope each time a signal is present that meets
the trigger conditions.

Single sets Single mode, which arms the oscilloscope to trigger once (single-shot acquisition) when
the input signal meets the trigger conditions. If the trigger is armed, it will force it to fire.

Stop prevents the scope from triggering on a signal. If you boot up the instrument with the trigger in
Stop mode, a "No trace available" message is shown. Press the Auto button to display a trace.

Horizontal Controls
Turn the Delay knob to change the Trigger Delay value (S). Push the knob to reset Delay to zero.

If the trace source is an input channel, turn the Horizontal Adjust knob to set the Time/division (S) of
the oscilloscope acquisition system. The value is shown on the Timebase descriptor box. When using
this control, the oscilloscope allocates memory as needed to maintain the highest sample rate
possible for the timebase setting. If the trace source is a zoom, memory or math function, turn the
knob to change the horizontal scale of the trace, effectively "zooming" in or out. The value is shown
on the corresponding descriptor box. Push the knob to change the setting in fine increments; push it
again to return to 1, 2, 5, 10-step increments.
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Vertical Controls
The front panel Channel buttons (1-4) turn on a channel that is off, or activate a channel that is
already on. When the channel is active, pushing its channel button turns it off. A lit button shows the
active channel (in this image, C1 is lit).

Offset knob adjusts the zero level of the trace (this makes it appear to move up or down relative to
the center axis of the grid). The value appears on the trace descriptor box. Push it to reset Offset to
zero.

Gain knob sets Vertical Gain (V/div). The value appears on the trace descriptor box. Push it once to
adjust V/div in fine increments; push it again to adjust in 1, 2, 5, 10-step increments.

Dig button enables digital input on -MS models.

Math, Zoom, and Mem Buttons
The front panel Zoom button creates a quick zoom of each open channel trace. The resulting zoom
traces are 1/10 of the channel timebase and centered on the display. Touch the zoom trace
descriptor box to display the zoom controls and adjust this. Touch the Zoom button again to turn off
the zooms.

The Math and Mem(ory) buttons open the corresponding setup dialogs.

Cursor Controls
Cursors identify specific voltage and time values on the waveform. The white cursor markers help
make these points more visible, as well as provide a simple way to reposition them. A readout of the
values appears on the trace descriptor box.

There are five preset cursor types, each with a unique appearance on the display. These are
described in more detail in the Cursors section.

Press the front panel Type button to apply or remove cursors. Continue pressing to cycle through all
cursor types until the desired type is found ("no cursors" will appear in the cycle).

Turn the Cursor knob to reposition the selected cursor line. Push it to select a different cursor line to
adjust.

Adjust & Intensity
The front panel Adjust knob changes the value in active (highlighted) data entry fields that do not
have dedicated knobs. Pushing Adjust toggles between coarse (large increment) or fine (small
increment) adjustments when the knob is turned.

The Intensity button sets the Adjust knob to control the trace intensity. When more data is available
than can actually be displayed, the Intensity button helps to visualize significant events by applying
an algorithm that dims less frequently occurring samples. This feature can also be accessed from
the Display Setup dialog.

8



Oscilloscope Overview

Miscellaneous Controls
These miscellaneous controls also appear along the top and bottom rows of the front panel.

Auto Setup performs an Auto Setup. After the first press, you will be prompted for a confirmation.
Press the button again or use the touch screen to confirm.

Default Setup resets the oscilloscope to the factory default configuration. After the first press, you
will be prompted for a confirmation. Press the button again or use the touch screen to confirm.

Print captures the entire screen and outputs it according to your Hardcopy settings.

Touch Screen toggles on/off touch screen functionality.

Clear Sweeps resets the acquisition counter and any cumulative measurements.

Decode opens the Serial Decode dialog if you have serial data decoder options installed.

WaveScan opens the WaveScan dialog.

Spectrum opens the Spectrum Analyzer dialog if you have that option installed.

History opens the History Mode dialog.

9
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Signal Interfaces
The instrument offers a variety of interfaces for using probes or other devices to input analog or
digital signals.

See the product page at teledynelecroy.com for a list of compatible devices.

Analog Inputs
A series of connectors arranged on the front of the instrument are used to input analog signals on
channels 1-4. EXT can be used to input an external trigger pulse or sample clock signal.

WaveRunner 8000 channel connectors use the ProBus interface. The ProBus interface contains a 6-
pin power and communication connection and a BNC signal connection to the probe. It includes
sense rings for detecting passive probes and accepts a BNC cable connected directly to it. ProBus
offers 50 Ω and 1 MΩ input impedance and control for a wide range of probes.

The channel interfaces power probes and completely integrate the probe with the channel. Upon
connection, the probe type is recognized and some setup information, such as input coupling and
attenuation, is performed automatically. This information is displayed on the Probe Dialog, behind the
Channel (Cx) dialog. System (probe plus instrument) gain settings are automatically calculated and
displayed based on the probe attenuation.

Probes
The oscilloscope is compatible with the included passive probes and most Teledyne LeCroy ProBus
active probes that are rated for the instrument’s bandwidth. Probe specifications and documentation
are available at teledynelecroy.com/probes.

Passive Probes
The passive probes supplied are matched to the input impedance of the instrument but may need
further compensation. If using other passive probes, be sure to perform a low frequency calibration
using the Cal signal available from the front panel before using them to measure signal. Follow the
directions in the probe instruction manual to compensate the frequency response of the probes.

Active Probes
Most active probes match probe to oscilloscope response automatically using probe response data
stored in an on-board EEPROM. This ensures the best possible combined probe plus oscilloscope
channel frequency response without the need to perform any de-embedding procedure.

Be aware that many active probes require a minimum oscilloscope firmware version to be fully
operational. See the probe documentation.

10
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Oscilloscope Overview

Digital Leadset

The digital leadset enables input of up-to-16
lines of digital data. Lines can be organized into
four logical groups and renamed appropriately.

The digital leadset features two digital banks
with separate Threshold controls, making it
possible to simultaneously view data from
different logic families.

Connecting/Disconnecting the Leadset
To connect the leadset to the instrument, push the connector into the Mixed Signal interface below
the front panel until you hear a click.

To remove the leadset, press and hold the buttons on each side of the connector, then pull out to
release.

Grounding Leads
Each flying lead has a signal and a ground connection. A variety of ground extenders and flying ground
leads are available for different probing needs.

To achieve optimal signal integrity, connect the ground at the tip of the flying lead for each input used
in your measurements. Use either the provided ground extenders or ground flying leads to make the
ground connection.

11
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Oscilloscope Set Up
Powering On/Off

Press the Power button to turn on the instrument. The X-Stream application loads automatically
when you use the Power button.

Caution: Do not change the instrument’s Windows® Power Options setting from the default
Never to System Standby or System Hibernate. Doing so can cause the system to fail.

Caution: Do not power on or calibrate with a signal attached.

Use the File > Shutdown menu bar option to switch "off". Pressing Power again will execute a
shutdown, but we do not recommend doing this because it does not allow the Windows operating
system to shut down properly, and memories and setup panels will not be saved. Never power off by
pulling the power cord from the socket or shutting off a connected power strip.

The Power button does not disconnect the instrument from the AC power supply. The only way to fully
power down the instrument is to unplug the AC power cord.

We recommend unplugging the instrument if it will remain unused for a long period of time.

Software Activation
The operating software (firmware and standard applications) is active upon delivery. At power-up, the
instrument loads the software automatically.

Firmware
Free firmware updates are available periodically from the Teledyne LeCroy website at:

teledynelecroy.com/support/softwaredownload

Registered users can receive an email notification when a new update is released. Follow the
instructions on the website to download and install the software.

Purchased Options
If you decide to purchase an option, you will receive a license key via email that activates the optional
features. See Options for instructions on activating optional software packages.

12
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Oscilloscope Set Up

Connecting to Other Devices/Systems
Make all desired cable connections. After start up, configure the connections using the menu options
listed below. More detailed instructions are provided later in this manual.

LAN
The instrument accepts DHCP network addressing. Connect a cable from the Ethernet port on the
side panel to a network access device.

To assign a static IP address, go to Utilities > Utilities Setup > Remote and choose Net Connections
from the Remote dialog. Use the standard Windows networking dialogs to configure the device
address.

Go to Utilities > Preference Setup > Email to configure email settings.

USB Peripherals
Connect the device to a USB port on the front or of the instrument.

Printer
The supports USB printers compatible with the instrument's Windows OS. Go to Utilities > Utilities
Setup > Hardcopy to configure printer settings.

External Monitor
You may operate the instrument using the built-in touch screen or attach an external monitor for
extended desktop operation. A properly configured external touch-screen monitor will take on all the
touch-screen capabilities of the internal display.

Note: The oscilloscope display utilizes Fujitsu touch-screen drivers. Because of conflicts,
external monitors with Fujitsu drivers can not be used to control the system, only as displays.

The WaveRunner 8000 supports WQXGA monitors with 2560x1600 resolution.

Connect the monitor cable to the DisplayPort connector on the side of the instrument (you can use an
adaptor if the monitor cable has a different interface). Monitors with DVI-D interfaces are also
supported. Minimize the X-Stream application and use the Windows controls to configure the display.
Configure the instrument as the primary monitor and be sure to extend, not duplicate, the display.

Remote Control
Go to Utilities > Preference Setup > Remote to configure remote control. Connect the devices using
the cable type required by your selection. TCP/IP over Ethernet is generally supported, as is USB over
the USBTMC connection. GPIB is also supported with the correct hardware option installed.

13
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Sample Clock
To input an external sample clock signal, connect a BNC cable from the EXT input to the other device.
Go to Timebase > Horizontal Setup > Clock Source to configure the clock.

Reference Clock
To either input or output a reference clock signal, connect a BNC cable from the Ref In or Ref Out
connector to the other instrument. Go to Timebase > Horizontal Setup > Clock Source to configure the
clock.

Auxilliary Output
To output signal from the instrument to another device, connect a BNC cable from Aux Out to the
other device. Go to Utilities > Utilities Setup > Aux Output to configure the output.

Language Selection
To change the language that appears on the touch screen:

1. Go to Utilities > Preference Setup > Preferences and make a Language selection.

2. Follow the prompt to restart the application.

To also change the language of the Windows operating system dialogs:

1. Choose File > Minimize to hide X-Stream and show the Windows Desktop.

2. From the Windows task bar, choose Start > Control Panel > Clock, Language and Region.

3. Under Region and Language select Change Display Language.

4. Touch the Install/Uninstall Languages button.

5. Select Install Language and Browse Computer or Network.

6. Touch the Browse button, navigate to D:\Lang Packs\ and select the language you want to
install. The available languages are: German, Spanish, French, Italian, and Japanese. Follow
the installer prompts.

7. Reboot after changing the language.

Note: Other language packs are available from Microsoft’s website.

14



Using MAUI

Using MAUI
MAUI, the Most Advanced User Interface, is Teledyne LeCroy's unique oscilloscope user interface.

MAUI is designed for touch—all important controls for vertical, horizontal, and trigger are only one
touch away.

But MAUI is also flexible, allowing you to perform many operations from either the touch screen or the
front panel, or a mix of both.

MAUI seamlessly integrates every software option into the same oscilloscope application, creating a
unified toolset as deep and broad as you need.

X-Stream Application Window
X-Stream (the base oscilloscope application) runs on a Windows operating system and functions
exactly as do other Windows applications.

To minimize the application window and show the Windows desktop, touch the minimize button or
choose File > Minimize. To restore the window after minimizing, touch the display icon in the lower
right corner of the desktop.

To exit the application window, choose File > Exit. When you exit the application, the operating
system continues to run. To reload the application after exiting, touch the Start DSO desktop
shortcut.

Touch Screen
The touch screen is the principal viewing and control center. The entire display area is active: use
your finger or a stylus to touch, drag, swipe, or draw a selection box. Many controls that display
information also work as “buttons” to access other functions.

If you have a mouse installed, you can click anywhere you can touch to activate a control; in fact, you
can alternate between clicking and touching, whichever is convenient for you.

The touch screen is divided into the following major control groups:

l Menu bar

l Grid area

l Descriptor boxes

l Dialogs

15
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Menu Bar
The top of the window contains a complete menu of functions. Making a selection here changes the
dialogs displayed at the bottom of the screen.

While many common operations can also be performed from the front panel or launched via the
descriptor boxes, the menu bar is the best way to access dialogs for Save/Recall (File) functions,
Display functions, Status, LabNotebook, Pass/Fail setup, and Utilities/Preferences setup.

You will see a Q-Scape control added to the menu bar when the Q-Scape option is
installed. This allows you to choose different tabbed display configurations. See Display.

If an action can be “undone”, a small Undo button appears at the far right of the menu bar. Click
this to return to the previous display.

Grid Area
The grid area displays the waveform traces. Every grid is 8 Vertical divisions representing 256
Vertical levels and 10 Horizontal divisions. The value represented by Vertical and Horizontal divisions
depends on the Vertical and Horizontal scale of the traces that appear on the grid.

The grid area can be divided into multiple grids showing different types and numbers of traces (by
default, it will divide automatically as needed up to 16 times). Regardless of the number and
orientation of grids, every grid always represents the same number of Vertical levels. Therefore,
absolute Vertical measurement precision is maintained.

You can adjust the brightness of the grid lines. Go to Display > Display Setup and enter a new Grid
Intensity percentage. The higher the number, the brighter and bolder the grid lines.

16



Using MAUI

Different types of traces opening in a multi-grid display.

Q-Scape Tabs
On instruments with the Q-Scape option installed, Tabs 1-4 appear along the top of the grid area. Each
tab is a distinct multi-grid display. See Display for more information about using Q-Scape.

Grid Indicators
These indicators appear around or on the grid to mark important points on the display. They are
matched to the color of the trace to which they apply. When multiple traces appear on the same grid,
indicators refer to the foreground trace—the one that appears on top of the others.

Axis labels mark the times/units represented by a grid division. They update dynamically as you pan the trace or
change the Vertical/Horizontal scale. Originally shown in absolute values, the labels change to show delta from 0
(center) when the number of significant digits grows too large. The number of labels that appear on each grid
depends on the total number of grids open. To remove them, go to Display > Display Setup and deselect Axis
Labels.

Trigger Time, a small triangle along the bottom (horizontal) edge of the grid, shows the time of the trigger. Unless
Horizontal Delay is set, this indicator is at the zero (center) point of the grid. Delay time is shown at the top right of
the Timebase descriptor box.

Pre/Post-trigger Delay, a small arrow to the bottom left or right of the grid, indicates that a pre- or post-trigger
Delay has shifted the Trigger Position indicator to a point in time not displayed on the grid. All Delay values are
shown on the Timebase Descriptor Box.

Trigger Level at the right edge of the grid tracks the trigger voltage level. If you change the trigger level when in
Stop trigger mode, or in Normal or Single mode without a valid trigger, a hollow triangle of the same color
appears at the new trigger level. The trigger level indicator is not shown if the triggering channel is not displayed.

Zero Volts Level is located at the left edge of the grid. One appears for each open trace on the grid, sharing the
number and color of the trace.

Cursor markers appear over the grid to indicate specific voltage and time values on the waveform. Drag-and-
drop cursor markers to quickly reposition them.
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Descriptor Boxes
Trace descriptor boxes appear just beneath the grid whenever a trace is turned on. They function to:

l Inform—descriptors summarize the current trace settings and its activity status.

l Navigate—touch the descriptor box once to activate the trace, a second time to open the trace
setup dialog.

l Arrange—drag-and-drop descriptor boxes to move traces among grids.

l Configure—drag-and-drop descriptor boxes to change source or copy setups.

Besides trace descriptor boxes, there are also Timebase and Trigger descriptor boxes summarizing
the acquisition settings shared by all channels, which also open the corresponding setup dialogs.

Channel Descriptor Box
Channel trace descriptor boxes correspond to analog signal inputs. They show
(clockwise from top left): Channel Number, Pre-processing list, Coupling, Vertical
Scale (gain) setting, Vertical Offset setting, Sweeps Count (when averaging),
Vertical Cursor positions, and Number of Segments (when in Sequence mode).

Codes are used to indicate pre-processing that has been applied to the input. The
short form is used when several processes are in effect.

Pre-processing Symbols on Descriptor Boxes

Pre-Processing Type Long Form Short Form

Sin X Interpolation SINX S

Averaging AVG A

Inversion INV I

Deskew DSQ DQ

Coupling DC50, DC1M, AC1M or GND D50, D1, A1 or G

Bandwidth Limiting BWL B

Other Trace Descriptor Boxes
Similar descriptor boxes appear for math (Fx), zoom (Zx), and memory (Mx) traces. These descriptor
boxes show any Horizontal scaling that differs from the signal timebase. Units will be automatically
adjusted for the type of trace.
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Trace Context Menu
Touch and hold ("right-click") on the trace descriptor box until a white circle appears to open the trace
context menu, a pop-up menu of actions to apply to the trace such as turn off, move to next grid or
label.

Timebase and Trigger Descriptor Boxes
The Timebase descriptor box shows: (clockwise from top right) Horizontal Delay, Time/div, Sample
Rate, Number of Samples, and Sampling Mode (blank when in real-time mode).

Trigger descriptor box shows: (clockwise from top right) Trigger Source and Coupling, Trigger Level
(V), Slope, Trigger Type, Trigger Mode.

Horizontal (time) cursor readout, including the time between cursors and the frequency, is shown
beneath the TimeBase and Trigger descriptor boxes. See the Cursors section for more information.

Dialogs
Dialogs appear at the bottom of the display for entering setup data. The top dialog will be the main
entry point for the selected functionality. For convenience, related dialogs appear as a series of tabs
behind the main dialog. Touch the tab to open the dialog.
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Right-Hand Subdialogs
At times, your selections will require more settings than can fit on one dialog, or the task commonly
invites further action, such as zooming a new trace. In that case, subdialogs will appear to the right of
the dialog. These subdialog settings always apply to the object that is being configured on the left-
hand dialog.

Action Toolbar
Several setup dialogs contain a toolbar at the bottom of the dialog. These buttons enable you to
perform commonplace tasks—such as turning on a measurement—without having to leave the
underlying dialog. Toolbar actions always apply to the active trace.

Measure opens the Measure pop-up to set measurement parameters on the active trace.

Zoom creates a zoom trace of the active trace.

Math opens the Math pop-up to apply math functions to the active trace and create a new math trace.

Decode opens the main Serial Decode dialog where you configure and apply serial data decoders and
triggers. This button is only active if you have serial data software options installed.

Store loads the active trace into the corresponding memory location (C1, F1 and Z1 to M1; C2, F2 and
Z2 to M2, etc.).

Find Scale performs a vertical scaling that fits the waveform into the grid.

Next Grid moves the active trace to the next grid. If you have only one grid displayed, a new grid will
be created automatically, and the trace moved.

Label opens the Label pop-up to annotate the active trace.

Histogram, Trend, and Track buttons appear at the bottom of the Parameter (Px) dialogs. They allow
you to create a Math function to plot the parameter while remaining on the measurement dialogs.

20



Using MAUI

OneTouch Help
Touch, drag, swipe, pinch, and flick can be used to create and change setups with one touch. Just as
you change the display by using the setup dialogs, you can change the setups by moving different
display objects. Use the setup dialogs to refine OneTouch actions to precise values.

As you drag & drop objects, valid targets are outlined with a white box. When you're moving over
invalid targets, you'll see the "Null" symbol ( Ø ) under your finger tip or cursor.

Turn On
To turn on a new channel, math, memory, or zoom trace, drag any descriptor box of the same type to
the Add New ("+") box. The next trace in the series will be added to the display at the default settings.
It is now the active trace.

If there is no descriptor box of the desired type on the screen to drag, touch the Add New box and
choose the trace type from the pop-up menu.

To turn on the Measure table when it is closed, touch the Add New box and choose Measurement.

Activate
Touch a trace or its descriptor box to activate it and bring it to the foreground. When the descriptor
box appears highlighted in blue, front panel controls and touch screen gestures apply to that trace.
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Copy Setups
To copy the setup of one trace to another of the same type (e.g., channel to channel, math to math),
drag-and-drop the source descriptor box onto the target descriptor box.

To copy the setup of a measurement (Px), drag-and-drop the source column onto the target column of
the Measure table. You can do the same for a qualifier (Qx) on the Pass/Fail readout table.

Change Source
To change the source of a trace, drag-and-drop the descriptor box of the desired source onto the
target descriptor box. You can also drop it on the Source field of the target setup dialog.

To change the source of a measurement, drag-and-drop the descriptor box of the desired source onto
the parameter (Px) column of the Measure table. You can do the same to a qualifier (Qx) on the
Pass/Fail readout table.
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Position Cursors
To change cursor measurement time/level, drag cursor markers to new positions on the grid. The
cursor readout will update immediately.

To place horizontal cursors on zooms or other calculated traces where the source Horizontal Scale
has forced cursors off the grid, drag the cursor readout from below the Timebase descriptor to the
grid where you wish to place the cursors. The cursors are set at either the 5 (center) or 2.5 and 7.5
divisions of the grid. Cursors on the source traces adjust position accordingly.

Change Trigger
To change the trigger level, drag the Trigger Level indicator to a new position on the Y axis. The
Trigger descriptor box will show the new voltage Level.

To change the trigger source channel, drag-and-drop the desired channel (Cx) descriptor box onto the
Trigger descriptor box. The trigger will revert to the last trigger set on that channel.
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Store to Memory
To store a trace to internal memory, drag-and-drop its trace descriptor box onto the target memory
(Mx) descriptor box.

Move Trace
To move a trace to a different grid, drag-and-drop the trace descriptor box onto the target grid. If you
are in a multi-tabbed Q-Scape display mode, you can move traces between tabs this way.

Scroll
To scroll long lists of values or readout tables, swipe the selection dialog or table in an up or down
direction.
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Pan Trace
To pan a trace, activate it to bring it to the forefront, then drag the waveform trace right/left or
up/down. If it is the source of any other trace, that trace will move, as well. For channel traces, the
Timebase descriptor box will show the new Horizontal Delay value. For other traces, the zoom factor
controls show the new Horizontal Center.

Tip: If you are using the multi-zoom feature, all time-locked traces will pan together.

To pan at an accelerated rate, swipe the trace right/left or up/down.

Zoom
To create a new zoom trace, touch then drag diagonally to draw a selection box around the portion of
the trace you want to zoom. Touch the Zx descriptor box to open the zoom factor controls and adjust
the zoom exactly.

To "zoom in" on any trace, unpinch two fingers over the trace horizontally.

To "zoom out" on any trace, pinch two fingers over the trace horizontally.
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Note: Pinch gestures do not create a separate zoom (Zx) trace, they only adjust the Horizontal
Scale. When you pinch a channel (Cx) trace, the Timebase for all channels changes. If the
trace is the source of any other, all its dependent traces change as well.

Turn Off
To turn off a trace, flick the trace descriptor box toward the bottom of the screen.

To turn off a measure parameter or Pass/Fail qualifier, flick the Px or Qx cell toward the bottom of the
screen. If it's the last active cell of the table, the table will close.
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Working With Traces
Traces are the visible representations of waveforms that appear on the display grid. They may show
live inputs (Cx, Digitalx), a math function applied to a waveform (Fx), a stored memory of a waveform
(Mx), a zoom of a waveform (Zx), or the processing results of special analysis software.

Traces are a touch screen object like any other and can be manipulated. They can be panned, moved,
labeled, zoomed, and captured in different visual formats for printing/reporting.

Each visible trace will have a descriptor box summarizing its principal configuration settings. See
OneTouch Help for more information about how you can use traces and trace descriptor boxes to
modify your configurations.

Active Trace
Although several traces may be open, only one trace is active and can be adjusted using front panel
controls and touch screen gestures. A highlighted descriptor box indicates which trace is active. All
actions apply to that trace until you activate another. Touch a trace descriptor box to make it the
active trace (and the foreground trace in that grid).

Active trace descriptor (left), inactive trace descriptor (right).

Whenever you activate a trace, the dialog at the bottom of the screen automatically switches to the
appropriate setup dialog.

Active descriptor box matches active dialog tab.

Foreground Trace
Since multiple traces can be opened on the same grid, the trace shown on top of the others is the
foreground trace. Grid indicators (matched to the input channel color) represent values for the
foreground trace.

Touch a trace or its descriptor box to bring it to the foreground. This also makes it the active trace.

Note that a foreground trace may not be the same as the active trace. A trace in a separate grid may
subsequently become the active trace, but the indicators on a given grid will still represent the
foreground trace in that group.
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Turning On/Off Traces

Channel Traces
From the front panel, press the Channel button (1-4) to turn on the trace; press again to turn it off.

From the display, touch the Add New box and select Channel, or drag another Channel (Cx) descriptor
box to the Add New box.

To turn off a channel trace, do any of the following:

l Flick the descriptor box toward the bottom of the screen.

l Touch-and-hold (right-click) on the descriptor box until a white circle appears, then from the
context menu select Off.

l Clear the channel checkbox on the Channel Setup or Cx dialogs.

Note: The default is to display each trace in its own grid. Use the Display menu to change how
traces are displayed.

Digital Traces
From the front panel, press the Dig button, then check Group on the Digital<#> trace dialog.

From the menu bar, choose Vertical > Digital <#> Setup, then check Group on the Digital<#> trace
dialog.

Clear the Group checkbox to turn off the trace, or flick the digital trace descriptor box toward the
bottom of the screen.

Other Traces
From the front panel, touch the Zoom button to create quick zooms of all open traces. Press the
button again to turn them off.

From the display, touch the Add New box and select the trace type, or drag another descriptor box of
that type to the Add New box.

Adjusting Traces
To adjust Vertical Scale (gain or sensitivity) and Vertical Offset, just activate the trace and use the
front panel Vertical knobs. To make other adjustments—such as pre-processing on channel traces or
the function definition of math traces—touch the trace descriptor box twice to open the appropriate
setup dialog.

Many entries can be made by selecting from the pop-up menu that appears when you
touch a control. But when an entry field appears highlighted in blue after touching, it
is active and the value can be modified by turning the front panel knobs. Fields that
don't have a dedicated knob (as do Vertical Level and Horizontal Delay) can be

modified using the Adjust knob.
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If you have a keyboard installed, you can type entries in an active (highlighted) data entry field. Or, you
can touch again, then "type" the entry by touching keys on the virtual keypad or keyboard.

To use the virtual keypad, touch the soft keys exactly as you would a calculator. When you touch OK,
the calculated value is entered in the field.

Moving Traces
Use any of these methods to move traces from grid to grid. See OneTouch Help for ways to pan
traces within the same grid.

Drag-and-Drop
You can move a trace from one grid to another by dragging its descriptor box to the desired grid. This
is a convenient way to quickly re-arrange traces on the display.

If you are in Q-Scape display mode, you can drag the descriptor box to a grid on another tab, provided
the grid is visible while you are moving the trace. For example, you cannot drag descriptors across
tabs in Q-Scape Single mode, because the target grids aren't visible, but you can in Q-Scape Dual or
Q-Scape Mosaic modes. This is true even in extended display. For more information, see Display.

Next Grid Button
Touch twice on the descriptor box of the trace you want moved to open the setup dialog, then touch
the Next Grid action toolbar button at the bottom of the dialog. You can also touch and hold (right-
click) the trace descriptor box and choose Next Grid from the context menu.

Note: If only one grid is open, a second grid opens automatically when you select Next Grid.
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Labeling Traces
The Label function gives you the ability to add custom annotations to the trace display. Once placed,
labels can be moved to new positions or hidden while remaining associated with the trace.

Create Label

1. Select Label from the context menu, or touch the Label Action toolbar button on the trace setup
dialog.

2. On the Trace Annotation pop-up, touch Add Label.

3. Enter the Label Text.

4. Optionally, enter the Horizontal Pos. and Vertical Pos. (in same units as the trace) at which to
place the label. The default position is 0 ns horizontal. Use Trace Vertical Position places the
label immediately above the trace.

Reposition Label
Drag-and-drop labels to reposition them, or change the position settings on the Trace Annotation pop-
up.

Edit/Remove Label
On the Trace Annotation pop-up, select the Label from the list. Change the settings as desired, or
touch Remove Label to delete it.

Clear View labels to hide all labels. They will remain in the list.
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Zooming Traces
The Zoom function magnifies a selected region of a trace. Depending on your oscilloscope model,
you can display up to eight zooms of any channel, math, or memory trace.

Zooms may be created in several ways, using either the front panel or the touch screen. You can
adjust zooms the same as any other trace using the front panel Vertical and Horizontal knobs or the
touch screen zoom factor controls.

The current settings for each zoom trace can be seen on the Zx dialogs, while the Zoom dialog is a
convenient panel for turning on/off zooms or changing the zoom source.

The Multi-Zoom feature creates time-locked zoom traces for only the waveforms that you choose to
include. The zooms are of the same X-axis section of each waveform. As you scroll through a
waveform, all included zooms scroll in unison. For more information, refer to Multi-Zoom.

Zoom Dialog
Zoom controls appear throughout the X-Stream software wherever it is likely you may wish to change
the display scale of a trace, sometimes as a main dialog, sometimes as a subdialog, such as when
setting up:

l Math traces on Fx dialogs

l Memory traces on Mx dialogs

To display the zoom controls, choose Math > Zoom Setup from the menu bar, or touch a zoom
descriptor box.

The main Zoom dialog contains selection boxes for turning on/off and changing the source of a zoom.
There are also options to:

l Reset All, return all zooms to x1 magnification.

l Quick Zoom, create a corresponding zoom trace for each open channel trace, same as using
the front panel Zoom button.

l MultiZoom
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Zx Dialog
Behind the main Zoom dialog is a separate tab for each potential zoom trace (Z1-Zx). Each Zx dialog
reflects the current scale settings for that zoom trace. Use it to adjust the zoom magnification.

Trace Controls
Trace On shows/hides the zoom trace. It is selected by default when the zoom is created.

Source lets you change the source for this zoom to any channel, math, or memory trace while
maintaining all other settings.

Segment Controls
These controls are used in Sequence Sampling Mode.

Zoom Factor Controls

l Out and In buttons increase/decrease zoom magnification and consequently change the
Horizontal and Vertical Scale settings. Touch either button until you've achieved the desired
level.

l Var.checkbox enables zooming in single increments.

l Horizontal Scale/div sets the time represented by each horizontal division of the grid. It is the
equivalent of Time/div in channel traces, only unlike that setting, it may differ for each zoom
trace.

l Vertical Scale/div sets the voltage level represented by each vertical division of the grid; it's
the equivalent of V/div in channel traces.

l Horizontal/Vertical Center sets the time/voltage at the center of the grid. The horizontal center
is the same for all zoom traces.

l Reset Zoom returns the zoom to x1 magnification.

Creating Zooms
Zooms magnify a selected region of another trace by altering the Horizontal Scale relative to the
source trace. Any type of trace can be "zoomed" by creating a new zoom trace (Zx) following the
procedures here.

Note: Alternatively, channel or math traces can be "zoomed" by pinching/unpinching two
fingers over the trace. This method does not create a separate zoom trace. With channel
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traces, pinching will alter the acquisition timebase and the scale of all traces. Create a
separate zoom trace if you do not wish to do this.

All zoom traces open in the next empty grid, with the zoomed portion of the source trace highlighted.
If there are no more available grids, zooms will open in the same grid as the source trace.

Zoomed area of original trace highlighted. Zoom in new grid below.

Quick Zoom
Use the front panel Zoom button to quickly create one zoom trace for each displayed channel trace.
Quick zooms are created at the same vertical scale as the source trace and 10:1 horizontal
magnification.

To turn off the quick zooms, press the Zoom button again.

Manually Create Zoom
To manually create a zoom, touch-and-drag diagonally to draw a selection box around any part of the
source trace.

Selection box over trace.

The zoom will resize the selected area to fit the full width of the grid. The degree of vertical and
horizontal magnification, therefore, depends on the size of the rectangle that you draw.
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Alternatively, you can drag any Zx descriptor box over the Add New box, or touch the Add New box and
choose Zoom from the pop-up menu. The next available zoom trace opens.

Finally, you can touch-and-hold (right-click) on the descriptor box of the trace you wish to zoom until a
white circle appears, then choose Math from the context menu. Select the Zoom operator to create a
zoom in the next open math function. This method creates a new Fx trace, rather than a new Zx trace,
but it can be rescaled in the same manner.

Adjust Zoom Scale
The zoom's Horizontal units will differ from the signal timebase because the zoom is showing a
calculated scale, not a measured level. This allows you to adjust the zoom factor using the front
panel knobs or the zoom factor controls however you like without affecting the timebase (a
characteristic shared with math and memory traces).

Close Zoom
New zooms are turned on and visible by default. If the display becomes too crowded, you can close a
particular zoom and the zoom settings are saved in its Zx location, ready to be turned on again when
desired.

To close the zoom, touch-and-hold (right-click) on the zoom descriptor box until the white circle
appears, then from the context menu choose Off.

Multi-Zoom
Multi-Zoom creates time-locked zoom traces for only the waveforms that you choose to include. The
zooms are of the same X-axis section of each waveform. As you scroll through a waveform, all
included zooms scroll in unison.

Set Up Multi-Zoom

1. Choose Math > Zoom Setup... to open the Zoom dialog, then touch the Multi-Zoom tab or
Multi-Zoom Setup... button.

2. On the Multi-Zoom dialog, check On.

3. Select all the traces that are In the Multi-Zoom group.

Scroll Waveforms
The Auto-Scroll controls appear at the right of the Multi-Zoom dialog. They work similarly to A/V
controls to allow you to continuously scroll all the selected zoom traces in time-locked steps from
the beginning to the end of the acquisition.
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Printing/Screen Capture
The Print function captures an image of the display and outputs it according to your Hardcopy
settings.

Print may be used as a screen capture tool by selecting to print to a graphical file format on the
Hardcopy dialog. Once configured, there are three ways to take a capture of the screen:

l Press the front panel Print button.

l Choose File > Print.

l Go to Utilities > Utilities Setup > Hardcopy tab and touch the Print button to the far right of the
dialog.
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Acquisition
The acquisition settings include everything required to produce a visible trace on screen and an
acquisition record that may be saved for later processing and analysis:

l Vertical axis scale at which to show the input signal and probe characteristics that affect the
signal, such as attenuation and deskew time

l Horizontal axis scale at which to represent time, and acquisition sampling mode and sampling
rate

l Acquisition trigger mechanism

Optional acquisition settings include bandwidth filters and pre-processing effects, vertical offset, and
horizontal trigger delay, all of which affect the appearance and position of the waveform trace.

The overall length of the acquisition in time is determined by the Time/Division (timebase) setting,
with acquisition time equal to 10 times the Time/Division setting. The formula for maximum Sample
Rate is: Sample Rate = Memory Samples/Acquisition Time, with the maximum Sample Rate being
limited by the instrument's analog-to-digital converter (ADC).

To avoid aliasing and other waveform distortions, it is advisable (per Nyquist) to acquire at a sample
rate at least twice the bandwidth of the input signal. It can be shown that a sample rate 10 times the
acquisition bandwidth is preferable in order to over sample fast signal rise times consistent with the
oscilloscope bandwidth.

The instrument allocates memory as needed to maintain the highest Sample Rate possible for the
timebase, but those with higher speed acquisition systems may need to manually adjust these
settings to achieve the optimal result. Most Teledyne LeCroy oscilloscopes have a Fixed Sample
Rate option, which uses whatever memory is required for the acquisition time, until none remains.

Auto Setup
Auto Setup quickly configures the essential acquisition settings based on the first input signal it
finds, starting with Channel 1. If nothing is connected to Channel 1, it searches Channel 2 and so forth
until it finds a signal. Vertical Scale (V/div), Offset, Timebase (Time/div), and Trigger are set to an
Edge trigger on the first, non-zero-level amplitude, with the entire waveform visible for at least 10
cycles over 10 horizontal divisions.

To run Auto Setup:

1. Either press the front panel Auto Setup button or choose Auto Setup from the Vertical,
Timebase, or Trigger menus. All these options perform the same function.

2. Press the Auto Setup button again or use the touch screen display to confirm Auto Setup.

After running Auto Setup, you'll see the words "Auto Setup" next to an Undo button at the far right of
the menu bar. This allows you to restore the settings in place prior to the Auto Setup. 
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Note: You will undo all new measurements or math function definitions entered since the Auto
Setup when you Undo the Auto Setup. Perform this work when the instrument is not in the
Auto Setup mode if you wish for it to persist.

Restore Default Setup
Restore the factory default state by pressing the front panel Default Setup button. You can also
restore default settings by choosing File > Recall Setup > Recall Default.

Setting Default

Channel/Vertical C1 and C2 on at 50 mV/div Scale, 0 V Offset, Linear Interpolation

Timebase Real Time Sampling at 50 ns/div, 0 Delay, 5.0 kS at 10 GS/s, 1.0 MS Memory

Trigger C1 with an Auto Positive Edge, DC Coupling, 0 V Level

Display Auto Grid

Cursors Off

Measurements Cleared

Math Cleared

Viewing Status
All instrument settings can be viewed through the various Status dialogs. These show all existing
acquisition, trigger, channel, math function, measurement and parameter configurations, as well as
which are currently active.

Access the Status dialogs by choosing the Status option from the Vertical, Timebase, Math, or
Analysis menus (e.g., Channel Status, Acquisition Status).
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Vertical Settings
Vertical, also called Channel, settings usually relate to voltage level and control input channel traces
(C1-Cx) along the Y axis.

Note: While Digital settings can be accessed through the Vertical menu on -MS model
instruments, they are handled quite differently. See Digital.

The amount of voltage displayed by one vertical division of the grid, or Vertical Scale (V/div), is most
quickly adjusted by using the front panel Vertical knob. The Cx descriptor box always shows the
current Vertical Scale setting.

Detailed configuration for each trace is done on the Cx dialogs. Once configured, channel traces can
be quickly turned on/off or modified using the Channel Setup dialog.

Channel Setup Dialog
Use the Channel Setup dialog to quickly make basic Vertical settings for all analog input channels. To
access the Channel Setup dialog, choose Vertical > Channel Setup from the menu bar.

To show/hide the channel trace, select/deselect the checkbox next the channel number.

To change the channel trace color, touch the color block next to the channel number, then choose the
new color from the pop-up menu.

To change any other Vertical settings, touch the input field and enter the new value.

Tip: Apply pre-processing settings on the Channel Dialog (Cx).

To copy settings from one channel to another, drag-and-drop the source channel descriptor box onto
the target channel descriptor box.

You can also touch Copy Channel Setup, then select the channel to Copy From and all the channels to
Copy To.
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Cx (Channel) Dialog
Full vertical setup is done on the Cx dialog. To access it, choose Vertical > Channel <#> Setup from
the menu bar, or touch the Channel descriptor box.

The Cx dialog contains:

l Vertical settings for scale, offset, coupling, bandwidth, and probe attenuation.

l Rescale settings

l Pre-processing settings for pre-acquisition processes such as noise filtering and interpolation.

If a Teledyne LeCroy probe is connected to the channel, a Probe dialog tab appears to the right of the
Cx dialog.

Vertical Settings
The Trace On checkbox turns on/off the channel trace.

Vertical Scale sets the gain (sensitivity) in the selected Vertical units, Volts by default. Select
Variable Gain for fine adjustment or leave the checkbox clear for fixed 1, 2, 5, 10-step adjustments.

Offset adds a defined value of DC offset to the signal as acquired by the input channel. This may be
helpful in order to display a signal on the grid while maximizing the vertical height (or gain) of the
signal. A negative value of offset will "subtract" a DC voltage value from the acquired signal (and
move the trace down on the grid") whereas a positive value will do the opposite. Touch Zero Offset to
return to zero.

A variety of Bandwidth filters are available at fixed settings. The exact settings vary by model. To
limit bandwidth, select a filter from this field.

Coupling may be set to DC 50 Ω, DC1M, AC1M or GROUND.

Caution: The maximum input voltage depends on the input used. Limits are displayed on the
body of the instrument. Whenever the voltage exceeds this limit, the coupling mode
automatically switches to GROUND. You then have to manually reset the coupling to its
previous state. While the unit does provide this protection, damage can still occur if extreme
voltages are applied.

Probe Attenuation and Deskew
Probe Attenuation and Deskew values for third-party probes may be entered manually on the Cx
dialog. The instrument will detect it is a third-party probe and display these fields.
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When a Teledyne LeCroy probe is connected to a channel input:

l Passive probe Attenuation is automatically set, and this field is disabled on the Cx dialog.

l For active voltage and current probes, a tab is added to the right of the Cx tab. The Attenuation
field becomes a button to access the Probe dialog. Enter Attenuation on the Probe dialog.

Rescale Settings
The rescale function allows you to apply a multiplication factor, additive constant, and differential
vertical unit to the waveform vertical samples.

Vertical Units may be changed from Volts (V) to Amperes (A). This is useful when using a third-party
current probe (which is not auto-detected) or when probing across a current sensor/resistor.

Enter the desired values in Units/V and Add. These two selections provide the same capability as the
Rescale math function (y=mx+b) but in a more intuitive, user-friendly format.

Pre-Processing Settings
Average performs continuous averaging or the repeated addition, with unequal weight, of successive
source waveforms. It is particularly useful for reducing noise on signals drifting very slowly in time or
amplitude. The most recently acquired waveform has more weight than all the previously acquired
ones: the continuous average is dominated by the statistical fluctuations of the most recently
acquired waveform. The weight of old waveforms in the continuous average gradually tends to zero
(following an exponential rule) at a rate that decreases as the weight increases.

Interpolate applies (Sinx)/x interpolation to the waveform. The default selection of None applies
Linear interpolation, which inserts a straight line between sample points and is best used to
reconstruct straight-edged signals such as square waves. (Sinx)/x interpolation, on the other hand, is
suitable for reconstructing curved or irregular wave shapes, especially when the sample rate is 3 to 5
times the system bandwidth. Select an upsample factor of 2 or 5 points between each sample point.

Deskew adjusts the horizontal time offset by the amount entered in order to compensate for
propagation delays caused by different probes or cable lengths. The valid range is dependent on the
current timebase setting. The Deskew pre-processing setting and the Deskew math function perform
the same action.

Noise Filter applies Enhanced Resolution (ERes) filtering to increase vertical resolution, allowing you
to distinguish closely spaced voltage levels. The tradeoff is reduced bandwidth. The functioning of
the instrument's ERes is similar to smoothing the signal with a simple, moving-average filter. It is
best used on single-shot acquisitions, acqusitions where the data record is slowly repetitive (and you
cannot use averaging), or to reduce noise when your signal is noticeably noisy but you do not need to
perform noise measurements. It also may be used when performing high-precision voltage
measurements and zooming with high vertical gain, for example. See Enhanced Resolution.

Invert inverts the trace.

Cable De-Embedding (available as an option) allows you to remove the effects of cables used in the
test setup. Select the checkbox, then enter the attenuation constants or cable characteristics
(provided by the cable manufacturer) on the Cable De-Embedding dialog that appears. See Cable De-
Embedding.
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Probe Dialog
The Probe Dialog immediately to the right of the Cx dialog displays the probe attributes and
(depending on the probe type) allows you to AutoZero, DeGauss and make tip selection for probes
from the touch screen. Other settings may appear, as well, depending on the probe model.

Caution: Remove probes from the circuit under test before initializing Auto Zero or DeGauss.

Auto Zero Probe
Auto Zero corrects for DC offset drifts that naturally occur from thermal effects in the amplifier of
active probes. Teledyne LeCroy probes incorporate Auto Zero capability to remove the DC offset from
the probe's amplifier output to improve the measurement accuracy.

DeGauss Probe
The Degauss control is activated for some types of probes (e.g., current probes). Degaussing
eliminates residual magnetization from the probe core caused by external magnetic fields or by
excessive input. It is recommended to always Degauss probes prior to taking a measurement.

Tip Select
If using one of the modular WaveLink probes, specify the type of tip/lead you're using by touching the
Tip Select control and making the appropriate selection.

Note: It's crucial to make the tip selection on this field as it results in the amplifier and tip
combination having the response calibrated for at the factory. Failure to do so may result in
inaccurate measurements.

Cable De-Embedding Option
Losses in the cables used in the test setup can reduce the accuracy of your signal (for example,
signal amplitude and risetime), as well as introduce Inter-Symbol Interference. These cable effects
can dramatically alter measurements and potentially create mask test violations.

Cable De-Embedding, available as an option on WaveRunner oscilloscopes, allows you to quickly
specify the characteristics of the cables (typically found on the cable's data sheet) in your test setup
and analyze your signal with the effects of the cables removed. The compensated signal is a more
accurate representation of what was actually transmitted.
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When Cable De-Embedded is installed and selected from the channel pre-processing settings, the
Cable De-Embedding dialog will appear for you to describe the cable being used on the channel.

1. Touch Vertical > Channel # Setup... from the menu bar.

2. On the Cx dialog, check Cable De-Embeddingto display the Cable De-Embedding tab.

3. On the Cable De-Embedding dialog, touch Cable Specified by and choose either:
Attenuation Constants. Enter the cable loss model constants (provided by the manufacturer) in
Cable A1 and Cable A2.
Or
Attenuation Table. Enter the first set of Frequency and Attenuation values. Touch Add to
continue adding rows as needed.

Tip: To edit a row in the table, select the row, change values, then touch Change. To
delete a row, select the row and touch Delete.

4. Touch Delay Specified by and choose from Propagation Velocity, Nominal Delay, or Dielectric
Constant. Enter the delay value in the field of the same name that appears below your
selection.

5. Enter the Cable Length in inches.

6. Click Apply to initiate the cable de-embedding for the signal on this channel so that the effects
of the cable are removed.

7. To save this cable configuration for future use, touch File Name [DefaultCable] and enter a
name, or touch Browse and select a file to overwrite. To reload previously saved
configurations, browse to the file, then touch Load.
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Digital (Mixed Signal) Settings
The digital leadset (standard with -MS model oscilloscopes) inputs up-to-16 lines of digital data.
Leads are organized into two banks of eight leads each, and you assign each bank a standard Logic
Family or a custom Threshold to define the digital logic of the signal.

There are four set up dialogs for each of four possible digital groups, which correspond to buses:
Digital1 to Digital4. You choose which lines from among the 16 make up each digital group, what they
are named, and how the group appears on the display. Initially, logical lines are numbered the same
as the physical lead they represent, although any line number can be re-assigned to any lead.

Digital Traces
When a digital group is enabled, digital Line traces show which lines are high, low, or transitioning
relative to the threshold. You can also view a digital Bus trace that collapses all the lines in a group
into their Hex values.

Four digital traces displayed with a Vertical Position +4.0 (top of grid) and a Group Height 4.0 (divisions).

Activity Indicators
Activity indicators at the bottom of the Digitalx dialogs show which lines are High (up arrow), Low
(down arrow), or Transitioning (up an down arrows) relative to the Logic Threshold value. They provide
a quick view of which lines are active and of interest to display on screen.
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Digitalx (Group) Set Up

To set up a digital input:

1. Connect the digital leadset to the test device and the instrument.

2. From the menu bar, choose Vertical > Digital <#> Setup, or press the front panel Dig button and
select the desired Digitalx tab.

3. On the Digitalx set up dialog, check the boxes for lines D0 through D15 that comprise the
group.

Touch the Display D0-D7 and Display D8-D15 buttons to quickly turn on the entire digital bank,
or touch the Right and Left Arrow buttons to switch between each digital bank as you make
line selections.

Note: Each group can consist of anywhere from 1 to 16 of the leads, from either digital
bank regardless of the Logic set on the bank. It does not matter if the some or all of the
lines have been included in other groups.

4. Check View Group to enable the display. Go on to set up the digital display for the group.

5. When you're finished on the Digitalx dialog, touch Logic Setup and choose the Logic Family
that applies to each digital bank, or set custom Threshhold and Hysteresis values.
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Digital Display Set Up
Choose the type and position of the digital traces that appear on screen for each digital group.

1. Set up the digital group.

2. Choose a Display Mode:

l Lines (default) shows a time-correlated trace indicating high, low, and transitioning
points (relative to the Threshold) for every digital line in the group. The size and
placement of the lines depend on the number of lines, the Vertical Position and Group
Height settings.

l Bus collapses the lines in a group into their Hex values. It appears immediately below
all the Line traces when both are selected.

l Lines & Bus displays both line and bus traces at once.

3. In Vertical Position, enter the number of divisions (positive or negative) relative to the zero line
of the grid where the display begins.The top of the first trace appears at this position.

4. In Group Height, enter the total number of grid divisions the entire display should occupy. All
the selected traces (Line and Bus) will appear in this much space. Individual traces are resized
to fit the total number of divisions available.

The example above shows a group of three Line traces plus the Bus trace occupying a Group
Height of 4.0 divisions. Each trace takes up one division.

To close digital traces, uncheck the Group box on the Digital# dialog.

Tip: Because a new grid opens to accommodate each enabled group, you may wish to enable
groups one or two at a time when they have many lines to maximize the total amount of
screen space available for each. Closing the set up dialogs will also increase available screen
space.
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Renaming Digital Lines
The labels used to name each line can be changed to make the user interface more intuitive. Also,
labels can be "swapped" between lines.

Changing Labels

1. Set up the digital group.

2. Touch Label and select from:

l Data - the default, which appends "D." to the front of each line number.

l Address - appends "A." to the front of each line number.

l Custom - lets you create your own labels line by line.

3. If using Custom labels:

l Touch the Line number button below the corresponding checkbox. If necessary, use the
Left/Right Arrow buttons to switch between banks.

l Use the virtual keyboard to enter the name, then press OK.

The button and any active line traces are renamed accordingly.

Swapping Lines
This procedure helps in cases where the physical lead number is different from the logical line
number you would like to assign to that input. It can save time having to re-attach leads or re-
configure groups.

Example: A group is set up for lines 0-4, but lead 5 was accidentally attached to the probing
point. By "swapping" line 5 with line 4, you do not need to change either the physical or the
logical setup.

1. Select a Label of Data or Address.

2. Touch the Line number button below the corresponding checkbox. If necessary, use the
Left/Right Arrow buttons to switch between banks.

3. From the pop-up, choose the line with which you want to swap labels.

The button and any active line traces are renumbered accordingly.
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Timebase Settings
Timebase, also known as Horizontal, settings control the trace along the X axis. The timebase is
shared by all channels.

The time represented by each horizontal division of the grid, or Time/Division, is most easily adjusted
using the front panel Horizontal knob. Full Timebase set up, including sampling mode and clock
source selection, is done on the Timebase dialog, which can be accessed by either choosing
Timebase > Horizontal Setup from the menu bar or touching the Timebase descriptor box.

The Timebase dialog contains settings for Sampling Mode, Timebase Mode, Real Time Memory, and
Active Channels. There are related dialogs for Sequence Mode and Clock Source.

The Active Channels controls at the right of the Timebase dialog enable you to increase the sampling
rate and memory of a single input by combining the digital capabilities of two channels.

Timebase Set Up
Use the Timebase dialog to select the sampling mode and combine channels to increase sample
rate. You can also use it instead of the Front Panel to modify the Time/Div, horizontal Delay, and Max
(imum) Sample Points stored in memory.

Sampling Mode
Choose from Real Time, Sequence, RIS, or Roll mode.

Timebase Mode
Time/Division is the time represented by one horizontal division of the grid. Touch the Up/Down
Arrow buttons on the Timebase dialog or turn the front panel Horizontal knob to adjust this value.

Delay is the amount of time relative to the trigger event to display on the grid. Raising/lowering the
Delay value has the effect of shifting the trace to the right/left. This allows you to isolate and display
a time/event of interest that occurs before or after the trigger event.

l Pre-trigger Delay, entered as a negative value, displays the time prior to the trigger event,
which occurs at time 0 in Real Time sampling mode. Pre-trigger Delay can be set up to the
instrument's maximum sample record length; how much actual time this represents depends
on the timebase. At maximum pre-trigger Delay, the trigger position is off the grid (indicated by
the arrow at the lower right corner), and everything you see represents pre-trigger time.

l Post-trigger Delay, entered as a positive value, displays time following the trigger event. Post-
trigger Delay can cover a much greater lapse of time than pre-trigger Delay, up to the
equivalent of 10,000 divisions after the trigger event occurred (it is limited at slower time/div
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settings and in Roll mode sampling). At maximum post-trigger Delay, the trigger point is off the
grid far left of the time displayed.

Set to Zero returns Delay to zero.

Real Time Sampling Rate
These controls specify how the instrument samples when in Real Time mode.

Sampling Rate/Maximum Sample Points is the number of samples taken per time division when
using a Fixed Sampling Rate. It changes to Maximum Sample Points, the number of samples taken
per acquisition, if you choose to Set Maximum Memory.

Set Maximum Memory automatically adjusts the sampling rate to take the maximum number of
samples possible given the amount of pre- or post-trigger Delay and the Time/div, up to the maximum
record length. This optimizes the sample rate for fast timebases when in Real Time mode.

Fixed Sampling Rate activates the Sampling Rate field for you to set your own rate. Lowering the rate
can extend the acquisition to accommodate slower timebases or longer delays.

Active Channels (Dual-Channel Acquisition)
The Active Channels settings allow you to combine the acquisition capabilities of the leftmost pair of
channels (C1 and C2) and the rightmost pair of channels (C3 and C4) to result in two channels with
maximum sample rate and memory.

In 4-channel mode, all channels remain active at the default sample rate.
To combine channels, under Active Channels, choose 2 or Auto.

2-channel mode turns off acquisition on Channels 1 and 4. Channels 2 and 3 acquire at doubled
sample rate and memory.

In Auto mode, the oscilloscope will allot the maximum memory and sample rate possible based on
the activity within each pair of channels. As long as only one channel in each of the C1-C2 and C3-C4
pairs is turned on, the maximum rate is used. Turning on both channels in either pair has the same
effect as selecting 4 active channels.

Example: C1 can operate with either C3 or C4 at higher sample rate and memory since they
belong to different pairs, and likewise C2. However, C1 cannot operate with C2 without dropping
the sample rate, nor can C3 operate with C4.

Refer to Acquisition System in the product datasheet for maximum sample rates.

Sampling Mode
The Sampling Mode setting determines how the instrument samples the input signal and renders it
for display.

Real Time Sampling Mode
Real Time sampling mode is a series of digitized voltage values sampled on the input signal at a
uniform rate. These samples are displayed as a series of measured data values associated with a
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single trigger event. By default (with no Delay), the waveform is positioned so that the trigger event is
time 0 on the grid.

The relationship between sample rate, memory, and time can be expressed as:

Capture Interval = 1/Sample Rate X Memory
Capture Interval/10 = Time Per Division

Usually, on fast timebase settings, the maximum sample rate is used when in Real Time mode. For
slower timebase settings, the sample rate is decreased so that the maximum number of data
samples is maintained over time.

Roll Sampling Mode
Roll mode displays, in real time, incoming points in single-shot acquisitions that appear to "roll"
continuously across the screen from right to left until a trigger event is detected and the acquisition
is complete. The parameters or math functions set on each channel are updated every time the roll
mode buffer is updated as new data becomes available. This resets statistics on every step of Roll
mode that is valid because of new data.

Timebase must be set to 100 ms/div or slower to enable Roll mode selection. Roll mode samples at
≤ 5 MS/s. Only Edge trigger is supported.

Note: If the processing time is greater than the acquire time, the data in memory is
overwritten. In this case, the instrument issues the warning, "Channel data is not continuous
in ROLL mode!!!" and rolling starts again.

RIS Sampling Mode
RIS (Random Interleaved Sampling) allows effective sampling rates higher than the maximum single-
shot sampling rate. It is available on timebases ≤ 10 ns/div.

The maximum effective RIS sampling rate is achieved by making multiple single-shot acquisitions at
maximum real-time sample rate. The bins thus acquired are positioned approximately 5 ps (200
GS/s) apart. The process of acquiring these bins and satisfying the time constraint is a random one.
The relative time between ADC sampling instants and the event trigger provides the necessary
variation.

Because the instrument requires multiple triggers to complete an acquisition, RIS is best used on
repetitive waveforms with a stable trigger. The number depends on the sample rate: the higher the
sample rate, the more triggers are required. It then interleaves these segments (as shown in the
following illustration) to provide a waveform covering a time interval that is a multiple of the
maximum single-shot sampling rate. However, the real-time interval over which the instrument
collects the waveform data is much longer, and depends on the trigger rate and the amount of
interleaving required.
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Interleaving of samples in RIS sampling mode.

Note: RIS is not available when the oscilloscope is operating in fixed sample rate mode.

Sequence Sampling Mode
In Sequence sampling mode, the complete waveform consists of a number of fixed-size segments
(see the instrument specifications at teledynelecroy.com for the limits). The instrument uses the
Timebase Sequence settings to determine the capture duration of each segment. The desired
number of segments, maximum segment length, and total available memory are used to determine
the actual number of samples or segments, and time or points.

Sequence mode is ideal when capturing many fast pulses in quick succession or when capturing few
events separated by long time periods. The instrument can capture complicated sequences of events
over large time intervals in fine detail, while ignoring the uninteresting periods between the events.
You can also make measurements on selected segments using the full precision of the acquisition
timebase.

Sequence Mode Set Up
The Sequence dialog appears only when Sequence sampling mode is selected. Use it to define the
number of fixed-size segments to be acquired in single-shot mode.

1. From the menu bar, choose Timebase > Horizontal Setup..., then Sequence Sampling Mode.

2. On the Sequence tab under Acquisition Settings, touch Number of Segments and enter a value.

Note: The number of segments displayed can be less than the total number of
segments acquired.

3. To stop acquisition in case no valid trigger event occurs within a certain timeframe, check the
Enable Timeout box, then touch Timeout and provide a timeout value.
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Note: While optional, Timeout ensures that the acquisition completes in a reasonable
amount of time and control is returned to the operator/controller without having to
manually stop the acquisition.

4. Touch Display mode and select a sequence display mode from the pop-up menu:

Adjacent

Waterfall (cascaded)

Mosaic (tiled)

Overlay

Perspective

Note: Some display modes have limitations on the number of segments that can be
shown at one time.

5. Touch one of the front panel Trigger buttons to begin acquisition.

Tip: Once acquisition has started, you can interrupt it at any time by pressing the front
panel Stop button. In this case, the segments already acquired will be retained in
memory.

View Sequence Segments
When in Sequence sampling mode, you can view individual segments easily using the front panel
Zoom button. A new zoom of the channel trace defaults to Segment 1.

You can view other segments by changing the First and total Num(ber) of segments settings on the
Zx dialog. Touch the Zx descriptor box to display the dialog.

Tip: By setting the Num value to 1, you can also use the front panel Adjust knob to scroll
through each segment in order.

Channel descriptor boxes indicate the total number of segments acquired in sequence mode. Zoom
descriptor boxes show the first segment displayed and total number of segments displayed ([#] #).
As with all other zoom traces, the zoomed segments are highlighted on the source trace.
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Example: You have acquired 10 segments. You choose to display segments 4 to 6—or, a total of
3 segments beginning with segment 4. The Cx descriptor box reads 10. The Zx descriptor box
reads [4]3, meaning you are displaying a total of 3 segments, starting with segment 4.

Besides using the Zoom feature, you can also create a Math (Fx) trace to display individual
segments.

1. From the menu bar, choose Math > Math Setup...

2. Touch a Function (Fx) tab to display its corresponding dialog.

3. On the dialog, touch Operator1 and select the Segment button from the pop-up menu.

4. Touch the Select subdialog tab.

5. Touch First Selected and choose the first segment to display.

6. Touch Number of Selected and enter the total number of segments to display.

To view time stamps for each segment:

1. From the Sequence dialog, choose Show Sequence Trigger Times.

Or

From the menu bar, choose Timebase > Acquisition Status, then open Trigger time .

2. Under Show Status For, choose Time.
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Clock Source Settings
An external reference clock, applied via the REF In input, is used to synchronize the instrument's
internal timebase to an external frequency source. This allows multiple instruments to lock their
timebases to a common source.

An external sampling clock, applied via the EXT input, replaces the internal timebase as the sampling
clock. This means that the external sampling clock controls when the digitizers sample the input
waveforms.

Since the external sampling clock uses the EXT input, an external trigger cannot be used when the
external sampling clock is in use.

Sample Clock
The default setting is to use the instrument's Internal clock. To use an external sample clock:

1. Connect a clock source of 50 Ohms or 1 M Ohm impedance to the EXT input using a BNC
cable.

2. Go to Timebase > Horizontal Setup and choose Real-time Sampling Mode.

3. On the Clock Source tab under Sample Clock choose from 0V, ECL, or TTL pulse types.

4. Choose an External Coupling that matches the input impedance.

Reference Clock
The default setting is to use the instrument's Internal 10 MHz clock. To use an external reference
clock:

1. Connect a clock source to the Ref In 10 MHz input using a BNC cable.

2. Go to Timebase > Horizontal Setup and choose Real-Time Sampling Mode.

3. On the Clock Source tab under Reference Clock choose External.

The WaveRunner 8000 accepts external reference clock frequencies of 10 MHz ± 25 ppm.
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History Mode
History Mode allows you to review any acquisition saved in the history buffer, which automatically
stores all acquisition records until full. Not only can individual acquisitions be restored to the grid,
you can "scroll" backward and forward through the history at varying speeds to capture individual
details or changes in the waveforms over time.

Each record is indexed and time-stamped, and you can choose to view the absolute time of
acquisition or the time relative to when you entered History Mode. In the latter case, the last
acquisition is time zero, and all others are stamped with a negative time. The maximum number of
records stored depends on your acquisition settings and the total available memory.

Press the front panel History Mode button, or choose Timebase > History Mode to access this
feature.

Entering History Mode automatically stops new acquisitions. To leave History Mode, press the
History Mode button again, or restart acquisition by pressing one of the front panel Trigger Mode
buttons.

Oscilloscope in History mode.
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Replay Acquisition History
This is a good way to begin using History Mode. Watching a "movie" of the history allows you to see
waveform changes that are invisible during real-time acquisition.

Select View History to enable the display, then use the Navigation buttons or the slider bar at the
bottom of the dialog to "scroll" the history of acquisitions.

l The top row buttons scroll: Fast Backward, Slow Backward, Slow Forward, Fast Forward.

l The bottom row buttons step: Back to Start, Back One, Go to Index (row #), Forward One,
Forward to End.

Press Pause when you see something of interest, then use the History table to find the exact Index.

Select Single Acquisition

1. Select View History to enable the display, and View Table to show the index of records.

2. Optionally, select to show Relative Times on the table.

3. View individual acquisitions by selecting the row from the table or entering its Index number on
the dialog.
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Trigger Settings
While the instrument continuously samples as long as a channel is turned on, it can only display up to
its maximum memory in data samples. Triggers select an exact event/time in the waveform to
display on the touch screen so that memory is not wasted on insignificant periods of the signal. The
trigger may be set on a single channel or a complex pattern of events across several channels.

Unless modified by a pre- or post-trigger Delay, the trigger event appears at point 0 at the center of
the grid, and an equal period of time before and after this point is shown to the left and right of it.

In addition to the trigger type, the trigger mode determines how the instrument behaves in the
presence or absence of a trigger event. Holdoff by time or event is available for some trigger types.

On instruments with Mixed Signal capabilities, many trigger types can be set on either analog
channels, including the External Trigger input, or digital lines.

Trigger Modes
The trigger mode is how the instrument sweeps, or refreshes, the display. This can be set from the
Trigger menu or from the front panel Trigger control group.

Auto mode sweeps after a preset timeout period if the trigger event has not occurred, so that the
display refreshes continuously. Otherwise, Auto functions the same as Normal when a trigger
condition is found.

In Normal mode, a sweep occurs only when the input signal achieves the trigger conditions.
Otherwise it continues to display the last acquired waveform.

In Single mode, one sweep occurs each time you choose Trigger > Single or press the front panel
Single button.

Stop pauses sweeps until you select one of the other three modes.

Trigger Types
These are the trigger types available for selection. If the trigger is part of a subgroup (e.g., Smart),
first choose the subgroup from among the basic types to display all the trigger options.

Basic Triggers
Edge triggers upon a achieving a certain voltage level in the positive or negative slope of the
waveform.

Width triggers upon finding a positive- or negative-going pulse width when measured at the specified
voltage level.

Pattern triggers upon a user-defined pattern of concurrent high and low voltage levels on selected
inputs. In Mixed-Signal oscilloscopes, it may be a digital logic pattern relative to voltage levels on
analog channels, or just a digital logic pattern omitting any analog inputs. Likewise, if your
oscilloscope does not have Mixed-Signal capability, the pattern can be set using analog channels
alone.

Measurement triggers when a certain measurement is found.
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TV triggers on a specified line and field in standard (PAL, SECAM, NTSC, HDTV) or custom composite
video signals.

Serial triggers on the occurrence of user-defined serial data events. This type will only appear if you
have installed protocol-specific serial data trigger and decode options.

MultiStage Triggers
MultiStage subgroup triggers establish dependencies between two or more distinct trigger events.
The events are set up exactly as are the basic triggers (Edge, Width, Pattern, etc.)

Cascaded triggers establish a succession of criteria in Stages A-D. Stage A arms the trigger, while
the trigger fires when stages B through D are achieved.

QualFirst arms the oscilloscope on the A event, then fires on all subsequent B events, saving each as
a sequence segment.

Note: This trigger is only enabled when using sequence sampling mode.

Qualified arms the trigger on the A event, then fires on the B event. In Normal trigger mode, it
automatically resets after the B event. The options for the B event depend on the type of A event.

Note: This functionality is identical to Teledyne LeCroy's previous Qualify and State triggers,
but presented through a different user interface.

Smart Triggers
The Smart subgroup triggers allow you to apply Boolean logic conditions to the basic signal
characteristics of level, slope, and polarity to determine when to fire the trigger.

Glitch triggers upon finding a pulse-width that is less than a specified time or within a specified range
of times.

Window triggers when a signal enters or exits a window defined by voltage thresholds.

Interval triggers upon finding a specific interval, the time (period) between two consecutive edges of
the same polarity: positive to positive or negative to negative. Use the interval trigger to capture
intervals that fall short of, or exceed, a specified range.

Dropout triggers when a signal loss is detected. The trigger is generated at the end of the timeout
period following the last trigger source transition. It is used primarily in single-shot applications with
a pre-trigger delay.

Runt triggers when a pulse crosses a first threshold, but fails to cross a second threshold before re-
crossing the first. Other defining conditions for this trigger are the edge (triggers on the slope
opposite to that selected) and runt width.

SlewRate triggers when the rising or falling edge of a pulse crosses an upper and a lower level. The
pulse edge must cross the thresholds faster or slower than a selected period of time.
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Trigger Set Up
To access the Trigger setup dialog, press the front panel Trigger Setup button or touch the Trigger
descriptor box.

To the left side of the Trigger dialog are the trigger Type selections. This is the primary selection;
other controls will appear depending on the trigger type selected (e.g., Slope for Edge triggers).
Complete those shown for your type.

The trigger condition is summarized in a preview window at the far right of the Trigger dialog. Refer to
this to confirm your selections are producing the trigger you want.

Source
For most trigger types, the Source is the analog channel or digital line to inspect for the triggering
condition.

Tip: When triggering on analog channels, the source can be easily set by dragging the desired
source channel descriptor box onto the Trigger descriptor box. Note that the trigger type will
revert to whatever was last set on that channel.

Pattern triggers may seek a pattern across multiple sources (such as a mix of analog and digital
signals), and likewise Multi-Stage triggers may use different sources for the arming and triggering
events.

Coupling
For analog triggers, specify the type of signal Coupling at the input.

l DC - All the signal’s frequency components are coupled to the trigger circuit for high frequency
bursts or where the use of AC coupling would shift the effective trigger level.

l AC - The signal is capacitively coupled. DC levels are rejected, and frequencies below 50 Hz
are attenuated.

l LFREJ - The signal is coupled through a capacitive high-pass filter network, DC is rejected and
signal frequencies below 50 kHz are attenuated. For stable triggering on medium to high
frequency signals.

l HFREJ - Signals are DC coupled to the trigger circuit, and a low-pass filter network attenuates
frequencies above 50 kHz (used for triggering on low frequencies).
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Slope/Polarity
For some triggers, such as Edge, you will be asked to select the waveform Slope (rising vs. falling) on
which the triggering event may occur.

For others, such as Width, the equivalent selection will be Polarity (positive vs. negative).

Level
For analog triggers, enter the voltage Level at which the triggering condition must occur. Use the Find
Level button to set the level to the signal mean.

Trigger types that require multiple crossings to define the triggering condition—such as Window,
SlewRate and Runt— will have Upper Level and Lower Level fields.

For digital triggers, the level is usually determined by the Logic Family that is set on the digital group.
This can also be specified by a custom (User-Defined) crossing Threshold and Hysteresis band.
Usually, there will be a separate Logic dialog tab for these triggers.

Conditions (Smart Triggers)
Smart triggers all allow you to apply Boolean logic to refine the triggering condition beyond simply
Level and Slope/Polarity.

The values that satisfy the operators of Less Than, Less Than or Equal To, Greater Than, etc. can
usually be set by entering an Upper Value and/or Lower Value.

In some cases, it is possible to set a range of values that satisfy the condition. The ranges may be In
Range, all the values in the range that is bounded by the upper/lower values, or Out Range, all values
outside the range bounded by upper/lower values.

The extent of the range can often also be specified by using a Nominal and Delta value, rather than an
absolute upper and lower value. In this case, the Nominal value sets the center of the range, and the
Delta determines how many units plus/minus the Nominal value are included in the range.

Patterns
A triggering pattern of low/high states across multiple inputs is used by the Pattern trigger type and
Multi-Stage triggers that include pattern triggers as either the arming or triggering event. Patterns
may be set on analog channels, digital lines, or a combination or both when Mixed-Signal capabilities
are available.

Digital Pattern
The Logic Bus method simplifies pattern set up by utilizing digital groups and logic you have already
defined on the Digital Setup dialogs. A digital pattern is set on a single bus (group) manually or by
applying a hexadecimal value, while the remaining lines are disabled ("Don't Care").

If you have not set up digital groups, you can set a digital pattern line by line using the Logic method.
All available lines remain active for selection.
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1. On the Trigger dialog, select Pattern trigger type. Open the Digital Pattern dialog.

2. At the far right of the dialog, choose either Logic Bus or Logic.

3. Optionally, deselect Filter Out Unstable Conditions. This default filter ignores short glitches in
logic state triggers that last less than 3.5 ns.

4. If using Logic Bus, touch Source and select the digital group. Any lines that are not in this
group will now be disabled.

5. To apply a digital logic pattern, either:

l Enter the hexadecimal value of the pattern in Hex or Value. Lines will take a logical 1, 0,
or X ("Don't Care") according to the pattern. Disabled lines will remain X.

l Touch the Dx button for each active line, and select whether it must be High or Low
compared to the logic threshold. Depending on your selection, a logical 1 (High) or 0
(Low) now appears on the dialog. Leave X selected for any line you wish to exclude from
the pattern. Use the Left and Right Arrow buttons to display lines in other digital banks.

Note: As an alternative to a pattern, you may set edge conditions on any line. Touch the
Dx button and choose the edge. Edge conditions always assume a logical OR in the
overall trigger criteria.

Tip: As you work, the checkboxes along the bottom of the dialog will change to show
the pattern. You can also use these checkboxes to make selections.

6. If you have not already set a logic threshold, open the Levels dialog and select a Logic Family
for each digital bank from which you've selected lines. To set a custom logic threshold, choose
Logic Family User Defined, then enter the Threshold voltage and Hysteresis.

Note: Digital lines inherit the Logic Setup made when defining digital groups. However,
you can change the logic threshold on the Levels dialog. The two settings are linked
and always reflect whatever was last selected. Logic thresholds can only be set per
lead bank, not individual line.

Analog Pattern

Tip: With the Mixed-Signal option, you can use the Digital Pattern dialog to set an analog
pattern as well as a digital pattern. For an analog-only rather than a mixed-signal pattern,
touch Set All To... and select Don't Care. This will eliminate any meaningful digital pattern and
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activate all the Boolean operators. Use the Left Arrow button to display the C1-EXT group of
inputs, and follow the procedure below to set the low/high pattern on each input.

1. Select the Boolean Operator (AND, NAND, OR, or NOR) that describes the relationship among
analog inputs (e.g., C1 must be High NAND C2 must be Low).

2. For each input to be included in the trigger pattern, select what State it must be in (High, Low,
or Don't Care) compared to the threshold Level you will set. Leave "Don't Care" selected for any
input you wish to exclude.

3. For each input included in the trigger, enter the voltage threshold Level.

4. If you've included EXTERNAL as an input, open the Ext tab and enter the Attenuation.

Multi-Stage Triggers
Multi-stage triggers arm the trigger on the "A" event, then fire on the "B" event or a series of events.
The options for the firing event(s) depend on the type of arming event. You may apply additional
Holdoff by time or number of events.

Note: The QualFirst trigger, which is used in Sequence sampling mode, is set up exactly like
the Qualified trigger. The only difference is that the B event is captured as a series of
sequence segments, rather than a single acquisition.

On the Trigger dialog, select MultiStage trigger type and choose Qualified, QualFirst, or Cascaded.

Then, on the Qualified, QualFirst, or Cascaded dialog, choose the arming and firing events.
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Besides an Edge or Pattern trigger, two special conditions may be selected as the arming event:

l State, any voltage measured above or below a threshold Level.

l PatState, a pattern that persists over a user-defined number of events or time. Like Pattern
triggers, PatState events may be analog voltage patterns, digital logic patterns, or a mix of
both, depending on the instrument's capabilities.

Once you've selected the arming and firing events, set up the conditions on the respective sub-
dialogs exactly as you would a single-stage trigger.

Measurement Trigger
Measurement triggers fire when the trigger source achieves the specified measurement. The
available measurements depend on your model instrument and the options installed, and each will
offer a different method for specifying the trigger condition, based on the type of measurement.
Generally, you will be able to specify a triggering value or range of values, and for @level parameters,
the voltage level at which the measurement must occur.

A measurement trigger is either the only trigger or the final trigger in a multi-stage chain of trigger
events including hardware triggers.

TV Trigger
TV triggers on a specified line and field in standard (PAL, SECAM, NTSC, HDTV) or custom composite
video signals.

1. Choose the Source signal input.

2. Choose the signal TV Standard. To use a custom signal, also enter the:
l Frame Rate
l # of Fields per line
l # of Lines
l Interlace ratio

3. Choose the Line and Field upon which to trigger.
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Serial Triggers
The Serial trigger type will appear if you have installed protocol-specific serial data trigger and
decode options. Select the Serial type then the desired Protocol to open the serial trigger setup
dialogs.

For serial trigger setup instructions, see the user's manual for your software option(s) at
teledynelecroy.com/support/techlib under Manuals > Software Options.

A 3.125 Gb/s Serial Trigger hardware option is available for WaveRunner oscilloscopes. This option
provides capability for 8b/10b symbol triggering. The trigger hardware is factory installed and is
permanently connected internally to C4. Complete information on the operation of this trigger can be
obtained in the High Speed Serial Triggers Instruction Manual at teledynelecroy.com/support/techlib
under Manuals > Software Options > 8b10b.

Trigger Holdoff
Holdoff is either a period of time or an event count that may be set as an additional condition for Edge
and Pattern triggers. Holdoff disables the trigger temporarily, even if the other conditions are met,
until the holdoff conditions are also met. The trigger fires when the holdoff has elapsed.

Use holdoff to obtain a stable trigger for repetitive, composite waveforms. For example, if the number
or duration of sub-signals is known, you can disable them by setting an appropriate holdoff value.
Qualified triggers operate using conditions similar to holdoff.

Hold Off by Time
This is a period of time to wait to fire the trigger, either since the beginning of the acquisition or since
the trigger conditions were met. You may achieve a stable display of complex, repetitive waveforms
by placing a holdoff condition on the time between successive Edge trigger events. This time would
otherwise be limited only by the input signal, the coupling, and the instrument's bandwidth. Select a
positive or negative slope, and a minimum time between triggers.

Positive Edge trigger with holdoff by time. The broken up-arrows indicate potential triggers which would occur without
holdoff. The bold arrows indicate where triggers actually occur when the holdoff has been satisfied.
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Hold Off by Events
For purposes of Hold Off, Events refers to the number of times the trigger conditions have been met,
counted either from the beginning of the acquisition or since the last trigger. For example, if the hold-
off is two events counted from the beginning of the acquisition, the trigger fires on the third event.

Positive Edge trigger with holdoff by events. The broken up-arrows indicate potential triggers which would occur without
holdoff. The bold arrows indicate where triggers actually occur when the holdoff has been satisfied.

Holdoff Set Up
To access the Trigger Holdoff dialog, choose Triggers > Trigger Setup from the menu bar or press the
front panel Trigger Setup button, then touch the Holdoff tab.

Choose to Holdoff by Time (clock) or Event. None disables Holdoff.

l If using Holdoff by Time, enter the Time in S to wait before triggering.

l If using Holdoff by Events, enter the number of Events to count before triggering.

Choose to Start Holdoff Counter On either:

l Acquisition Start, best for single-shot acquisitions.

l Last Trigger Time, best for acquiring repetitive waveforms.
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Software Assisted Trigger
Software Assisted Trigger is used to find the trigger-level crossing point closest to the hardware
trigger point. It then adjusts the time offset of the waveform so that it is aligned with the specified
trigger level and slope.

In the following figure, the white trace is the waveform at the input to software-assisted trigger
processing. The red trace shows it after processing, aligned with the trigger point indicated by the red
marker below the grid.

Note: This feature can only be used with an Edge trigger type in Normal trigger mode.

1. From the menu, choose Triggers > Trigger Setup, then touch the Software Assisted Trigger tab.

2. Touch Enable.

3. Create a trigger window by entering a Hysteresis value. This value sets a boundary above and
below the main trigger level to exclude noise.

4. Choose Auto or Normal mode; this determines the trigger behavior when trigger crossings are
not found in the trigger source waveform.

l Auto mode allows all waveforms through the channel.
l Normal mode allows waveforms only with a trigger crossing within the horizontal gate

region through the channel.
5. Set Start and Stop time values on the Horizontal Gate part of the Software Assisted Trigger

tab. These values control where in the waveform the software-assisted trigger processing
searches for trigger crossings.
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TriggerScan
TriggerScan is a debugging tool that helps you quickly discover waveform anomalies by automating
the process of building triggers designed to find rare events in an acquisition. TriggerScan:

l Trains the system by looking at normal acquired waveforms. During the training, TriggerScan
analyzes the waveforms to determine what waveforms normally look like. Using this
information, it generates a list of smart triggers to isolate abnormal situations.

l Loads the trigger setups from the Trainer and cycles them. As triggers occur, they are overlaid
on the screen. All acquisition settings are preserved, and you can use other tools to find the
root cause of these anomalies such as WaveScan, Histograms, etc.

Training TriggerScan
The TriggerScan Trainer inspects the current acquisition and automatically builds a list of trigger
setups that could potentially be used to find events of interest.

Note: Run the Trainer if you want to change the trigger types or if you change the channel or
signal. You must acquire and display at least 3 cycles of a signal before running the Trainer.

1. Touch Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.

2. Touch the Trainer button.

3. On the TriggerScan Trainer pop-up, choose the Source channel on which to train and trigger,
and select all the trigger types you want to set up.

4. Touch the Start Training button. When training is complete, a list of smart trigger setups is
displayed in the Trigger List.

Modifying Trigger List
Follow these steps to change the triggers created by TriggerScan. Once you have finalized the Trigger
List, you are ready to start scanning.

1. Choose Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.

2. Make any of the following modifications to the Trigger List:

l Add new trigger: touch the Trigger descriptor box and set up the new trigger as desired
on the Trigger dialog. Then, back on the TriggerScan dialog, touch the Add New button to
append the new trigger to the Trigger List.
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l Replace a trigger with one manually set up on the Trigger dialog: highlight the setup in
the Trigger List and touch the Update Selected button.

l Delete a trigger: highlight the setup in the Trigger List and touch the Delete Selected
button. All trigger setups can be deleted in one step by touching the Delete All button.

3. Optionally:

l Enter a Dwell Time the time instrument should wait before loading the next trigger.

l Check the Stop On Trigger checkbox. You can use this to isolate events as the triggers
find them.

Note: If you have Persistence enabled, all trigger events are recorded on the display.

Saving TriggerScan Setups
You can preserve the Trigger List by saving it to a setup file. The current Trigger List is not preserved
after exiting the application unless you manually save it.

1. On the TriggerScan dialog, touch Setup File Name and enter a file name, or touch the Browse
button and select a location and file name.

2. Touch the Save Setup... button.

To reload a saved Trigger List, touch the Browse button, locating the file, then touch Load Setup....

Running TriggerScan
When the Trigger List is set, touch the Start Scan button on the Trigger Scan dialog. The instrument
automatically cycles through all the triggers in the list.

To run only a single trigger, select it from the Trigger List and touch Load Selected. The trigger
settings are copied to the Trigger dialog and will be used when you start acquisition.
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Display
Display settings affect the number and style of grids that appear on screen and some of the visual
characteristics of traces, such as persistence.

Multi-Grid Display
The WaveRunner features multi-grid display, where each separate grid represents the full number of
256 vertical levels.

Auto Grid Mode is enabled by default. This feature adds a grid each time a new trace is opened, up to
16 grids, until no more grids are available. There are display options to show all traces on a Single
Grid, or to manually divide the display into different numbers and orientations of grids. The Grid Mode
icon shows what the result of the selection will be.

Q-Scape Multi-Tabbed Display
Available with the Q-Scape option, the Q-Scape Display Modes divide the screen into multi-tab
displays, each of which can be configured with a different multi-grid display mode. Many of the same
functions you can perform in Normal mode, such as moving traces by drag-and-drop, you can also
perform in Q-Scape modes.

When Q-Scape is installed, the Display Mode setting determines whether the touch screen has a
single display area ("Normal" mode) or tabs each representing a separate display (the various "Q-
Scape" modes). The Grid Mode setting determines how grids are configured within the display area
and what kind of traces they show (for example, XY or VT). Normal Display Mode (a single display) is
the default.

Multi-grid display.
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Display Set Up
To access the Display dialog, choose Display > Display Setup.

Display Mode (Q-Scape only)
The Display mode determines the number and layout of tabs, each being a unique display area.
Choose Normal (default), a single display with no tabs, or one of the three Q-Scape display modes:

l Q-Scape Single, a single set of four tabs stacked so that only one at a time is visible. Each tab
can have any style of grid mode, same or different.
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l Q-Scape Dual, two sets of four stacked tabs. Equivalent tabs in each set share the same grid
mode, but can display different traces. You can simultaneously view one tab from each set, but
they must be different tabs (e.g., Tab 1 from set one and Tab 3 from set two).

l Q-Scape Mosaic, a single set of four tabs arranged so that all are viewed simultaneously. Note
that the decoder table appears only in Tab1, since it is part of the display associated with the
trace in that tab. However, in the Q-Single example above, the table appears along the entire
bottom of the window, because Tab1 takes up the entire display area, whereas here Tab1
takes up only the upper left quadrant of the display.

In Q-Scape modes, channel, math, memory, and zoom descriptors appear in the tab where the trace is
open, while Timebase and Trigger descriptors remain outside the tabs, since they are not associated
with any one trace.
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Note: If you switch from Normal mode into any Q-Scape mode, all traces will move to Tab 1,
from which you can drag-and-drop to redistribute them to other grids. In Q-Scape Single mode,
you will not be able to drag-and-drop traces across tabs, only to other Tab1 grids.

To rename Q-Scape tabs after they open:

1. Touch-and-hold (right-click) on the Tab <#> until Rename pops up.

2. Touch Rename.

3. Enter the New Alias, then touch OK.

Extended Display
If you have an external monitor installed, you can extend the display to take advantage of the greater
screen area.

1. On the Display dialog, select Extend Grids Onto 2nd Monitor. The Select Grid pop-up opens,
showing the Single Display menu.

Note: This checkbox only appears when a second monitor is connected. Be sure
Windows is configured so that the instrument is the primary display and to extend, not
duplicate, the display.

2. Switch to the Extended Display submenu and choose a Grid style. Tab 1 and the external
monitor will share the same grid style.

3. Drag-and-drop descriptor boxes to place traces on the desired grids.

Tip: To take advantage of more grid styles on the larger display, choose File > Windowed on
the instrument, then grab the window title bar and drag it to the external monitor screen. Drag
the Extended Display window to the instrument screen.

Grid Mode
Touch the Grid button, then select one of the grid modes. In Normal Display Mode, select one Grid
Mode. In Q-Scape Display Mode, select a Grid Mode for each tab. The selection icon shows the
number and arrangement of grids.
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Normal display with a multi-grid mode.

Q-Mosaic display showing four distinct grid modes in each tab.

Grid Mode Number Orientation Notes

Auto
(default)

variable landscape Automatically adds or deletes grids as traces turned on/off, up to the maximum
supported

Single 1 landscape All traces share one grid

Dual 2 landscape One top, one bottom

Tandem 2 portrait One left, one right

Triplex 3 landscape Stacked top to bottom

Triad 3 portrait Left, center, right
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Grid Mode Number Orientation Notes

Quad 4 landscape Stacked top to bottom

Quattro 4 landscape One in each quarter of screen

Octal 8 landscape Two columns of four stacked top to bottom

Twelve 12 landscape Three columns of four stacked top to bottom

Sixteen 16 landscape Four columns of four stacked top to bottom

XY 1 portrait Single XY type grid

XYSingle 2 portrait One VT grid left, one XY grid right

XYDual 3 variable Two VT grids left, one XY grid right

Note: Additional grid modes may become available with the installation of software options.

Grid Intensity
To dim or brighten the background grid lines, touch Grid Intensity and enter a value from 0 to 100.

Grid on top superimposes the grid over the waveform.

Note: Some waveforms may be hidden from view with the grid on top.

Axis labels display the values represented by each division of the grid, based on your vertical scale
and timebase. Turned on by default, they may appear as absolute values or delta from center (0).
Deselect the checkboxbox to remove them from the display.

Trace Intensity
Choose a line style for traces: solid Line or disconnected sample Points.

When more data is available than can actually be displayed, Trace Intensity helps to visualize
significant events by applying an algorithm that dims less frequently occurring samples. Touch
Intensity and enter a value from 0 to 100.

Intensity 40% (left) dims samples that occur ≤ 40% of the time to highlight the more frequent samples,
vs. intensity 100% (right) which shows all samples the same.
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XY Plots
XY plots display the phase shift between otherwise identical signals. They can be used to display
either voltage or frequency on both axes, each axis now corresponding to a different signal input,
rather than a different parameter. The shape of the resulting pattern reveals information about phase
difference and frequency ratio.

Note: The inputs can be any combination of channels, math functions, or memories, but both
sources must have the same X-axis scale.

Choose an XY grid mode and select the sources for Input X and Input Y.

Sequence Display Mode
Use these settings to select the Display Mode used when sampling in Sequence mode.
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Persistence Display
The Persistence feature retains waveform traces on the display for a set amount of time before
allowing them to gradually "decay," similar to the display of old phosphor screen oscilloscopes.

The Persistence display is generated by repeated sampling of the amplitudes of events over time,
and the accumulation of the sampled data into display maps. These maps create an analog-style
display. Statistical integrity is preserved because the duration (decay) is proportional to the
persistence population for each amplitude or time combination in the data.

Use Persistence to accumulate on-screen points from many acquisitions to see your signal change
over time. The persistence modes show the most frequent signal path in three-dimensional
intensities of the same color (Analog), or graded in a spectrum of colors (Color). You can show
persistence for any channel, math function, or memory.

Access the Persistence dialog from the Display dialog or by choosing Display > Persistence Setup.

Apply Persistence
1. Check Persistence On.

2. To set up all traces together, touch All Locked. This constrains all input channels to the same
persistence settings.

To set up traces individually, touch Per Trace.

3. Use the buttons to select a persistence mode:

Color Mode persistence works on the same principle as Analog
persistence, but instead uses the entire color spectrum to map signal
intensity: violet for minimum population, red for maximum population.
In this mode, all traces use all colors, which is helpful for comparing
amplitudes by seeking like colors among the traces.

In Analog Mode, as a persistence data map develops, different
intensities of the same color are assigned to the range between a
minimum and a maximum population. The maximum population
automatically gets the highest intensity, the minimum population gets
the lowest intensity, and intermediate populations get intensities in

between these extremes. The information in the lower populations (for example, down at the
noise level) could be of greater interest to you than the rest. The Analog persistence view
highlights the distribution of data so that you can examine it in detail.
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3d Mode persistence creates a topographical view of your waveform from a selection of
shadings, textures, and hues. The advantage of the topographical view is that areas of highest
and lowest intensity are shown as peaks and valleys, in addition to color or brightness. The
shape of the peaks (pointed or flat) can reveal further information about the frequency of
occurrences in your waveform. You choose the Quality of the 3D display:

Solid quality can be either color or monochrome. Saturation is set at
50%, with hotter colors indicating highest intensity.

In the monochrome view of solid, the lightest areas indicate highest
intensity, corresponding to the red areas in the color view.

In shaded (projected light) quality, the shape of the pulses is
emphasized. This quality is monochrome only.

In wire frame quality, lines of equal intensity are used to construct the
persistence map. This display can be either color or Monochrome.

In 3d mode, X Axis Rotation and Y Axis Roation can range 180° from -90° to +90°. In the
examples above, the X-axis is rotated 60° an the Y-axis 15°.

Tip: To quickly rotate the graph, grab a corner of the persistence map and drag it in the
desired direction.

4. Select the Saturation level as a percentage of the maximum population. All populations above
the saturation population are assigned the highest color intensity: that is, they are saturated.
At the same time, all populations below the saturation level are assigned the remaining
intensities. Data populations are dynamically updated as data from new acquisitions is
accumulated. A saturation level of 100% spreads the intensity variation across the entire
distribution; at lower saturation levels the intensity will saturate (become brighter) at the
percentage value specified. Lowering this percentage causes the pixels to be saturated at a
lower population and makes visible those events rarely seen at higher saturation levels.

5. In Persistence Time, enter the duration of time (in seconds) after which persistence data is
erased from the display.

6. Choose to superimpose the last waveform over the persistence display by selecting Show Last
Trace (not available in 3d mode).

7. To display persistence traces as a continuous line (instead of a series of sample points),
select Dot Joined.

Remove Persistence
To turn off persistence and return to the regular trace style, clear Persistence On or select an
individual trace's None (left-most) persistence mode button.

76



Math and Measure

Math and Measure
Teledyne LeCroy offers a rich set of standard, pre-programmed tools for the "quickest time to insight"
into the characteristics of acquired waveforms. Most instruments calculate measurements for all
samples in an acquisition, enabling you to rapidly and thoroughly calculate thousands or millions of
parameter values and apply a variety of mathematical functions to the input waveform trace.

A wide variety of hardware and software options may be purchased to enhance these basic features.
See Advanced Analysis.

Cursors
Cursors are markers (lines, cross-hairs, or arrows) that identify voltage and time values on the
waveform. Use cursors to make fast, accurate measurements of specific points in the waveform.
There are five, standard cursor types available.

Vertical (amplitude) cursor readouts appear the trace descriptor box; Horizontal (time) cursor
readouts appear below the Timbebase descriptor box.

Cursors can be placed on math functions whose X-axis has a dimension other than time, such as an
FFT. When there is at least one non-time-domain math trace open, the Standard Cursors dialog
contains an X-Axis control where you can choose the units measured by the horizontal cursors. The
options will be appropriate to the types of function traces open; for example, if there is an FFT trace,
there is an option for Hz. The cursor lines are placed on the traces that normally display X-axis values
in the selected units.

Horizontal and vertical relative cursors.
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Cursor Types
Horizontal (Time) cursors intersect a point on the horizontal axis.

l Horizontal Abs displays a single, dashed, vertical line. The readout shows the absolute value at
the cursor location.

l Horizontal Rel displays two, dashed, vertical lines. The readout may be in absolute values or a
delta of the two points, depending on the Show option selected.

Vertical (Amplitude) cursors intersect a point on the vertical axis.

l Vertical Abs displays a dashed, horizontal line. The readout shows the absolute value at the
cursor location.

l Vertical Rel displays two dashed, horizontal lines. As with Horizontal Relative cursors, the
readout may show absolute values or a delta.

The Both Rel(ative) option places both Vertical and Horizontal relative cursors together.

Apply and Position Cursors

Apply Cursors
To turn on cursors, either:

l From the menu bar, choose Cursors and select the desired cursor type from the drop-down list.

l On the front panel, press the Cursor Type button repeatedly to cycle through all the cursor
types. Stop when the desired type is displayed.

Note: There must be a waveform on the grid for cursors to execute, although acquisition may
be in process or stopped when you turn them on.

To turn off cursors, choose Cursors > Off, or continue cycling the button until they disappear.

Position Cursors
The easiest way to reposition a cursor is to drag-and-drop the cursor marker to a new position.
Indicators outside the grid show to which trace the cursor belongs when you have multiple traces on
one grid.

Alternatively, turn the front panel Cursors knob. If both vertical and horizontal cursors are turned on,
push the knob until the correct line is selected, then turn to move it. When there are multiple traces
each with its own cursors on the same grid, bring the desired trace to the foreground by touching the
trace or its descriptor box. The Cursors knob will only operate on the foreground trace.

If Horizontal cursors are applied to a source trace but do not appear on its dependent traces (e.g., a
zoom) because of differences in scale, you can drag-and-drop the cursor readout from below the
Timebase descriptor box onto the target trace or its descriptor box. This applies the same cursors at
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the 5 (for single cursors) or 2.5 and 7.5 (for relative cursors) division marks of the target trace and
adjusts the source cursors accordingly.

Note: Horizontal Relative cursors are initially placed one on the negative side of the X-Axis
(marked by a ⬇ down arrow) and one on the positive side (marked by an ⬆ up arrow). If you
move the negative cursor to the right of the positive cursor, or the positive cursor to the left of
the negative cursor, the delta will be shown in negative increments.

Use the Position data entry controls on the Standard Cursors dialog to place cursors precisely.

Standard Cursors Dialog
These controls can be used instead of the front panel controls to set cursors or to refine the cursor
position. Access the dialog by choosing Cursors > Cursors Setup from the menu bar.

Cursors On displays or hide cursor lines. When first checked, the last selected cursor type is
displayed.

Cursor Type buttons select the type of cursor displayed on the grid.

The Show controls determine which values are shown in the readout, particularly when using relative
cursors:

l Absolute shows specific voltages for the two cursor locations.

l Delta shows the difference between the specific voltages at the cursor locations.

l Abs+Delta shows both the absolute and delta readouts.

l Slope (Horizontal Relative only) shows the slope of the waveform between the cursor
locations.

The Position controls at the right-side of the Standard Cursors dialog display the current cursor
location and can be used to set a new location. The options available depend on the Cursor Type and
Show settings.

l X 1 (negative) and X 2 (positive) sets time from the zero point.

l Y 1 (negative) and Y 2 (positive) sets number of divisions from the zero level. May be a fraction
of a division.

l Track locks cursor lines so they move together, maintaining their same relative distance from
each other.
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Measure
Measurement parameters are tools that give you access to a wide range of waveform properties. Use
them to analyze many attributes of your waveform such as rise-time, rms voltage, and peak-to-peak
voltage. Measurements can also be graphed as histrogram, track, or trend to facilitate analysis.

The instrument offers a quick selection of standard horizontal and vertical measurements, or you can
create a custom set of parameters (My Measure) drawn from all available measurements.

Measure Table
Measurement readouts appear in a table below the grid. The value row shows the measurements
taken for each parameter on the last cycle of the last acquisition. Other rows show optional statistics
for parameters.

Measurement Status Indicators
Symbols in the status row of the Measure table indicate the following:

Symbol Description

Problem with the signal or the setup. Touch cell and see explanation in the message bar.

Valid value returned.

Unable to determine top and base; however, measurement may still be valid.

Underflow condition.

Overflow condition.

Simultaneous underflow and overflow condition.

Navigating with the Table
It is helpful to close setup dialogs when the Measure table is displayed to maximize the touch screen
area available for viewing waveforms. The table can be used to quickly access the user-defined (My
Measure) setup dialogs and make modifications. To open the Parameter Setup (Px) dialog, touch the
Px cell of the table. Touch the far left Measure column to open the Measure dialog and modify the

80



Math and Measure

table contents. The table is static when using the standard measurements, as these cannot be
changed.

Quick Table Setup
Any parameter can be copied by dragging the cell onto the target cell of the table. Then, drag the
desired measurement source descriptor box onto the new parameter. Touch the cell to make any
other modifications on the Px dialog.

Measure Dialog
The Measure Dialog gives quick access to measurement display features. Besides turning on/off
parameters, use the Measure dialog to show Statistics, Histicons, or Help Markers for standard and
user-defined parameter sets. You can also Gate standard parameters to limit the horizontal scope of
the measurement. All standard parameters will share the same gate. (Use the Px dialogs to gate
user-defined parameters.)

To open the Measure dialog, touch the Add New box and select Measurement, or choose Measure >
Measure Setup from the menu bar.

Parameter Sets
Pre-configured standard parameter sets are available for quick display. Choose either:

l Std Vertical: mean, sdev, max., min., ampl, pkpk, top, base.

l Std Horizontal: freq, period, width, rise, fall, delay, duty, num points.

To define your own parameter set, choose My Measure. Open the Px dialogs to define new
parameters. Once parameters are configured, , select the On checkbox next to each parameter to turn
on the measurement.

To quickly begin a new parameter set based on the standard vertical or horizontal sets, touch Quick
Setups and choose the set to copy. Refine the settings on the Px dialogs.Touch Clear All to remove
all measurement definitions.

Caution: Measurement definitions cannot be restored after clearing. You must repeat the
manual set up.
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Statistics
You can add the statistical measures mean, min., max., sdev, and num(ber of measurements
computed) to the table by checking Statistics On, or by choosing Measure > Statistics from the menu
bar.
For any parameter that computes on an entire waveform (like amplitude, mean, minimum, maximum,
etc.) the num statistic represents the number of sweeps.

For any parameter that computes on every event, the num statistic represents the number of events
per acquired waveform. If x waveforms were acquired, num is x times the number of cycles per
waveform.

To reset the statistics counter, touch Clear Sweeps on the display or front panel.

Histicons
Histicons are miniature histograms of measurement parameters that appear on the measurement
table. These thumbnail histograms let you see at a glance the statistical distribution of each
parameter. Select the Histicons checkbox to turn on histicons.

Tip: You can quickly display a full histogram by touching the histicon you want to enlarge.

Help Markers
Help Markers clarify measurements by displaying cursor lines and labels marking the points being
measured on the trace. For "@Level" parameters, markers make it easier to see where your waveform
intersects the chosen level. This feature also displays any hysteresis band that you have set about
that level.

You can choose to use Simple markers, which are only the lines, or Detailed markers, which include
the measurement point labels.

You also have the option, by means of the Always On checkbox, to leave the markers displayed over
traces after you have closed the Measure dialogs or readout table. If you change the set of
parameters displayed, the markers will change, as well.

Note: Unlike regular cursors, which are white and can be moved, help markers are blue and
only augment the display; they cannot be moved, and they do not reset the measurement
points. Some optional analysis software packages include markers designed specially for
that domain of reference, which are documented in the option manual.

82



Math and Measure

Detailed Help Markers on standard horizontal parameters.

Parameter Set Up
Use the Px dialogs to define a new set of measurement parameters ("My Measure").

You may also define parameters using Math on Parameters or the Web Editor.

1. From the menu bar, choose Measure > Measure Setup. On the Measure dialog, select Show
Table to display the readout on screen.

Tip: To quickly reopen the Measure Setup dialog, touch any cell of the Measure readout
table.

2. Choose Measure Mode My Measure.

3. Open the Px tab of an unused location (or one that you want to change).

4. Check On to enable the parameter and add it to the measurement readout table.

5. Select the Type Measure On Waveforms.

6. Touch Source1 and select the channel, math trace, memory trace, or other waveform to be
measured.

7. Touch the Measure field and select the measurement from the pop-up menu.
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8. Enter the measurement Level and Type (percent or absolute) when it appears on the parameter
subdialogs (e.g., for @Level parameters).

9. For certain time-based measurements, choose to measure on the positive, negative, or both
Slope(s). For two-input parameters, such as Dtime@level, you can specify the slope for each
input, as well as the level and type.

10. Make any further selections on the subdialogs that appear after your Measure selection. These
are explained on the dialog and are necessary to fully define the selected measurement.

11. Optionally, turn on Help Markers, or use the parameter subdialogs to:

l Gate measurements (limit the horizontal scope of the measurement)

l Qualify measurements (accept only measurements that meet additional conditions)

Note: In some applications, such as certain serial decoders, you will also see a Filter
subdialog. This enables you to apply additional types of filters specific to the serial
data measurements.

Gating Measurements
By using gates, you can narrow the span of the waveform on which to perform tests and
measurements, allowing you to focus on the area of greatest interest. For example, if you "gate" five
rising edges of the waveform, rise time calculations are performed only on the five pulses bounded by
the gate posts.

The default starting positions of the gate posts are 0 div and 10 div, which coincide with the left and
right ends of the grid. Therefore, the gate initially encloses the entire waveform.

The quickest way to set a gate is to drag the gate posts from the far left and right of the grid to the
desired positions. You can refine this setting by specifying a position down to hundredths of a
division using the Gate Start and Stop fields.

Touch the Default button to return gates to the width of the trace.

Qualified Measurements
Some measurements can be constrained to a vertically or horizontally limited range, or to
occurrences gated by the state of a second waveform. Both constraints can operate together. This
capability enables you to exclude unwanted characteristics from your measurements. It is much
more restrictive than a measure gate, which is used only to narrow the span of analysis along the
horizontal axis.

Note: Since this feature operates on only a subset of the data, possible alerts or status
indicators concerning the measurement (such as "Data range too low") are not displayed.

If the measurement supports this feature, you will see the Accept subdialog next to the Px dialog for
you to define your constraints.
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Range Limited Parameters

1. From the menu bar, choose Measure > Measure Setup..., then touch the Px tab to open the
parameter setup dialog.

2. On the Accept subdialog, select Values In Range and enter the start and stop values, or touch
the Find Range button to quickly display the most recently measured range of values.

Note: Depending on whether it is a vertical or horizontal measurement, the correct units
are automatically displayed (V, s, Hz, dB) in Between and And. If you select a simple
ratio parameter (such as power factor) that yields a dimensionless number, no units
will be displayed.

Waveform Gated Parameters

1. From the menu bar, choose Measure > Measure Setup, then touch the Px tab to open the
parameter setup dialog.

2. On the Accept subdialog, select Values Based on Waveform State.

3. Touch When Wform and select the gating waveform. It can be any waveform active at the
same time as the measurement source waveform.

4. Touch State Is and select High or Low from the pop-up menu. Measurements will only be taken
when the gating waveform is in the selected state.

5. Touch Level Type and select Absolute (voltage) or Percent (of amplitude) from the pop-up
menu.

6. Enter the crossing Level value at which you want measurements to begin.

You can also touch the Find Level button to automatically set the level at 50% of the gating
waveform.
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Math on Parameters
In addition to waveform measurements, you can set up a parameter that performs mathematical
operations on measurements.

The setup for Math on Parameters is much like that for other parameters. Some parameters can also
be qualified on the Accept dialog using value ranges or gating waveforms, as can regular waveform
measurements.

Math on Parameters differs from Math functions in that the input and the output are still numerical
values that display in the measurement readout table. Math functions, on the other hand, input and
output waveform traces that appear on the grid.

Exclusions
The parameter math feature prevents multiplication and division of parameters that return
logarithmic values.

Parameters that are already the result of parameter math operations are also excluded. If they are
included in a remote control setup command, an error message is generated and the setup canceled.

Set Up Math on Parameters

1. From the menu bar, choose Measure > Measure Setup....

2. Choose Measure Mode My Measure and open a parameter setup (Px) dialog.

3. Touch the Math on Parameters button.

4. Touch Math Operator and choose an operation from the Select Measurement menu.

5. Touch the Source fields and select the parameters that are the inputs to the measurement.
These should be other parameters than that you are now using for Math on Parameters.

6. Check On to enable the new output parameter and add it to the measurement readout.
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Using Web Editor
Whereas with Math on Parameters you can apply a single math operation to a measurement
parameter, the Web Editor enables you to create custom processes that potentially chain many
operations and apply them to the output of a single parameter or math function. These processes are
integral to the operation of the instrument; there is no need to export data to other programs.

Processes are "programmed" in the X-Stream application simply by dragging and dropping a series of
blocks representing different math functions or measurements and connecting them to form a flow
chart—a "processing web." The parameter value shown in the Measure table represents the numeric
result of this process flow applied to the raw, acquired sample. Math functions would likewise
display the waveform trace that results from the process.

Create Processing Web

1. From the menu bar, choose Measure > Measure Setup.

2. On the Measure dialog, choose Measure Mode My Measure.

3. Open the Px dialog of an unused parameter (or one that you want to change) and select
Advanced Web Edit.

4. Touch the Show Processing Web button. You will see a "peg board" display with potential input
sources aligned along the left, and a terminal marked with the parameter number to the far
right.

Tip: On the Source Filter subdialog, deselect any types (e.g., zooms) that you do not
want to use in the process. This simplifes the display and reduces the need to scroll.
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5. On the Wed Editor dialog, choose the type of process to add to the flow. You can Add Math, Add
Measure, or Add Param Math (Math on Parameters).

6. From the pop-up, choose the operation or measurement that will occur at that node. A new
block appears on the display. Drag the block to a location in the flow.

Tip: Touch the location to place a green plus sign before adding the node. Then, the
new block will be created at this spot. Otherwise, blocks may cover one another until
they are moved.

7. The process block will have a input "pin" on the left. If a waveform is required, the pin is blue; if
a number is required, the pin is purple. Touch and drag a matching colored pin from the
sources on the left of the screen to the block. Choose as many sources as there are input pins
on the block.

Tip: You may need to use the scrollbar to see all the available sources. For
convenience, the Math and Measure dialogs behind the Web Editor dialog summarize
what is currently configured for those sources.

When you drop the pin, a line is drawn from the source to the process. If a source is
incompatible with a process, you will not be able to pin it.
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8. If the process requires additional configuration, a subdialog appears next to the Web Editor
dialog. Use it to enter the values to apply to that processing node.

9. Continue to add processes as needed, pinning the output of each block to the input of the next
block in the flow. The final process should be the same type as the terminal (in this example, a
measurement).

Note: The flow does not need to be strictly sequential, as many processes can accept
multiple inputs that may or may not have undergone other processes. The only
requirement is that the outputs are pinned to acceptable inputs. The color of the
input/output arrows indicates which connections are compatible.

10. Drag the output pin from the final process block to the input pin on the terminal to complete
the flow.

Preview Outputs
You can add preview "windows" to see the output of a process at any stage in the flow. These
previews apply only to the Web Editor.

Select the output pin of the processing block you wish to preview. It will turn bright green. Then, on
the Web Editor dialog choose Add Preview.

Delete Process/Connection
To delete any process from the web, select the block then touch Delete. All the connections to/from
it are automatically deleted.
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To remove a connection between process blocks, touch the line. A scissor icon appears above it.
Confirm whether or not to "cut" the connection.

Add Other Terminals to Processing Web
Other measurements or math functions can share the same processing web. For example, you may
wish to create a math function of the waveform that would result from a sub-processing node, while
the final output of the full process is a measurement parameter.

To add a terminal:

1. Open the Math or Measure dialog behind the Web Editor dialog.

2. Touch the Web Edit icon following the location (Px or Fx). The summary changes to Web Edit,
and a new terminal block appears on the Web Editor peg board.

3. Connect the output pin of the desired process to the input pin of the terminal. You can select
outputs that are already pinned to other blocks.
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Graphing Measurements
Measurements can be viewed in several graphical formats to facilitate your analysis:

l Histograms display the distribution of measured values for a given parameter as a bar chart.

l Tracks provide a time-correlated view of a measurement parameter compared to other
acquired channels or calculated math traces. A common usage for track is to observe the
modulation of a signal, such as amplitude, frequency, or pulse width modulation.

l Trends provide a view of a measurement parameter over an extended period of time and over
multiple acquisitions.

Action buttons at the bottom of the the Parameter (Px) dialogs let you quickly draw these plots for the
respective measurement.

Although these graphs plot measurement values, they are generated on the display as math functions
(Fx) and can be set up through either the Measure or Math dialogs.

Histogramming
Histograms are graphical representations of data which divide it into intervals, or bins. These
intervals/bins are plotted on a bar chart such that the bar height relates to the number of data points
within each bin.

Histograms can be created to visualize the results of measurement parameters or
math functions. Regardless of the source, the histogram is created as a Histogram
function (Fx) trace, and the number of sweeps (k#) comprising the histogram is
shown on the function descriptor box. The Phistogram function creates a histogram

of a persistence display.
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The range of a histogram is limited to the portion of the (measurement or math) source trace that is
visible on screen. If you zoom in on a trace, the histogram does not contain data for the no longer
visible parts of the original trace.

Thumbnail versions of measurement parameter histograms are called Histicons. They are available
as a checkbox option on the Measure dialog. Histicons appear on the measurement parameter table,
rather than as a new math trace.

Histogram Function
To create a histogram of a measurement:

1. Open the parameter setup (Px) dialog for the measurement you wish to histogram.

Tip: A quick way to do this is to touch the measurement table cell.

2. Touch the Histogram toolbar button at the bottom of the Px dialog and choose the function
location (Fx) in which to display the histogram. The histogram opens in a new grid along with
its function descriptor box.

3. Touch the new hist descriptor box to display the Fx dialog, then open the Histogram subdialog.

4. Enter the maximum #Values in one bin of the histogram. This determines the number of
samples that are represented by the bar at full height.

5. Touch #Bins and enter the number of bins that comprise the histogram. This determines how
many bars appear in the histogram.

6. To let the software determine the range of values represented by each bin/bar, check Enable
Auto Find, then touch the Find Center and Width button.

To set your own range, enter Center and Width values.

7. Choose a Vertical Scale method:

l Linear allows the histogram to build vertically as data accumulates. When the
histogram reaches the top of the display, it rescales the vertical axis to keep it on
screen

l LinConstMax keeps the histogram at near full scale and rescales the vertical axis as
data is accumulated.
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Phistogram Function
The Phistogram function creates a histogram of the samples within a horizontal or vertical “slice” of
a persistence map. You must apply persistence to the function source trace to generate the
persistence map.

Note: This operation is different than the Histogram math operation and is not affected by
Center and Width settings made on any existing Histograms.

1. Follow the usual steps to set up a math function, choosing a Single operator function using the
Phistogram operator.

2. On the Phistogram subdialog, enter values to select the slice of the persistence map to
histogram:

l Slice Direction of determines whether the slice transverses the entire height of the map
centered around a time (vertical), or transverses a period of time in the map centered
around a level (horizontal).

l Slice Center represents the center time or level of the slice.

l Slice Width represents the total time or amplitude of the slice, half each side of the
center.

3. Choose to Center Cursor to place a measurement cursor at the center of the slice.

93



WaveRunner 8000 Oscilloscopes Operator's Manual

Track and Trend
Both Track and Trend are tools that can be used to plot measurement data and observe variations
with respect to time. The table below summarizes their differences.

In general, Track is the tool to use if you want to capture a continuous stream of data spaced closely
together.

To understand the change in a parameter with time, Trend can be used if your data is spaced widely
apart and longer than the dead-time between acquisitions. Think of Trend as a strip chart recorder for
your instrument.

Characteristic Track Trend

Representation Parameter value vs. time Parameter value vs. event

Behavior Non-cumulative (resets after every
acquisition). Unlimited number of
events

Cumulative over several acquisitions
up to 1 million events

Time Correlation to Other Data Yes No

Monitors an Evolution in the Fre-
quency Domain

Yes No. Trend points are not evenly spaced
in time and therefore cannot be used
for an FFT.

Monitors the Evolution of a Meas-
urement Parameter over Several
Acquisitions

No. Track resets after every acquis-
ition.

Yes

Ensures No Lost Measurement Data Yes. Maximum time period that can be
captured is limited by acquisition
memory and sampling rate.

No. Since data can be accumulated
over many acquisitions, and since the
instrument takes time to calculate meas-
urement values and to display data
before the trigger is re-armed, data can
be missed.
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Track
A Track is a plot composed of parameter measurements that is time synchronous with the source
waveform. The vertical units are those of the source parameter and the horizontal units are seconds.
In order to maintain time synchronism, the parameter values are posted at the sampling rate. Track
values are redundant in that the same value is repeated every sample period until the measurement
changes.

1. Open the parameter setup (Px) dialog for the measurement you wish to track.

Tip: A quick way to do this is to touch the measurement table cell.

2. Touch the Track toolbar button at the bottom of the Px dialog and choose the function location
(F1-F12) in which to display the plot. The track opens in a new grid along with its function
descriptor box.

3. Touch the new Track descriptor box to display the Fx dialog, then open the Track subdialog.

4. On the Track subdialog, uncheck Auto Find Scale and enter a new Center and Height/div. You
can also use Find Scale to automatically find suitable values.

5. Choose a line Connect function of either Interpolate or Extend.
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Trend
A Trend is a plot composed of a series of parameter measurements in the order the measurements
were taken. The vertical units are those of the source parameter, the horizontal unit is measurement
number. The Trend contains a single value for each measurement. Trends are especially useful for
visualizing the history of a parameter over an extended period of time or over multiple acquisitions.

1. Open the parameter setup (Px) dialog for the measurement you wish to histogram.

Tip: A quick way to do this is to touch the measurement table cell.

2. Touch the Trend button at the bottom of the Px dialog and choose the function location (Fx) in
which to display the plot. The Trend opens in a new grid along with its function descriptor box.

3. Touch the new Trend descriptor box to display the Fx dialog, then open the Trend subdialog.

4. Choose a computation Mode of All (plots multiple points per acquisition) or Average (plots one
point per acquisition). Enter the number of measured Values to Trend.

5. To rescale the Trend, uncheck Auto Find Scale and enter the new Center and Height/div values.
You can also use Find Scale to automatically find suitable values.
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List of Standard Measurements
The measurements included standard with your instrument are listed below alphabetically.

Note: Additional measurements may be available depending on the software options installed.

Measurement Description

Amplitude
(ampl)

Measures the difference between upper and lower levels in two-level signals. Differs from pkpk in
that noise, overshoot, undershoot, and ringing do not affect the measurement. Amplitude is cal-
culated by using the formula Top – Base. On signals not having two major levels (such as triangle
or saw-tooth waves), the amplitude parameter returns the same value as peak-to-peak.

Area Integral of data. Computes area of the waveform relative to zero level. Values > zero contribute
positively to the area; values < zero, negatively.

Base

Lower of two most probable states (higher is top). Measures lower level in two-level signals. Dif-
fers from min in that noise, overshoot, undershoot, and ringing do not affect measurement. On sig-
nals not having two major levels (such as triangle or saw-tooth waves), the amplitude parameter
returns the same value as minimum.

Bit Rate Bit rate of serial data stream.

Cycles
(cycles)

Determines number of cycles of a periodic waveform lying between cursors. First cycle begins at
first transition after the left cursor. Transition may be positive- or negative-going.

Delay
Time from trigger to transition: Measures time between trigger and first 50% crossing of specifies
signal. Delay can be used to measure the propagation delay between two signals by triggering on
one and determining delay of other.

Delta Delay
(ddelay)

Computes time between 50% level of two sources.

Dperiod@level
(dper@lv)

Adjacent cycle deviation (cycle-to-cycle jitter) of the period measurement for each cycle in a wave-
form. The reference level for this measurement can be specified.

Dtime@level
(dt@lv)

Computes the time between transitions of the selected sources at the specified levels. Only pos-
itive going transitions are counted.

Dtrig Time
(dtrig)

Time from last trigger to this trigger

Duration
(dur)

For single sweep waveforms, dur is 0; for sequence waveforms: time from first to last segment's
trigger; for single segments of sequence waveforms: time from previous segment's to current seg-
ment's trigger; for waveforms produced by a history function: time from first to last accumulated
waveform's trigger.

Duty Cycle Percent of period for which data are above or below the 50% level of the signal.

Duty@level
(duty@lv)

Percent of period for which data are above or below a specified level.

Dwidth@level Difference (delta) between adjacent widths above or below a specified level.

Edge@level
(edge@lv)

Number of positive edges in waveform that cross the specified threshold level.

Edge to Edge Delta time between some edge on the first source to some (other) edge on a second source.

Fall 80-20%
(fall8020)

Duration of pulse waveform's falling transition from 80% to 20% of the amplitude averaged for all
falling transitions between the measurement gates. On signals not having two major levels (tri-
angle or saw-tooth waves, for example), top and base can default to maximum and minimum, giv-
ing less predictable results.
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Measurement Description

Fall time
(fall)

Duration of pulse waveform's falling transition from 90% to 10% of the amplitude averaged for all
falling transitions between the measurement gates. On signals not having two major levels (tri-
angle or saw-tooth waves, for example), top and base can default to maximum and minimum, giv-
ing less predictable results.

Fall@level
(fall@lv)

Fall at level: Duration of pulse waveform's falling edges between user-specified transition levels.

Threshold arguments specify two vertical values on each edge used to compute fall time:
lower = lower thresh. x amp/100 + base
upper = upper thresh. x amp/100 + base

First Indicates value of horizontal axis at left cursor.

Frequency
(freq)

Period of cyclic signal measured as time between every other pair of 50% crossings. Starting with
first transition after left measurement gate. The period is measured for each transition pair. The
reciprocal of each period measurement is calculated as the frequency.

Freq@level
(freq@lv)

Period of cyclic signal measured as time between every other pair at the specified level. Starting
with first transition after left measurement gate. The period is measured for each transition pair.
The reciprocal of each period measurement is calculated as the frequency.

FWHM Measures the width of the largest area histogram peak at half of the populationof the highest peak.

FWxx Measures the width of the largest area histogram peak at xx% of the population of the highest
peak.

Half Period
(hper)

Half period of a waveform.

Hist ampl
(hampl)

Difference in value between the two most populated peaks in a histogram.

Hist base Value of the left-most of the two most populated histogram peaks.

Hist max pop Peak with maximum population in a histogram.

Hist maximum Value of the highest (right-most) populated bin in a histogram.

Hist mean Average or mean value of data in a histogram.

Hist median Value of the 'x' axis of a histogram that divides the population into two equal halves.

Hist minimum Value of the lowest (left-most) populated bin in a histogram.

Hist mode Position of the highest histogram peak.

Hist pop@x Population at bin for specified horizontal coordinate.

Hist range Calculates range (max-min) of a histogram.

Hist rms Root mean square of the values in a histogram.

Hist sdev Standard deviation of values in a histogram.

Hist top Value of the right-most of the two most populated histogram peaks.

Hist X@peak Value of the nth highest histogram peak. You supply the value of n.

Hold Time Time from the clock edge to the data edge.

Last Time from trigger to last (rightmost) cursor.

Level@X
(lvl@x)

Gives the vertical value at the specified x position. If the x position is between two points, it gives
the interpolated value. When the Nearest point checkbox is selected, it gives the vertical value of
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Measurement Description

the nearest data point.

MATLAB param Custom MATLAB function that produces a measurement.

Maximum
(max)

Measures highest point in waveform. Unlike top, does not assume waveform has two levels.

Mean Average of data for time domain waveform. Computed as centroid of distribution for a histogram of
the data values.

Median The average of base and top values.

Minimum
(min)

Measures the lowest point in a waveform. Unlike base, does not assume waveform has two levels.

N-cycle Jitter Peak-to-peak jitter between edges spaced n UI apart.

NBPhase Provides measurement of the narrow band phase at a specific frequency of the waveform.

NBPower Provides measurement of the narrow band power at a specific frequency of the waveform.

None Disables parameter calculation

Num Points
(npoints)

Number of points in the waveform between the measurement gates.

Overshoot-
Amount of overshoot following a falling edge. This is represented as percentage of amplitude.
Overshoot- is calculated using the formula (base - min.)/ampl x 100. On signals not having two
major levels (triangle or saw-tooth waves, for example), may not give predictable results.

Overshoot+
Amount of overshoot following a rising edge specified This is represented as a percentage of amp-
litude. Overshoot+ is calculated using the formula (max. - top)/ampl x 100. On signals not having
two major levels (triangle or saw-tooth waves, for example), may not give predictable results.

Peak to Peak
(pkpk)

Difference between highest and lowest points in waveform. Unlike ampl, does not assume the
waveform has two levels. Peak to peak is calculated using the formula maximum – minimum.

Peaks Number of peaks in a histogram.

Percentile
(pctl)

Horizontal data value that divides a histogram so the population to the left is xx% of the total.

Period The time between every other pair of 50% crossings. Starting with first transition after left meas-
urement gate, period is measured for each transition pair, with values averaged to give final result.

Period@level
(per@lv)

The time between every other pair of at the level specified. Starting with first transition after left
measurement gate, period is measured for each transition pair, with values averaged to give final
result.

Phase Phase difference between signal analyzed and signal used as reference. Both signals are meas-
ured from the 50% point of their rising edges.

Rise 20-80%
(rise2080)

Duration of pulse waveform's rising transition from 20% to 80% of the amplitude averaged for all
rising transitions between the measurement gates. On signals not having two major levels (tri-
angle or saw-tooth waves, for example), top and base can default to maximum and minimum, giv-
ing less predictable results.

Rise Time

Duration of pulse waveform's rising transition from 10% to 90% of the amplitude averaged for all
rising transitions between the measurement gates. On signals not having two major levels (tri-
angle or saw-tooth waves, for example), top and base can default to maximum and minimum, giv-
ing less predictable results.

Rise@level
(rise@lv)

Duration of pulse waveform's rising edges between user-defined transition levels. Threshold argu-
ments specify two vertical values on each edge used to compute rise time:
lower = lower thresh. x amp/100 + base
upper = upper thresh. x amp/100 + base
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Measurement Description

RMS

Root Mean Square of data (between gates) calculated using the formula:

Where: vi denotes measured sample values, and N = number of data points within the periods
found up to maximum of 100 periods.

Setup Time from the data edge to the clock edge.

Skew Time of Clock2 edge (nearest to Clock1) minus time of Clock1 edge. "Clock" refers to specified
edge and level of any two sources, data signals included.

Slew Rate
(slew)

Slew rate or local dV/dt in a transition zone

Std Dev
(sdev)

Standard deviation of the data between the measure gates using the formula:

Where: vi denotes measured sample values, and N = number of data points within the periods
found up to maximum of 100 periods. This is equivalent to the rms for a zero-mean waveform. Also
referred to as AC RMS

TIE@level
(tie@lv)

Difference between the measured times of crossing a given slope and level and the ideal expec-
ted time. For Slope you can choose positive, negative, or both. For output units you can choose
time or unit interval (UI). A unit interval equals one clock period. The Virtual Clock setup gives you
a choice of Standard (1.544 MHz) or Custom reference clocks. You can also use a mathematically
derived Golden PLL to filter low frequency jitter. The cutoff frequency is user selectable.

Time@level
(time@lv)l

Time from trigger (t=0) to crossing at a specified level.

Top

Higher of two most probable states (base is lower). Measures higher level in two-level signals. Dif-
fers from max in that noise, overshoot, undershoot, and ringing do not affect measurement. On sig-
nals not having two major levels (such as triangle or saw-tooth waves), the amplitude parameter
returns the same value as minimum.

Total Pop
(totp)

Total population of a histogram.

Width

Width of cyclic signal determined by examining 50% crossings in data input. If first transition after
left cursor is a rising edge, waveform is considered to consist of positive pulses and width the time
between adjacent rising and falling edges. Conversely, if falling edge, pulses are considered neg-
ative and width the time between adjacent falling and rising edges. For both cases, widths of all
waveform pulses are averaged for the final result.

Width@level
(wid@lv)

Width measured at a user-specified level.

WidthN
(widn)

Time of cyclic signal determined by examining 50% crossings in data input. The widthN is meas-
ured from falling edge to rising edge.

X@max Determines the horizontal axis location of the maximum value between the measure gate.

X@min Determines the horizontal axis location of the minimum value between the measure gate.
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EMC Pulse Parameter Software Package
The EMC option enhances the oscilloscope's measurement functionality for the @level parameters
Rise@Level, Fall@Level, Width@Level, Time@Level, and dTime@level.

In addition to setting the Level for these measurements using the absolute voltage or percentage of
amplitude based on the computed Top and Base Lines, you may set Level using:

l actual Peak to Peak

l 0V - Max

l 0V - Min

Once the option is activated, the new selections are added to the Level pop-up menu. Otherwsise,
parameters are configured exactly the same as with other measurements.

Histogramming is also enhanced with the ability to plot up-to-2-billion events when configuring the
histogram and the addition of 19 histogram-specific measurements. To set up one of these
measurements in a parameter location, select the Math function (Fx) location of the histogram as the
measurement Source.

Calculating Measurements
The instrument uses the following methods to calculate measurements.

Determining Top and Base Lines
Proper determination of the top and base reference lines is fundamental for ensuring correct
parameter calculations. The analysis begins by computing a histogram of the waveform data over the
time interval spanned by the left and right measurement gates. For example, the histogram of a
waveform transitioning in two states will contain two peaks (see figure). The analysis will attempt to
identify the two clusters that contain the largest data density. Then the most probable state
(centroids) associated with these two clusters will be computed to determine the top and base
reference levels: the top line corresponds to the top and the base line to the bottom centroid.
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Determining Rise and Fall Times
Once top and base are estimated, calculation of the rise and fall times is easily done (see figure).
The appropriate threshold levels are automatically determined by the instrument, using the amplitude
(ampl) parameter.

Threshold levels for rise or fall time can also be selected using absolute or relative settings ( if
@level measurements are included with your model). If absolute settings are chosen, the rise or fall
time is measured as the time interval separating the two crossing points on a rising or falling edge.
But when relative settings are chosen, the vertical interval spanned between the base and top lines is
subdivided into a percentile scale (base = 0 %, top = 100 %) to determine the vertical position of the
crossing points.

The time interval separating the points on the rising or falling edges is then estimated to yield the
rise or fall time. These results are averaged over the number of transition edges that occur within the
observation window.
Rising Edge Duration

Falling Edge Duration

Where Mr is the number of rising edges found, Mf the number of falling edges found, the time

when rising edge i crosses the x% level, and the time when falling edge i crosses the x% level.

Determining Time Parameters
Time parameter measurements such as width, period and delay are carried out with respect to the
mesial reference level, located halfway (50%) between the top and base reference lines or with
respect to the specified level for @level parameters.

Time-parameter estimation depends on the number of cycles included within the observation window.
If the number of cycles is not an integer, parameter measurements such as rms or mean will be
biased. However, only the last value is actually displayed, the mean being available when statistics
are enabled. To avoid these bias effects, cyclic parameters can be chosen, including crms and
cmean, that restrict the calculation to an integer number of cycles.
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Determining Differential Time Measurements
The instrument enables accurate differential time measurements between two traces: for example,
propagation, setup and hold delays.

Parameters such as Skew require the transition polarity of the clock and data signals to be specified.
A hysteresis range may be specified to ignore any spurious transition that does not exceed the
boundaries of the hysteresis interval. In the figure below, Skew measures the time interval separating
the falling edge of Source1 from the rising edge of Source2.
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Math
Math traces (Fx) display the result of applying a mathematical operation to a source trace. The
output of a math function is always another trace, whereas the output of a measurement parameter is
a tabular readout of the measurement.

Math can be applied to any channel (Cx), zoom (Zx), or memory (Mx) trace. It can even be applied to
another math trace, allowing you to chain operations (for example, trace F1 can show the average of
C1, while trace F2 provides the integral of F1). Functions such as Trend can be applied to
measurement parameters (Px) to plot the history of the measurement.

In addition to the extensive math capabilities that are standard with every instrument, enhanced math
analysis tools customized for various industries and applications are offered through optional
software packages. To learn about math tools available in each optional package, see the datasheets
on the Teledyne LeCroy website at teledynelecroy.com.

If you have installed software options, the new capabilities are usually accessed through the Analysis
menu, rather than the Math menu, although special measure parameters and math functions will be
available when using Measure and Math dialogs.
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Math Function Set Up
Use the Function dialog to set up math function traces. Math functions take as input one or more
channel, zoom, memory or math traces and output a new function trace (Fx) . Any additional settings
required for the operator will appear on a subdialog at the right of the screen.

Single functions perform one operation on one or two input sources.

Dual functions chain two operations to arrive at a single result. This saves you the effort of having to
chain two separate math functions. As with single functions, the number of sources required will vary
based on the operation. You may need only one source for Operator1, but two for Operator2 (the result
of the first operation counts as one source).

Setting Up New Functions

1. From the menu bar choose Math > Math Setup, or press the front panel Math button.

2. Choose a location by touching one of the Fx tabs.

Tip: If you know which function location you'll be using, you can select Fx Setup right
from the Math menu.

3. Choose a single f(x) or dual g(f(x) operator function.

Tip: You can also choose Web Edit, in which case this function is added as a terminal
to the processing web. See the instructions for Using Wed Edit to set up the function.

4. In Operator1, choose the math operation to perform.

5. The choice of operator drives the number of Source fields you will see displayed. Make a
selection in each field, or drag the source channel descriptor box to the field.

A Summary of the function you are building appears on the dialog. Refer to this to be sure your
sources are in the proper order to yield the function you want (e.g., C1-C2 vs. C2-C1).

6. If the operator you've selected has any other configurable settings, you'll see a subdialog of the
same name as the operator. Touch the tab to open the dialog and make any further settings.
These are explained on the dialog.

7. If you're creating a dual function, repeat the procedure for the second operator.
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Graphing
The Graph button on the Function (Fx) dialogs allows you to plot the results of an applied
measurement parameter using histogram, track, or trend. Choose the source, the measurement
parameter, and the type of plot to draw. See Histogramming and Track and Trend.

Tip: The plots are the same as those created using the toolbar on the Parameter (Px) dialog.

As with other math functions, configurable settings will appear on subdialogs after the plot is
selected.

Adjusting Memory or Math Traces
Unlike channel traces, the scale of memory (Mx) or math function (Fx) traces can be adjusted directly
without having to create a separate zoom trace. The same set of zoom factor controls used for zoom
traces appear on the Zoom subdialog, but in this context they only rescale the active math or memory
trace rather than create a new zoom. This applies to any trace that is created as a math function (Fx)
trace, including traces generated through analysis options and graphs.

You can, if you wish, create a separate zoom trace from a memory or function trace the same as you
would normally create a zoom (draw a selection box, apply the Zoom math operator, etc.). In this
case, you choose one of the zoom locations (Zx) in which to draw the trace, but the source trace
remains at the original scale.

Math Dialog
Once a math function has been created and saved on the Function (Fx) dialog, use the main Math
dialog to quickly enable/disable it.

To open the Math dialogs, touch the front panel Math button, or from the menu bar choose Math >
Math Setup. Select the On checkbox next to each function you wish to display.

To modify a function, touch the Fx button.

To erase all functions from their locations, touch Reset All.

To restart the counter on cumulative functions (like Average), touch Clear Sweeps.
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Average Function

Setting Up Averaging
To apply Continuous or Summed Averaging as a Math function:

1. Follow the usual steps to set up a math fuction, selecting Average from the Basic Math
submenu.

2. On the Average subdialog, choose Summed or Continuous.

3. Touch Sweeps and provide a value. The valid range is 1 to 1,000,000 sweeps.

Tip: To quickly set up Continuous Averaging (only), access the channel setup dialog (Cx) and
enter the number of sweeps to average in Averaging. The valid range is 1 to 1,000,000 sweeps.

Summed Averaging
Summed Averaging is the repeated addition, with equal weight, of successive source waveform
records. If a stable trigger is available, the resulting average has a random noise component lower
than that of a single-shot record. Whenever the maximum number of sweeps is reached, the
averaging process stops. In Summed averaging, you specify the number of acquisitions to be
averaged. The averaged data is updated at regular intervals.

An even larger number of records can be accumulated simply by changing the number in the dialog.
However, the other parameters must be left unchanged or a new averaging calculation will be started.
You can pause the averaging by changing the trigger mode from NORMAL/AUTO to STOP. The
instrument resumes averaging when you change the trigger mode back to NORMAL/AUTO.

You can reset the accumulated average by pushing the CLEAR SWEEPS button or by changing an
acquisition parameter such as input gain, offset, coupling, trigger condition, timebase, or bandwidth
limit. The number of current averaged waveforms of the function, or its zoom, is shown in the
acquisition status dialog. When summed averaging is performed, the display is updated at a reduced
rate to increase the averaging speed (points and events per second).

Continuous Averaging
Continuous Averaging, the default setting, is the repeated addition, with unequal weight, of successive
source waveforms. It is particularly useful for reducing noise on signals that drift very slowly in time
or amplitude. The most recently acquired waveform has more weight than all the previously acquired
ones: the continuous average is dominated by the statistical fluctuations of the most recently
acquired waveform. The weight of ‘old' waveforms in the continuous average tends to zero (following
an exponential rule) at a rate that decreases as the weight increases.

You determine the importance of new data vs. old data by assigning a weighting factor. Continuous
averaging allows you to make adjustments to a system under test and to see the results
immediately. The formula for both summed and continuous averaging is:

new average = (new data + weight * old average)/(weight + 1)
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However, by setting a Sweeps value, you establish a fixed weight that is assigned to the old average
once the number of sweeps is reached. For example, for a sweeps (weight) value of 4:

Sweep New Average =

1 (no old average yet) (new data +0 * old average)/(0 + 1) = new data only

2 (new data + 1*old average)/(1 + 1) = 1/2 new data +1/2 old average

3 (new data + 2 * old average)/(2 + 1) = 1/3 new data + 2/3 old average

4 (new data + 3 * old average)/(3 + 1) = 1/4 new data + 3/4 old average

5 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

6 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

7 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

In this way, for sweeps > 4 the importance of the old average begins to decrease exponentially.

Note: The number of sweeps used to compute the average is displayed at the bottom of the
trace descriptor box.

Copy Function
The Copy math function saves a copy of your present waveform in its unprocessed state to the first
available memory location. While processing may continue on the original waveform, the copy
enables faster throughput in some cases by preserving the original data. No calculations need to be
undone on the copy before additional math can be calculated. This benefit of faster throughput,
however, comes at the expense of memory usage.

Follow the ususal steps to set up a math function, selecting Copy from the Misc submenu.

On the Wform Copy subdialog, optionally Reset Count or Change BatchSize.
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ERes Function
ERes (Enhanced Resolution) filtering increases vertical resolution, allowing you to distinguish closely
spaced voltage levels. The instrument's ERes function is similar to smoothing the signal with a
simple, moving-average filter. However, it is more efficient concerning bandwidth and pass-band
filtering.

Use ERes:

l On single-shot acquisitions, or where the data record is slowly repetitive (cases where you
cannot use averaging).

l To reduce noise on noticeably noisy signals when you do not need to perform noise
measurements.

l When performing high-precision voltage measurements (e.g., zooming with high vertical gain).

Setting Up ERes
To apply ERes as a Math function:

1. Follow the usual steps to set up a math function, selecting Eres from the Filter submenu.

2. Touch the Trace On checkbox.

3. On the Eres subdialog, then touch bits and make a selection from the pop-up menu.

Tip: To quickly set up ERes as a pre-processing function, access the channel setup dialog
(Cx) and select a Noise Filter (ERes) bit size.

How the Instrument Enhances Resolution
The instrument's enhanced resolution feature improves vertical resolution by a fixed amount for each
filter. This real increase in resolution occurs whether or not the signal is noisy, or whether it is single-
shot or repetitive. The signal-to-noise ratio (SNR) improvement depends on the form of the noise in
the original signal. The enhanced resolution filtering decreases the bandwidth of the signal, filtering
out some of the noise.

The instrument's constant phase finite impulse response (FIR) filters provide fast computation,
excellent step response in 0.5 bit steps, and minimum bandwidth reduction for resolution
improvements of between 0.5 and 3 bits. Each step corresponds to a bandwidth reduction factor of
two, allowing easy control of the bandwidth resolution trade-off.
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Resolution increased by -3 dB Bandwidth
(x Nyquist)

Filter Length
(Samples)

0.5 0.5 2

1.0 0.241 5

1.5 0.121 10

2.0 0.058 24

2.5 0.029 51

3.0 0.016 117

With low-pass filters, the actual SNR increase obtained in any particular situation depends on the
power spectral density of the noise on the signal.

The improvement in SNR corresponds to the improvement in resolution if the noise in the signal is
white (evenly distributed across the frequency spectrum). If the noise power is biased towards high
frequencies, the SNR improvement will be better than the resolution improvement.

The opposite may be true if the noise is mostly at lower frequencies. SNR improvement due to the
removal of coherent noise signals—feed-through of clock signals, for example—is determined by the
fall of the dominant frequency components of the signal in the passband. This is easily ascertained
using spectral analysis. The filters have a precisely constant zero-phase response. This has two
benefits. First, the filters do not distort the relative position of different events in the waveform, even
if the events' frequency content is different. Second, because the waveforms are stored, the delay
normally associated with filtering (between the input and output waveforms) can be exactly
compensated during the computation of the filtered waveform.

The filters have been given exact unity gain at low frequency. ERes should therefore not cause
overflow if the source data is not overflowed. If part of the source trace were to overflow, filtering
would be allowed, but the results in the vicinity of the overflowed data—the filter impulse response
length—would be incorrect. This is because in some circumstances an overflow may be a spike of
only one or two samples, and the energy in this spike may not be enough to significantly affect the
results. It would then be undesirable to disallow the whole trace.

Note: While ERes improves the resolution of a trace, it cannot improve the accuracy or
linearity of the original quantization. The pass-band causes signal attenuation for signals near
the cut-off frequency. The highest frequencies passed may be slightly attenuated. Perform the
filtering on finite record lengths. Data is lost at the start and end of the waveform and the
trace ends up slightly shorter after filtering. The number of samples lost is exactly equal to
the length of the impulse response of the filter used: between 2 and 117 samples. Normally
this loss (just 0.2 % of a 50,000 point trace) is not noticed. However, you might filter a record
so short that no data is output. In that case, however, the instrument would not allow you to
use the ERes feature.
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Fast Wave Port Function
Fast Wave Port is a function of Teledyne LeCroy X-Stream oscilloscopes that enables you to insert
your own custom algorithm, written in the C/C++ language, into the oscilloscope's processing stream.
It also maximizes data throughput from the acquisition system to your custom algorithm for purposes
of debugging. Custom algorithms can be written right on the oscilloscope using the Web Editor.

This is possible because two Windows system processes may share a region of memory, enabling
high-speed data transfer between the acquisition system and the custom algorithm, which runs in a
separate process from the oscilloscope application. A major benefit of Fast Wave Port is that your
algorithm may be implemented and, more importantly, debugged independently of the main
application.

It is important to note that transferring the results of your algorithm back into the X-Stream
processing stream is optional. If performance is the primary goal, and further processing of the
results within the X-Stream software is not required, this step may be skipped.

Fast Wave Port was designed for use with the C/C++ programming language. However, it is
theoretically possible for the processing to be implemented in any language supporting Windows
named events (Mutex) that can open a named memory-mapped file. No guarantee can be given,
however, as to the behavior of the function using anything but C/C++.

The size of the memory window is fixed at 80 MB, equating to 40 ms.

To use Fast Wave Port, follow the usual steps to set up a math function, selecting Fast Wave Port as
the Operator, then make the appropriate settings on the Fast Wave Port subdialog.

The Port Name is critical, indicating the base name of the memory window and the global objects
within the Windows O/S. Only change the default value if using multiple Fast Wave Port functions in
parallel.

Note: The base name must match the base name used in the client application.

The full names of the default global objects are as follows:

Object Full Name

Memory Mapped File FastWavePort1File

Data Available Event FastWavePort1MutexDataAvailable

Processing Complete Event FastWavePort1MutexProcessingComplete

The Timeout control specifies the amount of time the DSO waits for the custom processing function
to complete. This prevents the DSO from waiting indefinitely for a custom processing function which
may never arrive. Be careful to set this control to a reasonable value, meaning a time longer by a
reasonable margin than the custom processing is ever expected to take.
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FFT Function
For a large class of signals, you can gain greater insight by looking at spectral representation rather
than time description. Signals encountered in the frequency response of amplifiers, oscillator phase
noise and those in mechanical vibration analysis, for example, are easier to observe in the frequency
domain.

If sampling is done at a rate fast enough to faithfully approximate the original waveform (usually five
times the highest frequency component in the signal), the resulting discrete data series will uniquely
describe the analog signal. This is of particular value when dealing with transient signals, which
conventional swept spectrum analyzers cannot handle.

While FFT has become a popular analysis tool, some care must be taken with it. In most instances,
incorrect positioning of the signal within the display grid will significantly alter the spectrum,
producing effects such as leakage and aliasing that distort the spectrum.

An effective way to reduce these effects is to maximize the acquisition record length. Record length
directly conditions the effective sampling rate and therefore determines the frequency resolution and
span at which spectral analysis can be carried out.

Setting Up FFT

1. Follow the usual steps to set up a math function, selecting FFT from the Frequency Analysis
submenu.

2. Open the FFT subdialog.

3. Choose an Output type.

4. Optionally, choose a weighting Window (see below).

5. Depending on your Output Type selection, also make selections for :

l Group Delay Shift

l Line Impedence. By default, the FFT function assumes a termination of 50 Ohms. If an
external terminator is being used, this setting can be changed to properly calculate the
FFT based on the new termination value.

6. Check the Suppress DC box to make the DC bin go to zero. Otherwise, leave it unchecked.

Choosing a Window
The choice of a spectral window is dictated by the signal's characteristics. Weighting functions
control the filter response shape, and affect noise bandwidth as well as side lobe levels. Ideally, the
main lobe should be as narrow and flat as possible to effectively discriminate all spectral
components, while all side lobes should be infinitely attenuated. The window type defines the
bandwidth and shape of the equivalent filter to be used in the FFT processing.

Rectangular windows provide the highest frequency resolution and are useful for estimating the type
of harmonics present in the signal. Because the rectangular window decays as a (sinx)/x function in
the spectral domain, slight attenuation will be induced. Functions with less attenuation (Flat Top and
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Blackman-Harris) provide maximum amplitude at the expense of frequency resolution, whereas
Hamming and Von Hann are good for general purpose use with continuous waveforms.

Window Type Applications and Limitations

Rectangular Normally used when the signal is transient (completely contained in the time-domain window) or
known to have a fundamental frequency component that is an integer multiple of the fundamental
frequency of the window. Signals other than these types will show varying amounts of spectral
leakage and scallop loss, which can be corrected by selecting another type of window.

Hanning (Von Hann) Reduces leakage and improves amplitude accuracy. However, frequency resolution is also
reduced.

Hamming Reduces leakage and improves amplitude accuracy. However, frequency resolution is also
reduced.

Flat Top Provides excellent amplitude accuracy with moderate reduction of leakage, but with reduced fre-
quency resolution.

Blackman-Harris Reduces leakage to a minimum, but with reduced frequency resolution.

FFT Window Filter Parameters

Window Type Highest Side Lobe
(dB) Scallop Loss (dB) ENBW

(bins) Coherent Gain (dB)

Rectangular -13 3.92 1.0 0.0

Von Hann -32 1.42 1.5 -6.02

Hamming -43 1.78 1.37 -5.35

Flat Top -44 0.01 3.43 -11.05

Blackman-Harris -67 1.13 1.71 -7.53

Interpolate Function
Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct
straight-edged signals such as square waves. This is the default interpolation method used by the
oscilloscope.

(Sinx)/x interpolation, on the other hand, is suitable for reconstructing curved or irregular waveshapes,
especially when the sampling rate is 3 to 5 times the system bandwidth.

Cubic interpolation can be used to create a smooth, continuous function by applying a third-degree
polynomial.

For each method, you can select an upsample factor of 2 to 50 points to insert between samples.

1. Follow the usual steps to set up a math function, selecting Interpolate from the Filter
submenu.

2. Touch Algorithm and select an interpolation type.

3. Enter the Upsample factor by which to increase sampling.
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Tip: You can use the Up and Down buttons to set this value. To make fine increment
changes, deselect the "only by 2, 5..." checkbox.

4. In Half Width enter the width in taps of the filter.

5. To use a weighting function rather than an upsample factor, select it from Weighting. See FFT
for more information about the functions. If using the Kaiser function, also enter the Beta
value.

Sparse Function
The Sparse math function allows you to thin out an incoming waveform by skipping points at regular
intervals, and by starting acquisition at a particular offset (point). The Sparsing factor specifies the
number of sample points to reduce the input waveform by. A sparsing factor of 4, for example, says to
retain only one out of every 4 samples. A Sparsing offset of 3, on the other hand, says to begin on the
third sample, then skip the number of samples specified by the sparsing factor (4). In this way, the
sample rate is effectively reduced.

For the sparsing factor (interval), you can set a value from 1 to 1,000,000 points. For the sparsing
offset you can set a value from 0 to 999,999.

1. Follow the usual steps to set up a math function, selecting Sparse from the Misc submenu.

2. Touch the Sparsing factor control and provide a Bandwidth Limit value.

3. Touch the Sparsing offset control and provide a value.
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Rescale Function and Assigning Units
The Rescale function allows you to apply a multiplication factor (a) and additive constant (b) to any
source waveform. You can do it in the unit of your choice, depending on the type of application.

Setting Up Rescaling

1. Follow the usual steps to set up a math function, selecting Rescale from the Functions
submenu.

2. Touch the Rescale subdialog tab.

3. To apply a multiplication factor:

l Check the First multiply by: box and enter a value for a, the multiplication factor.

l Touch then add: and enter a value for b, the additive constant.

4. To change the output unit of measure from that of the source waveform:

l Check Override units.

l In Output enter the abbreviation for the new unit of measure.

You can combine units following these rules:

l For the quotient of two units, use the character ":/"

l For the product of two units, use the character "."

l For exponents, append the digit to the unit without a space (e.g., "S2" for seconds
squared)

Note: Some units are converted to simple units (e.g., V.A becomes W).

115



WaveRunner 8000 Oscilloscopes Operator's Manual

Abbreviated Units of Measure

Abbreviation Measure Abbreviation Measure

(blank) No units N Newton

A Ampere OHM Ohm

C Coulomb PAL Pascal

CYCLE Cycles PCT Percent

DB Decibel POISE Poise

DBC Decibel referred to carrier PPM Parts per million

DBM Decibel Milliwatt RAD Radian

DBV Decibel Volts DEG Degree (of arc)

DBUZ Decibel Microamp MNT Minute (of arc)

DEC Decade SAMPLE Sample

DIV Divisions SWEEP Sweeps

Event Events SEC Second (of arc)

F Farad S Second

G Gram SIE Siemens

H Henry T Tesla

HZ Hertz UI Unit interval

J Joule V Volt

K Degree Kelvin VA Volt amps

CEL Degree Celsius W Watt

FAR Degree Fahrenheit WB Weber

L Liter MIN Min

M Meter HOUR Hour

FT Foot DAY Day

IN Inch WEEK Week

YARD Yard

MILE Mile
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List of Standard Operators
The math operators included standard with your oscilloscope are listed below alphabetically.

Note: There may be additional operators available depending on the software options installed
on the oscilloscope.

Operator Definition

Absolute For every point in the waveform the distance away from zero is calculated. For values greater than
zero this is the same as the value. For values less than zero, the magnitude of this value without
regard to its sign is used.

Average Calculates either a summed or continuous average of a selected number of sweeps. See Aver-
aging Waveforms. The maximum number of sweeps is determined by the oscilloscope model and
memory.

Copy Copies waveform in its unprocessed state to the first available memory location.

Correlation Calculates a measure of similarity of two waveforms, or a waveform against itself, as a function of
a time-lag applied to one of them.

Derivative Calculates the derivative of adjacent samples using the formula:
(next sample value – current sample value) / (horizontal sample interval)

Deskew Shifts trace in time the amount of the deskew factor.

Difference For every point in the waveform, the value of Source2 is subtracted from the value of Source1.
Source1 and Source2 must have the same horizontal units and scale and the same vertical units.

Envelope Calculates highest and lowest vertical values of a waveform at each horizontal value for a spe-
cified number of sweeps.

ERes Applies a noise reduction and smoothing filter by adding a specified number of bits. See
Enhanced Resolution.

Exp Calculates the antilog to the base e of the source; that is, e raised to the power equal to the
source.

Exp10 Same as Exp, using base 10.

FFT Computes a frequency spectrum with optional Rectangular, Von Hann, Flat Topp, Hamming,
Blackman-Harris, and Hanning windows. Calculates up to 128 Mpts. Also allows FFT Averaging
through use of a second math operator. See FFT.

Floor Calculates the lowest vertical values of a waveform at each horizontal value for a specified num-
ber of sweeps.

Histogram Plots the number of data points that fall into statistically significant intervals or bins. Bar height
relates to the frequency at which data points fall into each interval/bin.

Integral Calculates the linearly rescaled integral (with multiplier and adder) of a waveform input starting
from the left edge of the screen using the formula:
(current sample value + next sample value) * (horizontal sample interval)
Each calculated area is summed with the previous sum of areas. The multiplier and adder are
applied before the integration function.

Interpolate Inserts points between sampled points (upsamples) according to one of three algorithms: Linear
(straight line), Sinx/x (curved), and Cubic (spine). Interpolation factor of 2 to 50 determines number
of points in the upsample.

Invert For every point in the waveform, the inverse of that point is calculated.

Ln Peforms a natural log of a waveform. Values less than or equal to zero are set to underflow.
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Operator Definition

Log10 Performs a log base 10 of a waveform. Values less than or equal to zero are set to underflow.

MatLab math Produces a waveform using a custom MatLab function.

Phistogram Creates a persistence histogram based on the displayed pixels of a waveform falling within a user
defined vertical or horizontal box (slice).

Product For every point in the waveform, the value of Source1 is multiplied by the value of Source 2.
Source1 and Source2 must have the same horizontal units and scale.

Ptrace mean Plots the mean value of each sample point in a persistence map.

Ptrace range Generates a waveform with a width derived from the population range of a persistence map.

Ptrace sigma Generates a waveform with a width derived from the sigma (sum) of a persistence map.

Ratio For every point in the waveform, the value of Source1 is divided by the value of Source2. Source1
and Source2 must have the same horizontal units and scale.

Reciprocal For every point in the waveform the inverse is calculated using the formula:
1 / (sample value)

Rescale For every point in the waveform the sample value is multiplied by the specified multiplier and then
add to with the specified adder. See Rescaling and Assigning Units.

Roof Calculates the highest vertical values of a waveform at each horizontal value for a specified num-
ber of sweeps.

Segment Selects one segment from a source waveform to place in a sequence waveform. Used in
Sequence sampling mode.

Sinx/x Performs 10-to-1 interpolation using a Sin(x)/x filter.

Sparse “Thins,” or decimates, an incoming acquisition by dropping sample points at regular intervals.
Sparsing factor specifies the number of points to drop between retained samples (e.g., factor of 4
retains 1 then drops 4). Sparsing offset specifies the point at which to begin applying the sparsing
factor (e.g., offset of 3 begins count on the third sample (3), then drops the number of samples spe-
cified by the sparsing factor (4).

Square For every point in the waveform, the square of the sample value is calculated.

Square Root For every point in the waveform, the square root of the sample value is calculated.

Sum For every point in the waveform, the value of Source1 is added to the value of Source 2. Source1
and Source2 must have the same horizontal units and scale and the same vertical units.

Track Generates a waveform composed of parameter measurements that is time synchronous with the
source waveform. The vertical units are those of the source parameter value and the horizontal
units are seconds. Parameter values are posted at the sampling rate.

Trend Produces a waveform composed of a series of parameter measurements in the order the meas-
urements were taken. The vertical units are those of the source parameter, the horizontal unit is
measurement number. The trend contains a single value for each measurement.

Zoom Produces a magnified trace of a selected portion of the input waveform. See Zooming Traces.
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Memory
The instrument is equipped with four internal memory slots (Mx) to which you can copy any waveform
that is active on the grid. This is a convenient way to store an acquisition for later viewing and
analysis.

Memories can be used as source inputs for most oscilloscope math and measurements, allowing you
to compare historical data to a live acquisition or perform "what if" modeling on saved acquisitions.

Saving Memories
Store memories on the Memory dialogs (Mx). Memories are created at the same scale as the source
trace, but they can be adjusted independently by using the zoom factor controls that appear next to
the Mx dialogs.

Save Waveform to Memory
Touch the Add New box and choose Memory until you see an empty memory slot. Drag the descriptor
box of the trace you wish to store onto the Mx descriptor box.

Note: Try to choose an empty slot, as anything currently stored in that location will be
overwritten. All memories will state if they are empty or an acquisition is stored there.

Or

1. Press the front panel Mem button or choose Math > Memory Setup to open the Memories
dialog.

2. Touch the Mx tab corresponding to the memory slot you wish to use.

3. In Copy from Waveform, choose the source trace to copy to memory.

4. Touch Copy Now.

5. Optionally, check Trace On to immediately display the memory. Use the Zoom controls to
adjust the scale of the memory trace.

Save (External) Waveform Files to Memory
Trace (.trc) files saved on other Teledyne LeCroy instruments can also be saved to internal memory.
Use the Recall Waveform function to save external files to memory. Then, you can use the Memories
dialog to restore them to the touch screen.
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Restoring Memories
The Memories dialog is a convenient panel for restoring saved memories to the display.

Access the Memories dialog by pressing the front panel Mem button or choosing Math >
Memory Setup.

Check On next to the memory trace you wish to display. A description of the memory showing the
source channel and creation time appears next to each Mx on the dialog.

Touch Clear All Memories to empty the memory banks.

Caution: Memories cannot be restored once they have been erased.
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Analysis
The Analysis menu tools complement the standard math and measurements to help you understand
the behavior of waveforms.

WaveScan searches a single acquisition for events that meet specific criteria, enabling you to zoom
in on anomalies in the waveform, or scans multiple acquisitions with allowable trigger actions when
conditions are met. It can also be used to filter measurements.

Pass/Fail Testing indicates whether or not waveforms or measurements meet a set of defined
criteria.

Optional software packages may be purchased for specialized uses, such as power analysis. In most
cases, these options are added to the Analysis menu. Documentation for software options can be
found at teledynelecroy.com/support/techlib under Manuals > Software Options. In addition,
documentation for many options available on your platform can be found in the online Help under the
Support menu.

WaveScan
The WaveScan® Search and Find tool enables you to search for unusual events in a single capture, or
to scan for a particular event in many acquisitions over a long period of time. Each Scan Mode is
optimized to find a different type of event. Results are time stamped, tabulated, and can be selected
individually.

WaveScan windowwith different scan "views" turned on.
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When setting up WaveScan, you can customize the presentation by choosing different WaveScan
display features, called Scan Views. Optionally, set actions to occur automatically when unusual
events are found, such as stopping the acquisition or sounding an alarm.

Note: The instrument reverts to Real-time sampling mode when WaveScan is enabled.

Scan Modes
The Scan Mode determines the type of search to be performed. Select the Mode along with the
Source trace to be searched on the main WaveScan dialog. For each mode, different controls appear
on the WaveScan dialog, providing additional inputs to the search criteria. Make the appropriate
entries in these fields before starting the search.

Edge Mode
Edge Mode is used for detecting the occurrence of edges. Events that meet the threshold level are
captured and tabulated. When the acquisition is stopped, scan filters can be applied to the edges to
find specific characteristics. Edge Mode settings are:

l Slope. Choose Pos, Neg, or Both.

l Level is (set in...). Choose Percent or Absolute.

l Percent/Absolute Level. Enter a threshold value as a percentage of Top to Base or voltage
level.

Non-monotonic Mode
Non-monotonic Mode looks for edges that cross a threshold more than once between high and low
levels. All events that meet the criteria of slope, hysteresis, and level are presented in a table and
highlighted in the source trace. The value displayed in the table is the difference of the max. and min.
of the non-monotonicity. This can be confirmed with cursors. The hysteresis value is used to
eliminate noise. A non-monotonicity is detected only when its amplitude is greater than the
hysteresis. Therefore, when setting a hysteresis level, set a value that is greater than the amplitude
of the noise. Non-monotonic Mode settings are:

l Slope. Choose Pos, Neg, or Both.

l Hysteresis is (set in...). Choose Division, Percent, Absolute.

l Division/Percent/Absolute. Enter hysteresis level in the selected unit.

l Levels are (set in...). Choose Percent, Absolute, or Pk-Pk%.

l High/Low Level. Enter top and bottom thresholds in the selected unit.

Runt Mode
Runt Mode looks for pulses that fail to cross a specified threshhold. You can search for positive-
going or negative-going runts, or both. An adjustable hysteresis band is provided to eliminate noise.

In the case of negative-going runt pulses, the value displayed in the table is the difference (delta) of
the high level of the signal and the runt amplitude (i.e., where the runt bottoms out). This can be
confirmed by placing cursors on the runt pulse and reading the delta Y value in the trace labels. In the
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case of positive-going runt pulses, the value displayed in the table is the absolute value of the
amplitude of the runt pulse. Runt Mode settings are:

l Runt Type. Choose Both, Pos, or Neg.

l Hysteresis. Enter the hysteresis level as a percentage or voltage.

l Low/High Threshold. Enter the levels as a percentage or voltage.

l Absolute Levels. Check this box to enter levels as absolute voltage instead of percentage.

Measurement Mode
Measurement Mode is used for applying filters to measurements to find those that meet your defined
criteria, helping to isolate particular events within many samples. Markers appear over the source
trace to indicate the location of measurement, while the table displays values for the selected
parameter that meet the criteria. Measurement Mode settings are:

l Measurement. Choose the measurement parameter you wish to search.

l Filter Method. Choose the operator that indicates the desired relationship to the Filter Limit.
Only measurements that meet this criteria are returned.

l Filter Limit. Enter the value that completes the filter criteria.

Alternatively, you can use the Filter Wizard to create the filter criteria.

Serial Pattern Mode
Serial Pattern Mode is used for finding 2- to 64-bit patterns in digital sequences; ideal for bursted
patterns where a PLL cannot lock. Serial Pattern Mode settings are:

l Viewing. Choose to enter the pattern as Binary or Hex(adecimal).

l Binary/Hex. Enter the pattern.

l Num. Patterns to detect. Enter a whole number.

Bus Pattern Mode
Bus Pattern Mode (-MS models only) is used for finding 2- to 16-bit patterns across the digital lines.
Bus Pattern Mode settings are:

l Viewing. Choose to enter the pattern as Binary or Hex(adecimal).

l Binary/Hex. Enter the pattern.

l Num. Patterns to detect. Enter a whole number.
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Scan Views
Scan Views are different ways to view your WaveScan results. You can choose to display views
simultaneously or visit them sequentially. Just check the boxes at the bottom of the WaveScan
dialog for those views you wish to display. Uncheck the box to turn off the view.

Note: The number of grids varies from one to three depending on which views are enabled.
WaveScan handles this function automatically, and you cannot move traces among grids as in
normal operation.

You'll find additional controls for manipulating Scan Overlay and Zoom on their respective dialogs. If
you turn on these traces from those dialogs, you must turn them off from there, too.

Source Trace
By default, the source trace is displayed in the top grid, with markers indicating points in the trace
that meet the search criteria.

Table
Table view displays a table of measurements relevant to your chosen Search Mode next to the source
trace. Times view adds columns to the table showing Start and Stop Times for each event.

Scan Overlay
Scan Overlay view plots the location of captured events in a new trace. Colored overlays provide quick
reference to sections of the waveform.

Zoom
Zoom view works exactly as it does elsewhere in the X-Stream software, creating a new trace that is
a magnified section of the source trace. A Zx tab appears by default when you launch WaveScan; see
zoom factor controls for an explanation of the remainder of the controls found on this dialog.

A unique feature of the WaveScan Zoom is that you can automatically zoom the events captured from
the source trace by touching the Prev/Next buttons on the Zx dialog. You can also select a row from
the Table, and you are automatically relocated to that point on the zoom.
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Setting Up WaveScan
This procedure explains how to set up WaveScan to search an acquisition for events of interest. Set
up your source channel and triggers before setting up the scan.

1. Press the front panel Stop button to stop acquisition.

2. Choose Analysis > WaveScan.

3. Check Enable.

4. Choose the Source waveform.

5. Choose the Scan Mode and enter values for any additional settings that appear at the right of
the dialog based on your selection.

6. If you're using Measurement Mode, set up the filter in one of the following ways:

l Touch Filter and choose an operator, then enter the Filter Limit.

l Touch Filter Wizard and choose one of the pre-set filters. The Filter and Filter Limit are
automatically set based on your selection.

7. Select each Scan View in which you wish to display results by checking the box at the bottom
of the dialog. Each view selected is displayed simultaneously.

8. If you're using Scan Overlay view, on the Scan Overlay dialog Clear Sweeps. If desired, set up
the Persistence display.

9. Optionally, choose an Action to trigger when an event that meets your scan criteria is found.

10. Restart acquisition.

11. When using the Zoom view, use the Zx tab to adjust the zoom.

Scan Overlay
To apply monochromatic persistence to a Scan Overlay:

1. Select Scan Overlay when setting up the wave scan, then open the Scan Overlay dialog.

2. Check Persistence On.

3. Enter a Saturation level as a percentage. All samples above the saturation level are assigned
the highest color intensity.

4. Choose a Persistence Time. The higher the time, the more static the persistence display.

To adjust the scan overlay to "zoom" in or out: touch the In/Out buttons, or touch Scale and enter new
values. Check Var. to adjust scale in finer steps than the default 1, 2, 5.
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Scan Histogram
Scan Histogram is an additional WaveScan "view" that generates a histogram to give you a statistical
view of edges that meet your search criteria. Enter the parameters as you would to set up any
histogram:

1. Total #Values in the histogram buffer

2. #Bins (bars) in the histogram

3. Center value and Width of each bin from center, or check Enable Auto Find and let the sofware
Find Center and Width.

4. Choose a Vertical Scale method:

l Linear allows the histogram to build vertically as data accumulates. When the
histogram reaches the top of the display it rescales the vertical axis to keep it on
screen.

l LinConstMax keeps the histogram at near full scale and rescales the vertical axis as
data is accumulated.

Search
Search is used to find events in traces—usually zoom (Zx) traces—that match user-defined criteria.
To search within WaveScan:

1. Select the Zoom view.

2. After stopping the acquisition, open the Zx dialog that appears behind the WaveScan dialog.

3. Use the Prev and Next buttons to move back or forward within the trace to the events that
matched your Scan Modes criteria.
Or
If you know the WaveScan table index (row) number of the event you wish to find, enter it in Idx.
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Pass/Fail Testing
Pass/Fail testing allows you to define a set of qualifying conditions that an acquisition may "pass" or
"fail" when tested against, then take actions depending on whether the result is a pass or a fail.

l Mask testing compares sampled values to a pre-defined area of the grid (the "mask") to see if
they fall within or without.

l Parameter comparison compares a measurement result to a pre-defined value (Param
compare) or to another measurement (Dual param compare).

You can preconfigure to eight qualifiers (Qx) using either method, which are then enabled by selecting
them on the Pass/Fail dialog and defining what combination of results constitutes a "Pass" on the
Actions dialog.

Mask Test Qualifiers
Testing against a mask is particularly useful for comparing newly acquired signals to a previously
acquired "golden standard" waveform.

A mask defines an area of the grid against which a source Channel, Zoom, or Math trace is compared.
Test conditions are associated with the mask, defining how the waveform is to be compared to the
masked area (e.g., some/all values fall within, some/all values fall outside), and a Pass or Fail result
is returned indicating the condition was found to be true or false.

Mask testing can be done using a pre-defined mask or a mask created from a waveform with user-
defined vertical and horizontal tolerances. Some industry standard masks used for compliance
testing are included with the X-Stream software. The mask test can be confined to just a portion of
the trace by the use of a measure gate.

Access Mask Test Dialogs

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qx button where you want to set up the qualifier.

3. Select Mask test.

The Qx dialog opens with the Mask test condition selected and the Test, Load Mask, Make Mask, and
Gate subdialogs displayed. On these dialogs, you manage, make, and apply gates to your mask.
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Make Mask
Use this procedure to create a new mask based on a live waveform. The mask covers the area of the
waveform plus the boundaries you enter.

1. Open the Make Mask subdialog.

2. If desired, enter a new Destination File Name and path, or touch Browse and select a previous
file to overwrite. The file name should end with the .msk extension.

3. Touch the Ver Delta and Hor Delta fields and enter boundary values using the pop-up Virtual
Keypad or the front panel Adjust knob.

4. Touch Make from Trace.

Load Mask
Use this procedure in lieu of Make Mask if you have a pre-defined mask file, or wish to recall a mask
you previously created and saved.

1. Open the Load Mask subdialog.

2. To use a saved .msk file, touch File and select the mask.
To use an industry standard mask, touch Standard and select the mask from the pop-up.

3. Check View Mask to display the mask over the trace.

Remove a Mask from the Display
Touch the Delete All Masks button. Alternatively, open the Qx dialog where a particular mask is set,
and on the Load Mask subdialog, touch Delete.

Set Gates
Set gates to limit the portion of the waveform that is compared to the mask.

1. Open the Gate subdialog.

2. Enter the Start and Stop horizontal divisions that mark the segment of the waveform to be
tested with this mask. This can be a whole division or a fraction of a division. Divisions are
numbered 1-n left to right.

Tip: A quick way to position the gate is to drag the gate posts initially placed at the
extreme left and right ends of the grid to the desired points.

Define "True"

1. Open the Test subdialog.

2. Select one of the conditions that, when True (yes), results in a Pass.

3. Optionally, turn Off/On markers. Markers visually indicate where on the waveform mask
violations have occurred.

128



Analysis

Param(eter) Compare Qualifiers
Pass/Fail qualifiers (Qx) can be configured to compare different parameter measurements (Px) to
each other or to a user-defined limit (or statistical range).

Comparing a Measurement to a Limit
This method takes the result of a selected measurement parameter and compares it to a user-
defined value or range of values.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qx button where you want to set up a qualifier.

3. From the pop-up menu, choose Param compare.

4. On the Qx dialog, touch Source1 and choose the parameter.

5. On the ParamCompare dialog, touch Compare Values and select All or Any from the pop-up.

By selecting All, the condition is true only if every waveform falls within the limit. Selecting Any
makes the condition true if just one waveform falls within the limit.

6. Touch Condition and select a math operator, then touch Limit and enter the value that
completes the condition. The value entered acquires properties corresponding to the
parameters being tested. For example, if you are testing a time parameter, the unit is seconds.

7. If you chose to set a Delta limit, also enter the Absolute or % Delta value. You may choose
instead to set Limit and Delta using one of the buttons at the bottom of the dialog.

Comparing Parameter Measurements
When using Dual Param Compare, two measurements are compared, rather than two waveforms.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qx button where you want to set up a qualifier.

3. From the Pass/Fail Condition menu, choose Dual Param Compare.

4. On the left-hand Qx dialog, select the parameters to compare in Source1 and Source2.

5. On the ParamCompare dialog, touch Compare values and select All or Any from the pop-up.

By selecting All, the test are true only if every waveform falls within the set limit. Selecting Any
makes the test true if just one waveform falls within the limit.

6. Touch Condition and select the math operator that completes the condition. The Summary
field shows the completed condition that is represented by this qualifier.
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Define Pass/Fail Tests
The Qualifiers define the conditions of a Pass/Fail test that would result in either "True" or "False"
but don't in themselves determine the test result. You must separately define what constitutes a
"Pass" or a "Fail" on the Actions dialog. A Pass or Fail result can be made to produce various
additional actions, such as sending a pulse to another device.

1. After setting up the Pass/Fail test qualifiers, open the Actions tab.

2. Optionally, check Summary View to see a running summary of results over the total number of
sweeps.

3. Select the test Pass criteria in Pass If.

4. To apply additional actions to the test result:
l Check Enable Actions to turn on actions.
l Under If, choose to apply actions if the result is a Pass or a Fail.
l Under Then, choose all the actions to apply:

l Save a waveform file
l Stop the test
l Sound an Alarm
l Emit a Pulse from the AUX OUT connector. When taking this action, also open the
Aux Output tab and choose to Use Auxilliary Output For Pass/Fail.

l Capture the screen and process it according to your Hardcopy selection (e.g.,
send to printer)

l Create a LabNotebook Notebook Entry

Use the Clear All button to clear all the action checkboxes, or Force Actions Once to apply
them once regardless of the test results.

Delay Test
You can delay the start of a test by entering the number of sweeps to wait in Start Testing After.

Touch Clear Sweeps at any time to reset the test counter.

Stop Test
To stop the test following a specified number of sweeps, rather than a Pass or Fail result, check the
Stop Test box, then enter the desired number of sweeps in After.
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Saving Data (File Functions)
This topics in this sections explain the instrument's File menu functions.

Some of these features, like the Disk Utilities, provide an alternative interface for performing typical
Windows file functions, such as creating and deleting files/folders on the instrument's hard drive.

Others, such as the Save/Recall features, are related directly to moving waveform data on/off the
instrument.

LabNotebook is Teledyne LeCroy's proprietary tool for capturing and creating custom reports of
waveform data. An important feature of LabNotebook is Flashback Recall, which enables you to
restore an acquisition (and the setups used to create it) to the oscilloscope screen simply by
recalling a LabNotebook entry.
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LabNotebook
The LabNotebook feature allows you to create and save Notebook Entries containing a capture of all
displayed waveforms and the waveform data, to which you may add custom annotations. Entries are
collected into separate Notebooks by project or user, especially useful if the instrument is shared.

Notebook Entries can be output to a hardcopy report format—.pdf, .rtf, or .html—and printed or e-
mailed. You can also upload your own report layout if you prefer not to use the default.

Besides storing the waveform data, LabNotebook also stores the current panel setups and parameter
measurements. The Flashback Recall feature instantly recalls the setups stored with individual
Notebook Entries, enabling you to restore the exact state of the instrument at a later date to perform
additional analysis.

Back up the LabNotebook database to external media for indefinite storage of waveform data.

Create Notebook Entry
A Notebook Entry is a snapshot of the instrument at the moment it is taken: it captures the
waveforms, their setups, and any measurements in process. As each new entry is created, it is added
to the current Notebook, a database of entries. All entries are accessible from the LabNotebook
dialog, where they can be organized into different Notebooks and Reports, or recalled to the screen
through Flashback Recall.

1. Choose File > LabNotebook to open the LabNotebook dialog.

2. Select the notebook to which to add the entry from the My Notebooks list.

New entries are added to whichever notebook was last selected, or to the default
MyNotebook.zip if you have only one.

3. Touch Create.

4. Optionally, Enter Report Title and Description.

The default title is the date and time stamp.

Note: By default, you will be prompted to title and annotate notebook entries as they are
created. You can configure LabNotebook preferences so that these steps are skipped
in order to streamline the creation process. To update entries at a later time, select the
entry from the list of Notebook Entries, then open the tab of the same name that
appears behind the LabNotebook dialog.
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5. Touch Save.

6. Use the Drawing toolbar to annotate the Notebook Entry. Click Done when finished.

LabNotebook Drawing Toolbar
The basic Notebook Entry is a screen capture of the display as it was at the time of entry, along with
the setup and waveform data. When an entry is first captured, it is immediately displayed in the
Drawing window for you to annotate.

Tip: This default setting can be changed on the LabNotebook Preferences dialog.

Markup tools are available from the toolbar along the top of the window.

To use any tool, touch the icon, then touch the point on the image where you wish to draw or add text.
From left to right, the tools are:

Tool Function

Pencil Draw in freehand. Maintain contact with the screen to make a continuous mark. Once you release,
you can touch-and-drag the object to any point on the image.

Circle Draw a circle around a waveform feature that you want to emphasize. Touch-and-drag across the
diameter of the circle. When you release, the circle is placed. You can drag the circle to any loc-
ation on the image.

Arrow Draw lines with arrowheads for placing callouts. You can rotate these lines through 360 degrees
or drag them to any location on the image.

Text Open a textbox for placing labels/annotations on the image. Touch the point on the image to place
the label, then enter the text in the pop-up dialog. Once placed, you can resize the textbox or drag
it to any location on the image.

RGB Selectors Quickly change the line color. Just touch the color icon, then choose the next drawing tool.

More Activates a Custom line color field. The default color is Yellow. To choose another, touch the color
swatch, then select from the Color dialog. You can enter RGB values, or choose from the spec-
trum. After saving, the new color appears in the Custom field. This remains the markup color until
you choose another.

Erase Selected /
Erase All

Remove selected drawing objects. Erase All will also undo any Custom color selection.

Undo Cancel the last action. Use it to restore any objects you inadvertently erased.

Move Undock the drawing toolbar so you can move it anywhere on the display. This helps to keep tools
handy when working on a particular area of a waveform. Touch the button again to restore the tool-
bar to the top of the Drawing window.

Done Save the annotations with the image and close the Drawing window.
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Manage Notebook Entries
Before any further actions can be performed on saved Notebook Entries, first select the Notebook
from the My Notebooks list, then select the entry from the My Notebook Entries list. The selected
entry is highlighted in blue.

Select Multiple Notebook Entries

1. Check the Multi-selection box at the far right of the dialog.

2. Select All, or else touch each desired entry then touch Select as the entry is highlighted. A
white arrow appears next to each selected entry.

3. To remove entries from a multi-selection, highlight them and touch Clear, or else Clear All.

Filter Notebook Entries
To apply filters to limit a large list of entries:

1. Select the notebook from the My Notebooks list.

2. Touch the Filter button.

3. On the Filter Entries pop-up, enter the filter criteria. You can use Day/Month/Year, a Keyword, or
a combination.

4. Touch Find Now to filter.

5. To restore the full list, touch Clear Filter.

Preview Notebook Entries
View allows you to preview the selected entries in the report format before printing/saving.

Select the desired entries, then touch the View button. Use the scrollbar that appears on the
LabNotebook window to navigate the report.

Edit Notebook Entries
To annotate or change the description of a notebook entry:

1. Select the entry from the My Notebook Entries list.

2. Go to the second tab labeled with the entry name.

3. Modify the Title or Description.

4. To add markup to the entry, touch Scribble and use the Drawing Toolbar.
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Email Notebook Entries
Choose E-Mail to send selected Notebook Entries to the default address specified in system
Preferences. To use the E-Mail button, the instrument must have an active network connection and
you must first configure the email address and server.

To change the recipient address (from the default) before sending, open the LabNotebook
Preferences tab, then touch the Configure E-Mail button.

Also select whether or not to Attach Setup & Waveform files to the email with the LabNotebook files.

Print Notebook Entries
To print multiple entries, select them on the main LabNotebook dialog, then touch the Print button on
the same dialog.

To print a single entry, select it on the main LabNotebook dialog, then go to the second tab and touch
the Print button.

Delete Notebook Entries
Use the Delete button to remove selected Notebook Entries, or Delete All to clear the entire My
Notebook Entries.

Note: Unless you have previously backed up the notebook, deleted entries cannot be restored.

Create Report
Create Reports collates the selected Notebook Entries into a single .RTF/.PDF document or HTML
archive using the report template selected on the LabNotebook Preferences tab. This can be one of
the preformatted templates or a custom format.

Note: It is not necessary to first create a report document to preview, email, or print selected
Notebook Entries.

1. Select the notebook from the My Notebooks list.

2. Select the entries from the My Notebook Entries list.

3. Choose the output Format.

4. Touch Create Report.

5. On the Create Report window, select the folder in which to save the report.

Tip: Touch Open Explorer Here and use the Windows Explorer to create a new folder.
After closing the Explorer, touch the Refresh button to display the folder in the Create
Report window.

6. Enter a File name for the report and click OK.
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Flashback Recall
Once a Notebook Entry is made, you can recall it at any time using Flashback Recall. The recall
includes waveforms and panel settings, so you can analyze the inputs that resulted in that capture.

1. Choose File > LabNotebook to open the LabNotebook dialog.

2. Select the Notebook and Notebook Entry from the lists.

3. Touch the Flashback Recall button.

4. To exit Flashback Recall, touch the Undo button at the far right of the menu bar.

Some result data not included in Flashback Recall are:

l Persistence data (although it is saved in with the Notebook Entry and appears on reports).

l Histogram data over 16-bits. Histograms internally have a 32-bit resolution, but when stored
into a trace file and recalled during Flashback they are clipped to 16-bits.

l Floating point waveforms resulting from certain math operations that have much higher
resolution than 16-bits. This extra resolution is not preserved when traces are recalled using
Flashback.

l Cumulative Measurements in process when Flashback Recall is entered. When Flashback is
used, they lose their history and show instead only the results from the stored waveforms, not
including any data taken from interim acquisitions.
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Manage Notebooks
LabNotebook stores Notebook Entries in a .zip archive on the instrument hard drive. Each .zip file is
one Notebook comprised of everything shown in the My Notebook Entries list. New Notebooks can be
created for different individuals or projects, or an existing Notebook backed up for storage.

Note: The default Notebook is D:\Xport\MyLabNotebook.zip. If you've already created
Notebook Entries that you wish to keep, you can use the backup feature to save them under a
new file name or location before starting a new Notebook.

Create New Notebook

1. Choose File > LabNotebook.

2. Touch the New button next to the My Notebooks list.

3. Enter a File Name for the Notebook (optionally, choose a new folder as well). Touch OK.

The new notebook now appears in the My Notebooks list. New Notebook Entries will be added to this
Notebook whenever it is selected.

Back Up Notebook

1. Choose File > LabNotebook.

2. Select the notebook from the My Notebooks list and touch Backup.

3. Optionally, enter a new File Name or choose a new storage Folder.

Note: The default is the notebook name with *.bak.zip appended to it.

4. Choose to Backup to Removable Disk (this option is active when a USB drive is connected) or
Backup to Folder on hard drive.

Import Notebook
Archived notebooks can be imported into the My Notebooks list.

1. Choose File > LabNotebook.

2. Touch the Import button.

3. Navigate to the desired archive and select it. Touch OK.

Delete Notebook

1. Choose File > LabNotebook.

2. Select the notebook from the My Notebooks list.

3. Touch the Delete button next to the My Notebooks list.
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Customize Reports
The Advanced dialog allows you to customize the LabNotebook report creation function.

Change Directories
To change where Notebooks are stored, change the Notebooks Directory folder.

To change where reports are output, change the Report Directory folder. You can choose an external
location, such as a USB drive.

Change Report Template
Deselect Use Default next to the Template field, then touch Browse and select a different template
from the D:\Xport folder.

You can create your own report template and place it in this directory for selection. Templates must
be saved as .xsl or .xslt files.

Change Logo
The included LabNotebook report templates use our logo as a placeholder. You can replace this with
your custom logo. Logo files should be in bitmap (.bmp) format and not exceed 100 pixels high by 180
pixels wide.

1. Copy the logo file to the D:\Xport folder.

2. Choose File > LabNotebook, then touch the Advanced tab.

3. Deselect the Use Default checkbox next to the Logo field.

4. Touch the Browse button and navigate to the the new logo file. Select and touch OK.The new
file path appears in the Logo field with a preview of the image above it.
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LabNotebook Preferences
To modify the behavior of the LabNotebook tool, change settings on the LabNotebook Preferences
dialog:

Prompt for Entry Title Before Saving opens the LabNotebook dialog when a new entry is created. You
can elect to name notebook entries using only the date/timestamp by leaving this box unchecked.

Annotate Entry Before Saving opens the Drawing Toolbar to annotate a notebook entry as soon as it is
created.

Use Print Colors outputs waveforms on a white background. This option helps save ink/toner when
printing. The print colors used for each trace are set in Utilities > Preferences Setup > Colors.

Hardcopy Area determines how much of the screen image is included in the report: grid area only, grid
area plus dialog, whole screen. Touch the field and choose from the pop-up menu.

Attach Setup & Waveforms attaches these files for each trace in the report: waveform data (.trc), a
screen dump (.png), setup file (.lss), report template file (.xsl), and export record (.htm).

Optionally, touch the Configure E-Mail button to set the recipient address and server information on
the Preferences E-mail dialog.
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Save / Recall
The Save/Recall dialog displays a series of shortcut buttons launching the various Save/Recall
functions. You can use these buttons or the tabs to navigate to the other Save/Recall dialogs.

Save Setups
Save Setups allows you to quickly save up-to-six panel settings to internal storage, while Recall
Setups restores them with a touch. Setups are saved to the D:\Internal Setups folder.

If desired, you can also save panel settings as an .lss file in a different location, such as a USB drive,
and recall them from the same.

Choose File > Save Setup... from the menu bar or click the Save Instrument Setup button on the main
Save/Recall dialog.

Save Setup to Memory

1. Touch one of the Setup data entry controls and enter a name for the memory.

2. Touch the corresponding Save button directly to the left of the Setup field.

The save date/time is displayed above the Setup data entry control.

Save Setup to File

1. In Save Panel to File, touch Browse and navigate to the desired folder.

Tip: If the instrument is networked, you can touch Save Panel to File and enter the full
Windows network address of another location in which to save the file. The instrument
must have access to this directory.

2. Enter a File name, or choose a existing file to overwrite. Touch OK.

3. On the Save Setups dialog, touch Save Now!
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Recall Setups
Recall Setups restores setups saved to one of the internal memory locations, or enables you to
import a setup file.

Choose File > Recall Setup... from the menu bar or click the Recall Instrument Setup button on the
main Save/Recall dialog.

Recall Setup from Memory
Touch one of the six Recall buttons under Recall From Internal Setup....

Note: If a setup has been stored to a location, it is labeled with the save date/time. Otherwise,
the slot is labeled Empty.

Recall Setup from File

1. In Recall panel from file, touch Browse and navigate to the desired folder.

2. Select the setup file and touch OK.

3. On the Recall Setups dialog, touch Recall Now!
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Save Waveforms
The Save Waveform function saves trace data to either an internal memory location, or to a text or
binary format file (.trc). The source waveform can be any type of trace; a channel, math function,
zoom, or even another memory. Use Recall Waveform to restore these previously saved waveforms to
the display.

Note: Only files saved in binary format (.trc) can be recalled to the touch screen.

By default, trace files are saved to the D:\...\Waveforms folder on the instrument hard drive, although
you can choose another location, such as a USB drive. The file name is autogenerated from the
<source trace><trace title><number in sequence> (e.g., C1test000001).

Choose File > Save Waveform from the menu bar or click the Save Waveform button on the main
Save/Recall dialog.

Save Waveform To Memory

1. Touch Memory.

Note: When Memory is selected, only Source and Destination controls are shown on the
Save Waveform dialog. When File is selected, many more controls are available.

2. Choose the Source trace you are saving.

3. Choose the Destination location.

4. Touch Save Now!

Save Waveform To File

1. Touch File.

2. Choose the Source waveform.

3. Optionally, touch Trace Title to change the root file name of your waveforms.

Caution: Numbers you place at the end of this name are truncated because the
instrument appends a sequence number to each file. Place numbers at the beginning,
or place an alpha character after the number (e.g., XYZ32a).
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4. Touch Data Format and select a file format:

l Binary, Teledyne LeCroy's binary file format (.trc). Binary results in the smallest possible
file size, and is necessary for recalling waveforms to Teledyne LeCroy instruments.

Note: Binary files can be converted to ASCII using Teledye LeCroy utilities such
as ScopeExplorer or WaveStudio.

l ASCII text file (.txt extension).

l MATLAB text file (.dat extension).

l Excel text file (.csv extension).

l MathCad text file (.prn extension).

l Audio .wav file.

l WaveML, Teledyne LeCroy's proprietary .xml format used to save persistence maps, eye
diagrams, histograms, and digital traces. This option will only be activated if the source
waveform/plot is of a type to require it.

5. Depending on your file format selection, you may also need to specify a SubFormat:

l Word (Binary) represents samples in the output file with 16 bits. Always use this options
unless Byte mode is "pre."

l Byte (Binary) represents samples in the output file with 8 bits. This option can result in
a loss of output file resolution.

l Auto (Binary) looks at the data and automatically selects either Word or Byte subformat.

l Amplitude only (Text) includes amplitude data for each sample, but not time data.

l Time and Amplitude (Text) includes both types of data for each sample.

l With Header (Text) includes a file header with scaling information.

6. If you selected ASCII format, also touch Delimiter and select a delimiter character from the
pop-up menu.

7. In Save Files in Directory, touch Browse and navigate to the desired location. Touch OK.

Tip: If the instrument is networked, you can touch on Save Files in Directory and enter
the full Windows network address of another location in which to save the file. The
instrument must have access to this directory.

8. On the Save Waveform dialog, touch Save Now!

143



WaveRunner 8000 Oscilloscopes Operator's Manual

Recall Waveforms
Use Recall Waveform to restore previously saved waveform files to the display.

Note: Only files saved in binary format (.trc) can be recalled to the touch screen.

Choose File > Recall Waveform from the menu bar or click the Recall Waveform button on the main
Save/Recall dialog.

Recall Waveform From Memory

1. Touch Memory.

2. Touch Source and choose a memory location from the Select Source pop-up.

3. Touch Destination and select a location into which to open the recalled memory.

4. Mark Show on Recall to display the trace on the grid.

5. Touch Recall Now!

Recall Waveform From File

1. Touch File.

2. Touch Recall files from directory and enter the path to the waveform folder, or touch Browse
and navigate to the folder.

3. Use the Up /Down Arrows to cycle through the available files until the desired file is selected.

Optionally, touch Show only files to apply a search filter (channels, math functions, or memory)
to the list of available files. 

Note: The filter only applies to the files that will appear in the "Next File Will Be
Recalled From..." list. It does not impact the Browse function.

4. Mark Show on Recall to display the trace on the grid.

5. Touch Recall Now!
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Save Table Data
The Save Table function saves tabular measurement data displayed on screen to an Excel or ASCII
file. By default, files are saved in D:\...\Tables, although you can choose another location.

Access the Save Table dialog by choosing File > Save Table from the menu bar.

1. Leave the default Source selection All Displayed.

2. Optionally touch Table Title and enter a new root file name.

Caution: Numbers you place at the end of this name are truncated because the
instrument appends a sequence number to each file. Place numbers at the beginning,
or place an alpha character after the number (e.g., XYZ32a).

3. Touch Data Format and choose from ASCII (.txt) or Excel (.csv) format.

4. If you selected ASCII format, also touch Delimiter and choose a character.

5. In Save Files in Directory, touch Browse and navigate to the desired folder. Select it and touch
OK.

Tip: If the instrument is networked, you can touch Save Files in Directory and enter the
full Windows network address of another location in which to save the file. The
instrument must have access to this directory.

6. On the Save Table dialog, touch Save Now!
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Auto Save
Data that appears on the oscilloscope display, such as waveforms, measurement readouts and
decoder data, can be very dynamic and difficult to read from the oscilloscope unless you stop the
acquisition.

The Auto Save enables you to automatically store waveform and table data to a file that can be
recalled to the oscilloscope later or saved permanently to external storage.

To automatically save data to a file after each new trigger, choose an Auto Save option on the Save
Waveform and Save Table dialogs: Wrap (old files overwritten) or Fill (no files overwritten).

Caution: If you have frequent triggers, it is possible you will eventually run out of storage
space. Choose Wrap only if you're not concerned about files persisting on the instrument. If
you choose Fill, plan to periodically delete or move files off the instrument.

By default, waveform files are stored in D:\Waveforms and tables are stored in D:\Tables on the
instrument hard drive.
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Utilities
Utilities settings primarily control the instrument's interaction with other devices/systems.

Preferences settings, on the other hand, tend to control the appearance and performance of the X-
Stream application. Use these settings to personalize the behavior of the instrument.

Disk Utilities enable you to perform commonplace Windows file functions. They are also accessible
from the File menu.

Utilities
To access the Utilities dialogs, choose Utilities > Utilities Setup... from the menu bar.

HardCopy Setup, Date/Time Setup, and System Status buttons open their corresponding dialogs, as
do the tabs.

There are also tabs linking to Remote Control, Auxilliary Output, and Options settings.

Note: Hardcopy Setup controls the behavior of the Print function. The selected print output
device or application is displayed to the right of the HardCopy Setup button for convenience.

Show Windows Desktop minimizes the X-Stream application window. Maximize the application by
touching the display icon located at the lower-right of the desktop.

Touch-Screen Calibration launches a sequence of display calibration screens. You will be prompted
through a series of actions to improve the precision and accuracy of the touch screen.

The Service button to the far right of the dialog launches a section of the application reserved for
qualified Teledyne LeCroy service personnel. An access code is required to enter this section.

Status
The Utilities Status dialog displays information about your instrument including model number, serial
number, firmware version, and installed hardware and software options.

Choose Utilities > Utilities Setup from the menu bar, then touch the Status tab.
Or
Choose Support > About from the menu bar.
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Remote Control
The Remote dialog contains settings to configure remote control of the instrument and also network
access. Supported remote control protocols are:

l TCPIP (Ethernet). If you choose this option, also install Teledyne LeCroy's VICP drivers on the
controller. These are included in the VICP Passport plug-in, available free from
teledynelecroy.com/support/softwaredownload under Oscilloscope Downloads > Software
Utilities. The instrument uses Dynamic Host Configuration Protocol (DHCP) as its default
addressing protocol. You can assign a static IP address using the standard Windows network
setup menus.

l LXI (Ethernet)

l USBTMC (USB 3.1 Gen1). This option will not appear until activated. To activate, connect a
cable to the USBTMC port on the side of the oscilloscope.

l GPIB. This selection is only active if the instrument has the GPIB hardware option installed.
Connect the controller to the GPIB port.

Set Up Remote Control

Note: Full remote control setup requires the installation and configuration of software on the
controller, as well. These steps represent only what is done on the instrument. See the
Remote Control manual for your model for an explantion of the complete process.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. On the Remote dialog, make a Control From selection.

3. If using TCPIP and wish to restrict controller privileges to specific network clients, touch Yes
under Security. Enter the IP addresses or DNS names of the authorized controllers in a comma-
delimited list.

Configure the Remote Control Assistant Event Log
The Remote Control Assistant monitors communication between the controller and instrument. You
can log all events or errors only. The log can be output to an ASCII file and is invaluable when you are
creating and debugging remote control programs.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. Under Remote Control Assistant, touch Log Mode and choose Off, Errors Only, or Full Dialog.

3. To always clear the log at startup, check Reset to Errors Only and clear at startup.
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Export Contents of the Event Log

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. Touch the Show Remote Control Log button. The Event Logs pop-up is shown.

3. Enter a log file name in DestFilename, or touch Browse and navigate to an existing file.

Note: New contents will overwrite the existing content; it is not appended.

4. Touch Export to Text File.

Hardcopy (Print)
Hardcopy settings control how the Print function behaves. Print captures an image of the touch
screen display, but there are several options as to what it does next with the image, which is
configured on the Utilities Hardcopy dialog. You can further set up a default print color scheme and
capture area. A preview of your hardcopy setup appears to the right of the dialog.

From the menu bar, choose Utilities > Utilities Setup > Hardcopy to display the Hardcopy dialog.

Send to Printer

Add Printer

Note: Any printer compatible with the instrument's Windows OS is supported. Minimize the X-
Stream application and use the Windows controls to install printer drivers. Connect printers
via LAN (Ethernet) or USB.

1. On the Utilities Hardcopy dialog, choose Printer.

2. Touch the Add Printer button that appears. A Microsoft Windows Devices and Printers window
opens where you can configure a new printer.

3. To make the printer the instrument default, select it from the Select Printer list.

Print Setup

1. On the Hardcopy dialog, choose Printer.

2. Touch Select Printer and choose a printer from the list. If you don't see the printer you want,
first follow steps to Add Printer.

3. Choose a page Orientation: portrait or landscape.
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4. Optionally, choose a color scheme and hardcopy (print) area.

5. Optionally, touch Properties to open the Windows print dialog and adjust printer properties.

Print to File
Image files can be saved to any folder on the instrument hard drive, or to an external drive connected
to a USB port.

1. On the Hardcopy dialog, choose File.

2. Choose the output File Format.

3. Enter a File Name. This will form the basis of all print filenames, until you change it.

Caution: Numbers you place at the end of the filename will be truncated, as the
instrument appends a sequence number to this name with each new file. If you wish to
add your own identifying numbers, place them at the front of the name.

4. Optionally, enter the path to a new save Directory, or touch the Browse button and navigate to
the folder.

Note: The default print folder is D:\Hardcopy. Other types of files that may be saved
using other functions, such as masks and scripts, have their own X-Stream subfolders.

5. Optionally, choose a color scheme and hardcopy (print) area.

Copy to Clipboard
This procedure copies the screen to the clipboard so you can paste it into another application
(Microsoft Word, for example).

1. On the Hardcopy dialog, choose Clipboard.

2. Optionally, choose a color scheme and hardcopy (print) area.

Send to E-Mail
Follow this procedure to e-mail capture files to a preset address. The e-mail connection is set up in
Utilities > Preferences Setup > E-Mail.

1. On the Hardcopy dialog, choose E-Mail.

2. Choose the output File Format.

3. If you wish to be able to include messages with the files as they are sent, check Prompt for
message to send with mail.

4. Optionally, choose a color scheme and hardcopy (print) area.

5. To go on and set up the e-mail connection, touch Configure E-Mail Server and recipient.
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Create LabNotebook Entry

1. On the Hardcopy dialog, choose LabNotebook.

2. Touch LabNotebook Preferences and set up your notebook preferences.

Choose Print Color Scheme
To change the color of your print output, touch the Color button on the Hardcopy dialog and choose
from:

l Standard (default) - prints objects on a black background, as they appear on the display.

l Print - prints objects on a white background using your chosen colors. This option saves ink.

l Black & White - prints objects in grayscale.

Note: The colors used to represent channels in Standard and Print schemes are configured on
the Preferences Colors dialog.

Set Print Area
To limit which part of the touch screen is captured, touch Hardcopy Area on the Hardcopy dialog and
choose from:

l Grid Area Only - omits dialogs and menus and prints only the grids.

l DSO Window - prints the dialogs with the grids.

l Full Screen - prints the entire touch screen.

Drawing Tools
To open the drawing toolbar to mark up each new capture as it is saved, select Annotate Before Print.
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Auxiliary Output
Use the Aux Output dialog to configure the output of the Aux Out port and Cal Out port.

Auxiliary Output
Trigger Enabled sends a pulse when the trigger is ready (Ready indicator lit), but not necessarily fired.
It can be used as a gating function to trigger another instrument. Enter the desired pulse Amplitude.

Trigger Out sends a pulse when the trigger fires (Trig'd Indicator lit). Enter the desired pulse
Amplitude.

Pass/Fail generates a pulse when Pass/Fail testing is active and conditions are met. Enter the
desired Pulse Duration.

Fast Edge provides a fast edge signal that can be used to deskew multiple channels.

Off disables auxiliary input/output.

Calibration Output
Choose the signal to be output from the Cal Out hook on the front of the instrument:

l Square wave signal. Enter the wave Frequency and Amplitude into 1 MΩ, or choose to Set to 1
kHz, 1 V Square Wave.

l Reference DC Level. Enter an Amplitude into 1 MΩ.

Off disables calibration output.
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Date/Time
Date/Time settings control the instrument's timestamp. These numbers appear in the message bar
and on tables/records internal to the X-Stream application, such as History Mode and WaveScan.

To access the Date/Time dialog, choose Utilities > Utilities Setup from the menu bar, then touch the
Date/Time tab.

Manual Method
Enter the Hour, Minute, Second, Day, Month, and Year, then touch the Validate Changes button.

Internet Method
This method uses the Simple Network Time Protocol (SNTP) to read the time from time-a.nist.gov.
The instrument must be connected to an internet access device through a LAN (Ethernet) port.

If your connection is active, touch the Set from Internet button.

Windows Method
To set date and time using the internal Windows system clock, touch the Windows Date/Time button.
This displays the standard Windows Date and Time Properties pop-up dialog, where you can further
configure these settings. If you are satisfied with the setup, just touch OK.
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Options
Many optional software packages are available to extend the Analysis functions of the
instrument. When you purchase an option, you will receive a key code by email that activates the new
functionality. Use the Options dialog to activate software options by installing the key code. This
dialog also displays the ScopeID and Serial #.

To install a key:

1. From the menu bar, choose Utillities > Utilities Setup, then touch the Options tab.

2. Touch Add Key. The Virtual Keyboard appears onscreen.

3. Use the VIrtual Keyboard to type the Key Code in the Enter Option Key field, then touch O.K. on
the keyboard to enter the information.

The Key Code is added to the list of Installed Option Keys. You can use the Up/Down buttons to
scroll the list. The software option that each key activates is displayed below the list.

4. Restart the X-Stream application: choose File > Shutdown, then double-click the Start DSO icon
on the desktop.
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Disk Utilities
Use the Disk Utilities dialog to manage files and folders on your instrument's hard drive. Disk Space
information is shown at the far right of the dialog for convenience.

Note: These tasks can also be accomplished using the standard Microsoft Windows file
management tools. Choose File > Minimize to access the Windows desktop and task bar.

Access the Disk Utilities dialog by selecting Utilities > Disk Utilities from the menu bar, or choose
any of the Save/Recall functions and open the Disk Utilities tab.

Delete a Single File

1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. Browse to the file to be deleted, or use the Up and Down arrow buttons to scroll through the
files in the folder.

4. With the desired file selected, touch Delete File.

Delete All Files in a Folder

1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. With the desired folder selected, touch Empty Folder.

Create a New Folder

1. Touch Create.

2. Touch Current folder and provide the full path to the new folder, including the folder name.

3. Touch Create Folder.
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Preferences
Preference settings have mostly to do with the appearance and performance of the instrument itself,
rather than its interaction with other devices/systems.

To change LabNotebook application preferences, see LabNotebook Preferences.

Access the Preferences dialogs by choosing Utilities > Preference Setup... from the menu bar.

Audible Feedback controls the instrument's audio output. Select this box to hear a beep each time
you touch a screen or front panel control.

Language sets the language used on the touch screen display.

Font Size changes the size of the text that appears on the touch screen display.

Performance settings let you optimize performance for either Analysis (speed of acquisition and
calculation) or Display (speed of update/refresh). For example, if you are concerned with persistence
or averaging, you might optimize for Analysis, giving higher priority to waveform acquisition at the
expense of display update rate. Choices are presented as a spectrum.

There are also tabs linking to Calibration, Acquisition, E-Mail, Color, and Miscellaneous settings.
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Acquisition Preferences
The Acquisition preference settings determine how traces behave as Vertical Offset or Horizontal
Delay changes. To access them, choose Utilities > Preference Setup and open the Acquisition dialog.

Offset Setting constant in:

l Volts moves the Vertical Offset level indicator with the actual voltage level.

l Div(isions) keeps the Vertical Offset level indicator stationary. The waveform remains on the
grid as you increase the gain; whereas, if Volts is selected, the waveform could move off the
grid.

Delay Setting constant in:

l Time moves the Horizontal Delay indicator relative to the 0 point at the center of the grid.

l Div(isions) keeps the Horizontal Delay indicator stationary. The trigger point remains on the
grid as you increase the timebase; whereas, if Time is selected, the trigger point could move
off the grid.

Note: The Offset value is always in the vertical unit, and the Delay is always in time. However,
whenever Div is selected, these values are scaled proportional to the change in gain or
timebase, thereby keeping the division of the grid constant.

Reset trigger counter before starting a new acquisition is selected by default. It clears the trigger
counter each time a new acquisition command is sent. It is only made active for deselection when
trigger Holdoff is set.

Calibration
Calibration ensures that the output from the analog-to-digital converters (ADCs) accurately represents
the input. The instrument is calibrated at the factory prior to shipment. So that it maintains specified
performance, it is factory set to perform an automatic calibration routine upon start-up and whenever
conditions warrant it, based on your automatic calibration selection.

Warm up the oscilloscope for at least 10 minutes prior to use to give the instrument time to complete
the automatic calibration procedure. You will see a warning message on the Calibration dialog when
the oscilloscope is still in the warm-up phase.

157



WaveRunner 8000 Oscilloscopes Operator's Manual

Automatic Calibration
You have the option of selecting the automatic calibration routine used. Go to Utilities > Preference
Setup > Calibration.

Stored Calibration (the default selection) uses cached calibration files to recalibrate the instrument
at start-up. As long as the oscilloscope is used at or near sea level within a temperature range of 19-
30 °C, this calibration routine should be sufficient to maintain specified performance. The instrument
will dynamically recalibrate if the temperature goes outside of the stored calibration range. If you
know you will be operating outside this temperature range, do a Calibrate All to minimize
recalibration.

The Dynamic Calibration routine recalibrates the oscilloscope at start-up and every time there is a
change in any of the acquisition settings that directly affect the performance of the ADCs, in
particular Vertical Scale, Coupling, Bandwidth, Attenuation, and Horizontal Scale. This can cause
interruptions during operation, but ensures absolute accuracy within the current operating
environment at every setting. When one setup is calibrated at a particular ambient temperature, the
calibration is entered in a calibration table and reused for the duration of the session, so that over
time the frequency of recalibration decreases. These calibration entries persist only for a single
session; Dynamic Calibration restarts when the instrument is restarted or you change the principal
acquisition settings.

Manual Calibration
Two manual calibration routines can be used to recalibrate immediately before sensitive
measurements or when there is a significant change of environmental characteristics that could
affect the performance of the ADCs.

Go to Utilities > Preference Setup > Calibration to manually invoke calibration.

Caution: Remove all inputs from the oscilloscope prior to manual calibration.

Calibrate Current State calibrates at the current vertical and horizontal settings. This calibration
takes 5 seconds but is valid for only this setup at the current temperature ±2.5 °C.

Calibrate All calibrates all possible combinations of vertical and horizontal settings. This calibration
is valid for the current temperature and takes about four to five hours. Perform it when the ambient
temperature is stable from the time of calibration to the time of operation.

We recommend that you run Calibrate All when:

l The instrument is operating outside the 19-30 °C range and the operating temperature changes
while outside that range. Calibrate All is only valid for ± 2.5 °C of the last calibration
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temperature when operating outside of the 19-30 °C range.

l The instrument is moved to a new operating environment.

l It has been six months since the previous manual calibration.

E-Mail
Use the E-mail dialog settings to configure e-mail on the instrument.

Under E-Mail Server, select the protocol used by your network:

l MAPI (Messaging Application Programming Interface) is the Microsoft interface specification
that allows different messaging and workgroup applications (including e-mail, voice mail, and
fax) to work through a single client, such as the Exchange client. MAPI uses the default
Windows e-mail application.

l SMTP (Simple Mail Transfer Protocol) is a TCP/IP protocol for sending messages from one
computer to another through a network. This protocol is used on the Internet to route e-mail. In
many cases no account is needed.

Under Configuration:

l If you chose SMTP, touch SMTP Server and enter the network address of your mail server.

l Touch Originator Address (From:) and enter the instrument's e-mail address.

l Touch Default Recipient Address (To:) and enter the recipient's e-mail address.

Use Send Test Mail to send a confirmation message to ensure proper e-mail configuration.
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Color
Color dialog settings assign the colors used for channel, math, and memory traces. All dialogs, tables,
and trace descriptor boxes will match the color of the trace assigned here. You can choose different
colors to be used on the instrument and in print.

For convenience, you can Preview print colors to see how the settings will appear in print output.

Note: Print colors are used only when the Colors control is set to Print on the Hardcopy dialog
in Utilities > Utilities Setup.... Otherwise, the Screen colors are used for print output as well as
on screen.

To make any setting, just touch the color swatch for either Screen or Print next to the trace number,
and make a selection from the Color pop-up menu.

Touch Factory default colors to recall the original color settings for your instrument.
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Miscellaneous
These other Preference settings are located on the Miscellaneous dialog.

To add the Teledyne LeCroy logo to print output, check Print Teledyne LeCroy Logo When Printing Grid
Area Only. This identifies the instrument as the source of the image.

You can adjust zoom behavior as follows:

l Dimming darkens/shades those areas of the source waveform that are not part of the Zoom
trace.

l Control Sensitivity adjusts the sensitivity of the front panel knobs. Optimized applies an
acceleration algorithm to the knobs. Legacy detects rotation of the front panel knobs in a
manner similar to our legacy oscilloscopes.

Serial Decode Annotation Position: If you have Serial Trigger or Decode options installed on your
instrument, this control determines the placement of annotation labels relative to the trace line. It
does not appear if there are no installed options.

l On Trace places the label close to the line.

l On Noisy Trace sets the label further from the line to accommodate potential noise spikes in
the trace.

Check Enable HTTP Screen Capture to enable remote capture of the touch screen display over a
netowrk. This setting is required to use the instrument with the WaveStudio software.
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Maintenance
Topics in this section describe procedures for keeping the instrument in optimal working condition.

Touch Screen Calibration
Periodically calibrate the touch screen to maintain its accuracy and responsiveness. We recommend
that you use a stylus rather than your finger for this procedure.

1. From the menu bar, choose Utilities > Utilities Setup.

2. On the Utilities main dialog, touch Touch-Screen Calibration.

3. Following the prompts, touch as close as possible to the center of each cross that appears on
the screen until the calibration sequence is complete.

Restart/Reboot Instrument
To restart the X-Stream application, choose File > Exit from the menu bar, then touch the Start DSO
desktop shortcut.

Note: You will generally need to exit and restart the application after adding new options keys.

To reboot the instrument, which includes restarting the OS:

1. From within the X-Stream application, choose File > Shutdown from the menu bar. From the
Windows desktop, use the Windows Start Menu Shutdown command.

2. Wait 10 seconds, then press the Power button on the front of the instrument.
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X-Stream Firmware Update
Teledyne LeCroy frequently releases free firmware updates for X-Stream model instruments
containing new product features and bug fixes. The X-Stream installer updates multiple components
including the base application, required DLLs, drivers, and low-level microcode for integrated circuits.

The firmware update procedure does not modify or delete any saved panel setups, waveforms, screen
captures, calibration constants, or other data stored on the D: drive.

Caution: The installation may take several minutes, depending on the length of time since
your last update. Do not power down at any point during the installation process.

1. Exit the X-Stream application by choosing File > Exit.

2. Visit our download page at teledynelecroy.com/support/softwaredownload and click the link to
Oscilloscope Downloads > Firmware Upgrades.

3. Select your series and model number.

4. Enter your registration login information, or create a new account.

5. Click the download link, and choose to Save the installer to the instrument Desktop or a folder
on the D: drive. If downloading from a remote PC, save the installer to a USB storage device to
transfer it to the instrument.

6. Browse to the location of the installer (xstreamdsoinstaller_x.x.x.x.exe) and double-click it to
launch the X-Stream Setup wizard.

7. On the wizard, click Next, then read the EULA and click I Agree.

8. Leave the default installation (recommended), or select individual components:

l Drivers for GPIB1 - required for internal PCI-GPIB card.

l MATLAB MCR - required for sampling scopes, QPHY-USB and QPHY-Broad-R-Reach.

l X-Stream DSO, DSO Device drivers, Upgrade DSO Microcode - required for a version
upgrade.

l Touch Screen Driver - required to use the display as a touch screen (you can opt to use
a mouse).

l SPARQ Package - required to drive a connected SPARQ from the instrument.

Click Install when done.

9. If you receive Windows security warnings, trust and Install the file. If you see the Hardware
Programmers screen, accept all code installations, then click Close to return to the X-Stream
Setup wizard.

10. When installation is complete, choose Reboot now and click Finish.
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Technical Support

Phone
Registered users can contact their local Teledyne LeCroy service center at the number listed on our
website. For a complete list of sales and service center by country, visit
teledynelecroy.com/support/contact.

Web
Teledyne LeCroy publishes a free Technical Library on its website. Manuals, tutorials, application
notes, white papers, and videos are available to help you get the most out of your Teledyne LeCroy
products.

The Datasheet published on the product page contains the detailed product specifications.

You can also submit Technical Support requests via the website at
teledynelecroy.com/support/techhelp.
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Returning a Product for Service
Contact your local Teledyne LeCroy service center for calibration or other service. If the product
cannot be serviced on location, the service center will give you a Return Material Authorization (RMA)
code and instruct you where to ship the product. All products returned to the factory must have an
RMA.

Return shipments must be prepaid. Teledyne LeCroy cannot accept COD or Collect shipments. We
recommend air-freighting. Insure the item you’re returning for at least the replacement cost.

1. Remove all accessories from the device. Do not include the manual.

2. Pack the product in its case, surrounded by the original packing material (or equivalent).

3. Label the case with a tag containing:
l The RMA
l Name and address of the owner
l Product model and serial number
l Description of failure or requisite service

4. Pack the product case in a cardboard shipping box with adequate padding to avoid damage in
transit.

5. Mark the outside of the box with the shipping address given to you by Teledyne LeCroy; be sure
to add the following:

l ATTN: <RMA code assigned by Teledyne LeCroy>
l FRAGILE

6. If returning a product to a different country:
l Mark the shipment as a "Return of US manufactured goods for warranty

repair/recalibration."
l If there is a cost for the service, list the cost in the Value column and the original

purchase price "For insurance purposes only."
l Be very specific about the reason for shipment. Duties may have to be paid on the value

of the service.

Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne
LeCroy sales representative to purchase a service plan.
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Service Centers
Our regional service centers are:

World Wide Corporate Office
Teledyne LeCroy
700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977, USA
teledynelecroy.com
Sales and Service:
Ph: 800-553-2769 / 845-425-2000
FAX: 845-578-5985
contact.corp@teledynelecroy.com
Support:
Ph: 800-553-2769
support@teledynelecroy.com

US Protocol Solutions Group
Teledyne LeCroy
3385 Scott Boulevard
Santa Clara, CA, 95054, USA
teledynelecroy.com
Sales and Service:
Ph: 800-909-7211 / 408-727-6600
FAX: 408-727-0800
protocolsales@teledynelecroy.com
Support:
Ph: 800-909-7112 / 408-653-1260
psgsupport@teledynelecroy.com

European Headquarters
Teledyne LeCroy SA
4, Rue Moïse Marcinhes
Case postale 341
1217 Meyrin 1
Geneva, Switzerland
teledynelecroy.com/europe
Ph: + 41 22 719 2111
FAX: + 41 22 719 2230
contact.sa@teledynelecroy.com

China
LeCroy Corporation Beijing
Rm. 2001, Unit A, Horizon Plaza
No. 6, Zhichun Road, Haidian Dist.
Beijing 100088, China
www.lecroy.com.cn
Sales:
Ph: 86-10-82800318/0319/0320
FAX:86-10-82800316
Marketing.China@teledynelecroy.com
Service:
Rm. 2002
Ph: 86-10-82800245
Service.China@teledynelecroy.com

Korea
Teledyne LeCroy Korea
10th fl. 333 Yeongdong-daero
Gangnam-gu
Seoul 135-280, Korea
teledynelecroy.com/korea
Ph: ++ 82 2 3452 0400
FAX: ++ 82 2 3452 0490

Japan
Teledyne LeCroy Japan
3F, Houbunshafuchu Bldg.
3-11-5, Midori-cho, Fuchu-Shi
Tokyo 183-0006, Japan
teledynelecroy.com/japan
Ph: + 81-42-402-9400
FAX: + 81-42-402-9586

For a complete list of offices by country,
including our sales & distribution partners, visit
teledynelecroy.com/support/contact.
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Certifications
Teledyne LeCroy certifies compliance to the following standards as of the time of publication. See
the EC Declaration of Conformity document shipped with your product for the current certifications.

EMC Compliance
EC Declaration of Conformity- EMC
The instrument meets the intent of EC Directive 2014/30/EU for Electromagnetic Compatibility.
Compliance was demonstrated to the following specifications listed in the Official Journal of the
European Communities:

EN 61326-1:2013, EN 61326-2-1:2013 EMC requirements for electrical equipment for measurement,
control, and laboratory use. 1

Electromagnetic Emissions:
EN 55011:2010, Radiated and Conducted Emissions Group 1, Class A 2 3

EN 61000-3-2/A2:2009 Harmonic Current Emissions, Class A

EN 61000-3-3:2008 Voltage Fluctuations and Flickers, Pst = 1

Electromagnetic Immunity:
EN 61000-4-2:2009 Electrostatic Discharge, 4 kV contact, 8 kV air, 4 kV vertical/horizontal coupling
planes 4

EN 61000-4-3/A2:2010 RF Radiated Electromagnetic Field, 3 V/m, 80-1000 MHz; 3 V/m, 1400 MHz - 2
GHz; 1 V/m, 2 GHz - 2.7 GHz

EN 61000-4-4/A1:2010 Electrical Fast Transient/Burst, 1 kV on power supply lines, 0.5 kV on I/O
signal data and control lines 4

EN 61000-4-5:2006 Power Line Surge, 1 kV AC Mains, L-N, L-PE, N-PE 4

EN 61000-4-6:2009 RF Conducted Electromagnetic Field, 3 Vrms, 0.15 MHz - 80 MHz

EN 61000-4-11:2004 Mains Dips and Interruptions, 0%/1 cycle, 70%/25 cycles, 0%/250 cycles 4 5

1. To ensure compliance with all applicable EMC standards, use high quality shielded interface cables.
2. Emissions which exceed the levels required by this standard may occur when the instrument is connected to a test object.
3. This product is intended for use in nonresidential areas only. Use in residential areas may cause electromagnetic

interference.
4. Meets Performance Criteria “B” limits of the respective standard: during the disturbance, product undergoes a temporary

degradation or loss of function or performance which is self-recoverable.
5. Performance Criteria “C” applied for 70%/25 cycle voltage dips and 0%/250 cycle voltage interruption test levels per

EN61000-4-11.

European Contact:*
Teledyne LeCroy Europe GmbH
Im Breitspiel 11c
D-69126 Heidelberg
Germany
Tel: + 49 6221 82700
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Australia & New Zealand Declaration of Conformity– EMC
The instrument complies with the EMC provision of the Radio Communications Act per the following
standards, in accordance with requirements imposed by Australian Communication and Media
Authority:

AS/NZS CISPR 11:2011RadiatedandConductedEmissions, Group1, Class A.

AUSTRALIA / NEW ZEALAND CONTACTS:*
RS Components Pty Ltd.
Suite 326 The Parade West
Kent Town, South Australia 5067

RS Components Ltd.
Unit 30 & 31 Warehouse World
761 Great South Road
Penrose, Auckland, New Zealand

*Visit teledynelecroy.com/support/contact for the latest contact information.

Safety Compliance
EC Declaration of Conformity– Low Voltage
The instrument meets intent of EC Directive 2014/35/EU for Product Safety. Compliance was
demonstrated to the following specifications as listed in the Official Journal of the European
Communities:

EN 61010-1:2010 Safety requirements for electrical equipment for measurement, control, and
laboratory use – Part 1: General requirements

EN 61010-2:030:2010 Safety requirements for electrical equipment for measurement, control, and
laboratory use – Part 2-030: Particular requirements for testing and measuring circuits

The design has been verified to conform to the following limits put forth by these standards:

l Mains Power Supply Circuits: Overvoltage Category II, instrument intended to be supplied from
the building wiring at utilization points (socket outlets and similar).

l Measuring Circuit Terminals: No rated measurement category. Terminals not intended to be
directly connected to the mains supply.

l Unit: Pollution Degree 2, operating environment where normally only dry, non-conductive
pollution occurs. Temporary conductivity caused by condensation should be expected.

U.S. Nationally Recognized Agency Certification
The instrument has been certified by Underwriters Laboratories (UL) to conform to the following
safety standard and bears UL Listing Mark:

UL 61010-1 Third Edition – Safety standard for electrical measuring and test equipment.
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Canadian Certification
The instrument has been certified by Underwriters Laboratories (UL) to conform to the following
safety standard and bears cUL Listing Mark:

CAN/CSA-C22.2 No. 61010-1-12. Safety requirements for electrical equipment for measurement,
control and laboratory use.

Environmental Compliance
End-of-Life Handling

The instrument is marked with this symbol to indicate that it complies with the
applicable European Union requirements to Directives 2012/19/EU and 2013/56/EU on
Waste Electrical and Electronic Equipment (WEEE) and Batteries.

The product is subject to disposal and recycling regulations that vary by country and
region. Many countries prohibit the disposal of waste electronic equipment in standard
waste receptacles. For more information about proper disposal and recycling of your
Teledyne LeCroy product, please visit teledynelecroy.com/recycle.

Restriction of Hazardous Substances (RoHS)
This instrument and its accessories conform to the 2011/65/EU RoHS2 Directive.

ISO Certification
Manufactured under an ISO 9000 Registered Quality Management System.
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Warranty
THE WARRANTY BELOW REPLACES ALL OTHER WARRANTIES, EXPRESSED OR IMPLIED,
INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS, OR
ADEQUACY FOR ANY PARTICULAR PURPOSE OR USE. TELEDYNE LECROY SHALL NOT BE LIABLE
FOR ANY SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN CONTRACT OR
OTHERWISE. THE CUSTOMER IS RESPONSIBLE FOR THE TRANSPORTATION AND INSURANCE
CHARGES FOR THE RETURN OF PRODUCTS TO THE SERVICE FACILITY. TELEDYNE LECROY WILL
RETURN ALL PRODUCTS UNDER WARRANTY WITH TRANSPORT PREPAID.

The product is warranted for normal use and operation, within specifications, for a period of three
years from shipment. Teledyne LeCroy will either repair or, at our option, replace any product returned
to one of our authorized service centers within this period. However, in order to do this we must first
examine the product and find that it is defective due to workmanship or materials and not due to
misuse, neglect, accident, or abnormal conditions or operation.

The instrument’s firmware has been thoroughly tested and is presumed to be functional.
Nevertheless, it is supplied without warranty of any kind covering detailed performance.

Teledyne LeCroy shall not be responsible for any defect, damage, or failure caused by any of the
following: a) attempted repairs or installations by personnel other than Teledyne LeCroy
representatives or b) improper connection to incompatible equipment, or c) for any damage or
malfunction caused by the use of non-Teledyne LeCroy supplies. Furthermore, Teledyne LeCroy shall
not be obligated to service a product that has been modified or integrated where the modification or
integration increases the task duration or difficulty of servicing the instrument. Spare and
replacement parts, and repairs, all have a 90-day warranty.

Products not made by Teledyne LeCroy are covered solely by the warranty of the original equipment
manufacturer.

Intellectual Property
All patents pertaining to the WaveRunner 8000 can be found on our website at:

teledynelecroy.com/patents/

Windows License Agreement
The X-Stream application software runs on a Windows® operating system. Teledyne LeCroy's
agreement with Microsoft® prohibits users from installing third-party software that is not relevant to
measuring, analyzing, or documenting waveforms.
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Index
A
acquisition

optimiztion 156

pre-processing 18, 40

sampling mode 47

settings 157

action toolbar 20, 91

activating traces 27

altitude 2

analog inputs 10

attenuation 10

auto save 142, 145

auto zero 41

AUX connectors 14, 152

averaging 18, 40, 107, 109

B
backup 137, 140, 142, 145

bandwidth limiting 18, 39

C
cable de-embedding 40

calibration 2, 12, 152, 165

channel 38

descriptor box 18

frequency 10

setup 39

cleaning 2

clock

external 53

reference 53

sample 53

color 139, 160

compliance 167

cooling 2

copy function 108

coupling 10, 18, 39

cursor 77-78

controls 79

readout 19, 77

custom measurements 83

D
date and time 153

de-embedding 10, 40

degauss 41

delay 47, 157

post-trigger 47

pre-trigger 47

descriptor box 16, 18, 27

deskew 18, 40

deskew calibration 2

dialogs 19

differential time measurements 103

display 13, 68

controls 69, 161

extended 13, 71

grid 16, 71

optimization 156

persistence 75

DisplayPort 13
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E
e-mail 134-135, 139, 149, 159

EC compliance 167

EMC 167

enhanced resolution 40, 109

extended display 13

external monitor 13

external trigger 10

F
FFT 112

file structure 155

filtering

bandwidth 39

LabNotebook entries 134

measurements 84

noise 40, 109

firmware 12

update 163

version 147

Flashback Recall 132, 136

foreground trace 27

frequency 109

response 10, 112

front panel 161

G
gain 39, 157

gating measurements 84

GPIB 148

graphing measurements 91

grid 16, 56, 68

auto grid 68

intensity 73

style 68, 71

H
hard drive 137, 155

hardcopy settings 149

histograms 82, 91, 93

WaveScan 126

holdoff 63

horizontal

controls 47

humidity 2

I
import

.trc files 144

Labnotebooks 137

setup panels 141

inputs

analog 10

intensity

grid 73

interfaces 10

interleaving 48-49

interpolation 40, 113

inversion 18, 40

IP address 13, 148

L
labelling traces 30, 132-133, 139

LabNotebook 16, 132-134, 136-139
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language selection 14

logs

remote control event 148

M
markers 82

mask testing 127

math 104, 106

descriptor box 18

function setup 105

graphing 106

on parameters 86

operators 105

measurement trigger 62

measurements 80, 101-103

cursors 77

custom 83

filtering 84

gating 84

graphing 91, 95-96

histicons 82

list of 97

markers 82

pass/fail testing 127, 129

processing web 87

readouts 80

saving 145

statistics 82

measurements; status 80

memory 119-120

descriptor box 18

memory length 48

multi-grid display 68

multi-zoom 31

N
notebooks 132, 134, 137

O
offset 157

operating environment 2

optimization 156

options 12, 154

P
parameter compare 127, 129

parameter math 86

pass/fail testing 127, 129-130

persistence 75

histogram 93

WaveScan 125

position

trace 31

post-trigger delay 47

power

standby 12

pre-processing 18

pre-trigger delay 47

preferences 156

printing 13, 35, 134-135, 149, 161

probes 10

settings 41
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tip selection 41

processing web editor 87

Q
Q-Scape display 68-69

qualified measurements 84

R
real-time sampling mode 48

recall

LabNotebooks 136

setup panels 141

waveforms 144

reference clock 14, 53

remote control 13, 148, 161

reports 132, 135, 138-139

rescaling 40, 115

restart/reboot 162

restore

waveforms 120

returns 165

RH 2

RIS sampling mode 49

rise and fall time 102

RoHS 169

roll sampling mode 49

S
safety 1, 168

sample clock 14, 53

sample points 48, 114

sample rate 48-49

sampling mode 47

real-time 48

RIS 49

roll 49

sequence 50

save

data 132, 145

LabNotebooks 137

setup panels 132, 140

waveforms 119, 142

screen capture 35, 149

search 121, 134

sequence sampling mode 50, 74

serial triggers 63, 161

service 164-165

setup panels 132, 140-141

sin x 18, 40

software assisted trigger 65

software options 12, 154

sound 156

sparse function 114

support 164-165

system

hibernate 12

on/off 12

status 147

timestamp 153

T
technical support 164-165
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temperature 2

time parameters 102

timebase 47, 157

clock 53

controls 47

descriptor box 19

top and base 101

touch screen 13, 15

calibration 162

language 14

traces

3D 76

activating 28

color 160

copy 108, 119

descriptor boxes 18

label 30, 82, 132-133

line style 73

persistence 75

recall 132, 144

save 132, 142

turn on/off 28

track 91, 94-95

TRC files 119, 142, 144

trend 91, 94, 96

trigger 56

automating 66

controls 56, 58, 63

counter 63, 157

delay 47

descriptor box 19

holdoff 63

software assisted 65

time 48, 63

TriggerScan 66

TV trigger 62

U
UL compliance 168

undo 16

units 40, 115

utilities 147

V
vertical 38

controls 39

offset 39

resolution 109

sensitivity 38-39

W
waveform files 119, 142, 144

WaveScan 121

WaveStudio 161

WEEE 169

Windows

dialogs 14

networking 13, 140, 143, 145

power settings 12

X
XWEB 87

XY plots 74
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Z
zoom 25, 28, 31

controls 31, 161

descriptor box 18

multi-zoom 31

undo 16
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